Publishing grief post updates

Hi. I wondered if someone might be able to help me out with a recently developed problem with RW 8.8.3. Everything worked fine until I had two RW updates in rapid succession a short while ago and now my publishing uploads have stopped working. I didn’t do anything apart from do the two upgrades.

I have asked Aaron at Realmac and he thinks it might be something to do with certificates but I have asked at both the hosts I publish to and neither thinks it is an issue with certificates and the suggestion is that it is Rapid Weaver. That being because I can upload to either domain without a problem using Filezilla; I only have a problem with RW publishing.

You might say carry on with Filezilla but this means a long down time for the site to wipe and upload everything. I am doing quick tweaks almost daily for a fundraiser and it should take a few seconds and instead it will consume a large part of the night when I’d rather be in bed.

The problem on one server is that I get to the end of the upload and it throws up an error at the end. It says the “changes to your website have been published” but there is always one or two failures which keep cycling, trying to upload and failing. If I click on the “i” it says “Your sign-in details are incorrect, please reenter them and try again.” Now obviously my sign in details are correct or the changes would not be published. I have no idea which bits have not published; they are not obvious. A couple of weeks or so ago this problem was not there; never occurred.

The other server is the same but different and also more serious because it fails before the upload is complete. This time when I click on the “i” I get “FTP: unknown PASV reply. I can start publishing 120 files and it will get to 92 and stop. Then if I try again it will say I have 110 files to publish and again, somewhere in the nineties, it will stop. The next time I try it will say 108 files and will stop before it gets there. This is more serious as it is a charity website which is running an appeal and has needed frequent updates. Some of the fail messages have a heading saying “Couldn’t sign in to your FTP server” and some identify a file with long name which is different each time but also appears not to be a file.

The changes I have made and am uploading are basically just wording in existing sections. I have about thirty sites I administer and this happens with all the updates I have needed to do over the last week.

I have tried slowing down the desired speed of upload to 5 and then 4 and then 3 but it makes no difference. Obviously (but I know some will not believe me) the publishing information is correct and identical to the same ftp information in Filezilla, it has not been changed, deliberately or accidentally. The hosts don’t think it is something they have done and Realmac don’t think it is an RW issue, so I am stuck.

Mac OS 10.14.6
Rediweb
Andrews & Arnold

Hi,

Without more information, it’s going to be difficult to determine what might be causing the issue.

To start with could you post some screenshots of your publishing settings (both from RapidWeaver and Filezilla) along with screenshots of the message you are getting. Also, if you could share the name of the hosting company that you are using.

Might also go through all the steps in this knowledge base article, especially step 6 about getting the log files.

Hi Doug. Thanks for responding. It is a tricky one, not least because of all the variables but here goes.

Here below are the settings for both applications. Neither of these has changed. I have tried tweaking the speed up upload and I have tried changing the server ID to its numeric form and back to see if that helped. I also tried toggling between PASV and PASV extended but no difference.

The hosting companies are Rediweb for most and Andrews & Arnold for the one which does not complete. The former is the more featured host, the latter the simpler / more basic.

I have gone through the diagnostics with some care. They tend to be aimed at set up rather than a spontaneous ceasing of function but I am aware how frustrating it is to get cries for help from people who do not first try to help themselves. The upload logs are too large to send here and Aaron did not ask for them so I took no action on that front. There are three files amounting to just over 13mb for each host.

First the FZ settings which always work for both hosts with the same setup for different servers, so I’ll not show both lots:



Then the RW settings for a site hosted by AAISP, which worked fine until a couple of weeks ago, roughly:

Then for the Rediweb host:

With this one I find that if I leave it cycling it eventually gives up without indicating whether it is resolved.

I am out of ideas. As it affects all web sites and both servers the temptation is to assume the problem is not to do with new content or to do with the servers. Because it affects Rapid Weaver but not Filezilla, logic suggests it is peculiar to Rapid Weaver. If it is Rapid Weaver, the only changes to RW have been the two updates which immediately preceded the problem emerging. That said, I know that 99% of these problems are pilot error, which needs to be eliminated first. Especially if everyone else who has had the updates has not had a problem, which I assume is the case, though I have no idea how many of them are with people running Mac OS 10.14.6 (still running essential 32 bit sw).

Thanks for taking a look.

Drew

Drew,
I’m still using Mojave (10.14.6) and have had no problems with publishing. I use SFTP (SSH File Transfer Protocol) only though (I don’t even have standard FTP on any of my servers). I’m not saying that the FTP shouldn’t work, but SFTP is much more secure.

FTP is a fifty-year-old protocol and sends your login credential in the clear (not encrypted), but it should still work if you want to use it.

Since you are able to publish to a local folder without error, I would say it’s not the content on any of the pages that is causing the error.

I don’t have any direct experience with Rediweb host, but looking at their site, they have little as for self-help. The video is about it on hosting RW sites.

I have found nothing on AAISP as for the hosting company. Perhaps a URL to them would be helpful.

I would tackle them as separate problems, though. They are two different hosting companies and appear to be giving you two different errors.


The support logs can get quite large they seem to accumulate from each publishing. You can clear them first from the menu >help>clear support logs
2021-05-14_12-07-35
So I would do that first then publish to only one of the site giving you problems.

Then RealMac support (@Aaron, @dan, @tpbradley) can probably help you out from there.

1 Like

Hi

Andrews & Arnold will not work with SFTP for some reason, don’t know why: https://support.aa.net.uk/Category:Webhosting

To rule out if it is a new RapidWeaver issue, you can downgrade to an earlier version and see if it helps, go here; RapidWeaver Release Notes

If the issue persists then we know it’s something else causing the problem.

Do try removing the publishing settings completely and re-adding them, this sometimes helps.

Thanks,
Dan

Hi Dan

I reverted to 8.7 (pre publishing engine update) but it failed. I reduced the upload speed setting to 2 and it worked. I do not know why. The connection speed is unchanged and it uploaded fine on 5 for years hitherto.