Publishing issues


(Chris Wootton) #1

Hi there. Publishing problems for boreal theme rapid weaver. It may not be in my publishing settings as I checked them with Web HostingNZ (my host). I tried changing theme as well but no go.

Appears publishing settings ok. But published site lacks any formatting

E mail message from my hosting service says:
It seems your software isn’t publishing everything needed, for example your
code links to a file
http://twoview.co.nz/rw_common/themes/boreal/consolidated.css
Yet that file is not uploaded.

Probably an easy fix here …covered off before most likely…maybe someone can give me an easy pointer?
Excuse my ignorance…
Thank you
(I can’t put in a screen shot yet as I am a new user)

Path used is: http://public_html

But here is the site:

http://twoview.co.nz


(Nik Fletcher) #2

Try the File menu -> Re-Publish All Files

—N


(Chris Wootton) #3

Hi there just tried and it is the same. I switched themes as well but no difference.

Altered path to http://public_html

also tried http://twoview.co.nz/public_html

Each time I test connection and it is OK.

Runs through publishing process.

Same result. It says it has published (72 files) but the result is…what you see at two view.co.nz

Would it help if I could send further info? I can’t put an image in currently being a new user.

I’m not overly technically able on this front but have had past experience publishing under RW5 a few years back, no problem there. I am on RW6 now

Thanks for your help


(Chris Wootton) #4

Also I toggled publishing preferences to enable upload logging and adjusted concurrent uploads but no joy so far


(Mark Sealey) #5

CJW,

Many hosts have their docroot (the directory on the server into which all pages are put, but which never actually figures in a URL) as public_html, public-html or similar; some have ‘www’, for instance.

Have you tried putting the path as ‘/’?

Under some circumstances where this is the case you can end up fighting a permissions issue.

Which could also be the case if ‘rw_common/themes/boreal/consolidated.css’ isn’t publishing, or can’t be published/overwritten.

Have you got a File Manager or Control Panel - or better still ftp or ssh access to your docket?

If you keep a copy of everything you could try deleting all the files in all past failed publishes, and trying again from scratch.


(Chris Wootton) #6

OK I’ll try. I have control panel access (CPanel) via web hosting where I can see file directories from the upload. Again difficult to explain as I cannot attach a screenshot here being a new person.

I’ll try altering path settings again too.

Thanks for your suggestions


(Mark Sealey) #7

CJW,

Let us know how it goes.

Suggest:

First keep ing a backup of everything
Then deleting everything - ON THE SERVER
Then make sure that permissions on the server for public_html are 755
Then trying again

Good luck!


(Daniel) #8

@MarkSealey. Deleting everything on the server could have very bad side effects. I would suggest people only delete things inside the public_html folder on cPanel. Other folders behind deleted can have bad side effects ie, no emails.

CJW now has the problem resolved. For reference for anyone searching and finding this thread the path should be just public_html for most cPanel servers, not http://public_html

http://www.webhostingnz.com

Edit: fixed typo


(Chris Wootton) #9

Thanks Mark. (and Nik) I got to the bottom of it! Path issues.

public_html

instead of:

http://public_html

So simple. All resolved.
Now for some real work. Funk up the site.

www.twoview.co.nz

Cheers Chris


(Mark Sealey) #10

Oh that would certainly do it! ‘http://’ is not part of the directory name. Glad you fixed it. Good luck :slight_smile: