Publishing problem: Access denied to remote resource


(Carl) #1

I haven’t been able to publish since upgrading to RW 7. FTP connection seems to be fine - however, I can’t publish. Here is the error message via the log:
urrent directory is /public_html
CWD Alternative Resources Links_files
550 Can’t change directory to Alternative Resources Links_files: No such file or directory
MKD Alternative Resources Links_files
550 Can’t create directory: File exists
CWD Alternative Resources Links_files
550 Can’t change directory to Alternative Resources Links_files: No such file or directory
Server denied you to change to the given directory

Has anyone had this problem? I’ve tried:
-creating a new directory and uploading to that - same error
-changing the number of connections to the slowest
-changing the mode
-updated stacks and blocks

It’s been over 1 1/2 months since my communication with RW support and being unable to publish. I don’t know what “resources” it is referring to. There is a resources tab on the left in RW 7, but nothing within that tab / folder.

Any suggestions are welcome.


(Mark Sealey) #2

Carl,

One or two things spring to mind here - but I fear they may not in and of themselves be solutions. Particularly since, I agree, it’s unclear which ‘Resources’ object(s) is/are being referred to and failing:

1 - the actual directory name ‘Alternative Resources Links_files’ does have spaces; on Unix and Linux filesystems it is necessary to escape (with the backslash) the strings representing such directories when in use in (some) other contexts. That would be ‘Alternative\ Resources\ Links_files’. This might just possibly account for the MKD failure.

2 - if somehow the command, ‘CWD Alternative Resources Links_files’, is being issued - as it seems it may be from your log - for these Resources files, mightn’t this be falling outside the legal docroot at /public-html and so failing for that reason?

3 - even when you create (or RW creates) such a directory, might it be that you then still have to change the permissions to allow the directory (and, potentially, its subdirectories) to be written to - especially if it’s RW which is creating the directory/directories and another user (on the system) who/which is trying to write to them - and vice versa.

I’s day the first step is to find out somehow what the ‘Alternative Resources Links_files’ directory is and where it fits in.


(Carl) #3

Thanks for the suggestions Mark! I found that it wasn’t the “resources” in Rapidweaver, but pages that were corrupted in my website. I couldn’t change the html - it reverted, so I deleted the pages and it “published”. Now when I check the site, it gives a “possible phishing” problem, redirects to my email address and no updates are made. Any suggestions? Thanks!


(Mark Sealey) #4

Carl,

Glad you got one thing sorted out; but I’m sorry you have this second anomaly.

I wish I could help but don’t know your site’s construction enough to know what could be causing it. Good luck!