RW 7.0.1 Publishing fine but nothing gets uploaded


(Andrew Mason) #1

Just upgraded to RW 7.0.1 and now for some reason I cannot seem to publish.

When I make changes and click publish, the publish appears to go through fine and the support logs check out OK.

Problem is nothing at all gets written to the server. timestamps on the files on the server do not change.

I have tried this with two different sites and both display the same problem.

Anybody any ideas as currently I am unable to update or use RapidWeaver!


(Doobox Software) #2

I am wondering, are you looking at a specific .html file to be updated by the publish, or are you looking at a selection of files?

The reason I ask is that if you are maybe expecting a specific .html file to be changed, you may have added a stack to your page that requires php. Stacks that require php to function have the power to change your page extension from html to php, thus the next publish would be publishing to a new .php file on the server instead of the old .html file you expect to see a change in. Also the url for your page would change from www.someplace.html to www.someplace.php

Just a thought :slight_smile:


(Scott Steven) #3

This happens on OS X Server I finally figured out that you need to have a path all the way to the root of the hard drive and proceed it with a …/ like in the terminal window. Support has added this to the plist of things to look at but at least I know my whole path as I own my own server


(Andrew Mason) #4

Hi, I have done both a specific file and also a total republish. The connection is made and I can see at the network level the SSH connection being established but nothing is written to the server…


(Andrew Mason) #5

The path is fine, checked all variants but still unable to publish any files…


(Andrew Mason) #6

I have just tried to make a new folder on the server and publish to that. Just the same, everything in RW looks like it has worked but nothing at all on the server. Permissions are 100% fine.


RW 7 recent uploads
RW7 problem with publishing
(Andrew Mason) #7

Right, fixed it. It is due to the full path as ScottSteven kindly pointed out.

If your ssh user (obviously non root) has a home directory set then the path in RW7 now starts there rather than / where it has before.

so, /var/www/website translates to /home/userdir/var/www/website

You have to set the path in RW to …/…/var/www/website and then this works fine…

Hopefully this bug will get fixed soon!


(Nick) #8

Well that’s half an hour of my life I’ll never get back. :smirk:

Thanks masontech, I was ready to pull my hair out.

Really wish there had at least been an error message to indicate that something was going wrong…


(Scott Steven) #9

support is working on this. So we will have a fix soon enough.


(Thomas Hallgren) #10

Very nice to hear. Does this new path “feature” provide better compatibility with some new stacks or add ons? Just wondering why RW team would make this kind of change. Otherwise, really liking the update - very much. You guys have been putting in well-spent time. Great job!


(Thomas Hallgren) #11

Just spoke with Godaddy. Since I’m on a shared server, they can not give me the “home” but they could give me the user directory. Unfortunately, it does not work. No problem, waiting for the fix that brings things back on par with RW6. Till then will continue exporting the site and uploading through Fetch. Cheers.


(Don Matheson) #12

Having a similar issue. Website updates but links to files loaded as a resource produce result in a “Not Found” error. Can someone explain how to reset the path to get around this issue until it is fixed on RW7?


(Scott Steven) #13

its in the publishing section. there are also many solutions in the forum that are either dependant on the Hosting provider or in my case the operating system

need to know details like that before anyone can answer your question