Publishing to port 2510

My hosting platform requires that I publish to port 2510. How can i set this up in Rapidweaver?

When you enter the server setting in the publishing set up, try ftp.yourserver.com:2510. You’ll need to replace ftp.yourserver.com with your own server.

That you NeilUK. That was interesting, but it didn’t work.

Can you post a screenshot of your publishing settings?

in the server address have your tried 185.20.50.28:2510 ?

Oh and in screenshots I would advise hiding the login ID as that is one half of the data a hacker needs to get into your hosting. No idea what your password would be but password crackers can break passwords in seconds these days.

Thanks Nick,

I’ve deleted that now.
Yes, I have tried 185.20.50.28:2510 and it didn’t work.

Let’s see a screenshot of the publishing settings you are using with the port set.

Looking at the deleted screenshot, your using SFTP, which uses a pair of keys to authenticate so I wouldn’t worry much about password hackers. You’re much more secure than anyone that has straight FTP on the server.

If you’re having publishing problems and you have set the port correctly by using the sever name to

185.20.50.28:2510

Then the issue is not the port number. That’s the standard way to apply the port number to an address.

Go through the standard publishing debugging steps. And give use the usual information that is we need to help.

  • Name of the host
  • Screenshots of the publishing settings and the error message you are getting. (if you are paranoid about the user name then obscure just the user name).
  • tell us what happens with the test button
  • Try publishing with a standalone FTP app (Transmit, FileZilla, etc, etc) report back with a screenshot of the settings you used.

Hello Doug,
Please see the attached four screenshots.
1, FileZilla settings. This, or Cyberduck, both work which is why not having a port setting field in Rapidweaver is suspect.
2, Result when clicking on ‘Test’
3, Rapidweaver settings
4, Result when trying to publish. 'Browse gives a similar result.
Thanks for your help.

It looks like the credentials aren’t working.

Who are you hosting with?


If you can’t get past the test button, there is no point in trying publishing or anything else.

I know the port works in RapidWeaver (I just did a test). Adding the port after the colon : is the TCP/IP standard way of adding a port (Terminal commands like SSH port forwarding use this all the time).

Depending on how the host is set up, if you hit the test button and have the wrong port, a suitable host won’t respond at all. You’ll get this screen forever (until you hit cancel).
2021-01-08_11-12-43

If you have a successful test, you’ll get this screen:
2021-01-08_11-13-02

The test button on RapidWeaver simply tests the Credentials (Server name, username and password). So This may seem elementary, but have you tried re-entering that stuff (User name and password)?

Hello Doug,

It’s a long story.

I’ve created and maintained a few websites for my self and for businesses and other organisations that I’ve been associated with.

I’m a member of our local photography club. Our landlord is Sutton Coldfield Methodists who previously had a c**p website and I negotiated a discount on the club’s rent for looking after it. So I’ve inherited a site hosted by TSO (no, I hadn’t heard of them either).

I’m working on the local Methodists to change their provider, but it’s not due for renewal until next autumn.

End of story!

Best Regards,
Paul Stokes

So, it’s going to be Cyberduck for the time being.

Best Regards,
Paul Stokes