Publishing troubles


(Alan Lacer) #1

I am new to RW. Using latest version of RW. I have published the site, but now every time I publish it will not update the changes. I save after all changes, then hit publish. Also, how do you only publish one page that has changes–rather than entire site?


(Doug Bennett) #2

Might want to check out this

https://kb.realmacsoftware.com/article/1-how-to-fix-ftp-publishing-issues

If that doesn’t help then we will need a little more information from you on what is happening when you hit publish?
Maybe screen shots of your publishing settings, and what hosting company are you using.

To publish a single page, right click on the page in the left side bar, there is an option to publish page.


(Alan Lacer) #3

Thanks. I have read that article before. Here are a couple of screen shots. Everything says it is uploading, then I hit “visit” and it is always the older versions. I use Bluehost.
[[quote=“teefers, post:2, topic:13021, full:true”]
Might want to check out this

https://kb.realmacsoftware.com/article/1-how-to-fix-ftp-publishing-issues

If that doesn’t help then we will need a little more information from you on what is happening when you hit publish?
Maybe screen shots of your publishing settings, and what hosting company are you using.

To publish a single page, right click on the page in the left side bar, there is an option to publish page.
[/quote]

](http://)


(Lisa Sandler) #4

Can’t see screen shots,
Are you now using php files? Possible you need to delete the html files in order for the php to show up? Unless you need to republish all. Another option.


(Doug Bennett) #5

Alan,
As Lisa pointed out might be you changed something that switched your page to PHP from HTML.
Also could be your publishing to the wrong path.
Are you using cloudflare? If you are you need to login to cloudflare and refresh your cache.

Do you have a FTP program like transmit or forklift that you can check what got published? If not I’d guess bluehost has a file manager program you could to a look at what’s on the host.


(Alan Lacer) #6

Sorry, can you do a screen shot of the publish a single page–cannot get that as an option.


(Alan Lacer) #7

Went to BlueHost the confirm path is correct and no problems on their end. They indicated the publishing is incorrect from my RapidWeaver–and they don’t support that of course.

Nothing has changed from html or using ftp–worked a week ago to publish site. It runs through the publishing, but no changes are made–just the originally published site.

Thanks.


(Lisa Sandler) #8

What are the dates of the files in your Control Panel and File Manager? Again, you need to go into your host site for this.
Assuming you’ve cleared cache and all that. From what you’re saying, it is publishing, which leads me to believe you’ve got old folders and files on your server that need to be deleted.


(Doug Bennett) #9

I would as my next step do what Lisa indicated and check dates on you file manager from bluehost or an FTP program.

To publish a single page right click the page on the left side and select publish page.

If when you check with bluehost cPanel file manager the dates in your public_html have not changed and you are not getting any error message then they are more than likely not going to the right path.
If that is the case then I would try clearing the path in RW and select browse and find public_html and select it.

I never used iWeb but the bluehost site has a help section for setting up iWeb
https://my.bluehost.com/hosting/help/iweb
I understand that the setup is simular to RW. One thing I noticed is most of the help pages just show public_html as the path. Your screen shot has a bit more in front. That’s why I suggested clearing the path and browse.


(gary pullings) #10

change your connection speed to 1 slowest and that fixed it for me when I had issues. and remove backup.


(Lisa Sandler) #11

If he wasn’t able to publish, I’d say for sure do that. But I think he is able to.

@turnguy - What you might not understand, is that RW does not delete old files and pages. If you change page names, if you add stacks that use php, you need to go delete old files on the server itself. Otherwise you will not see the new pages/changes.


(Alan Lacer) #12

Tried the slowest speed and no backup–no change.

Changed the path to simply: public_html No change.

I don’t understand something: if I modify a page and publish it to my remote server RW does not take the newest version? I need another application to look at what is on the remote server (BlueHost in my case) and delete the older file (s)? Is this before or after I publish the new version of a page?


(gary pullings) #13

Is RW even connecting to your host? it is sounding like you had the file path correct and it wasn’t making any changes. When I went from 7.xx to 7.1x what ever we are now. I had to go into my server manually delete all the files there and republish all files once I did that, everything was gravy.


(Lisa Sandler) #14

All RW is doing is uploading… think of it as copying to a folder. It will replace any original files of the same name. What it will not do is take away old files, or rename old files.

You should have instructions from your host how to get into your Control Panel, then File Manager, on your server. Then you can look at the dates on your files (open folders) and see if your site is publishing.

You will also be able to see if you added a stack or plugin (such as a Contract Form or Blog page) that would change your page to php from html. In that case, as mentioned above, you would need to delete the html file in order for the php page to show.

You do not need another app or program if you know how to get into your server and see your File Manager and published files.


(Alan Lacer) #15

Thanks so much Lisa and Gary.
I have the same file names with some content changes–but it is always the same old content after publishing. Does RW change the contents of a file if a newer version is published AND with same name? I have also added new pages that do not appear when published–but do appear in preview.
The host indicated I need a third party program to view contents, so I am a bit confused with the host and RW–each seems to point to a problem with the other. Will return to BlueHost control panel and try again to see the files that are published.


(Lisa Sandler) #16

Once you see what’s going on with your files in the File Manager, it will be easier to see where the problem is. It does seem like it’s publishing, since you’re not getting an error. Since you tried a couple different locations, I would expect a couple of copies in different places on your server.
The 2 main questions are, 1) where? and 2) do you have old conflicting files that need to be cleaned up.
This is most likely what you will see in FM. You should be publishing into the public_html folder, but that’s dependent on your host.


(Lisa Sandler) #17

and, if your host is not helping, I’d consider moving to https://www.chillidoghosting.com, run by Greg @barchard, who is very active in the RW community and very helpful with support. I learned everything I know about how my files on the server work through him and using Chillidog.


(Doug Bennett) #18

Hey Alan,

Bluehost per their KB anyway has a file manager:
https://my.bluehost.com/hosting/help/file_manager

That should give a view just like Lisas screen shot above.

RW will change the contents of a file with the same name, but it will show that it modified by updating the Last Modified date. That’s why it’s important to get to the file manager to see if the updates have been applied

but how did you change it:

    /public_html 
     public_html/
    /public_html/

Those are all different locations on a file server.

That’s why I suggested above to clear your path in RW and select browse, choose the folder.


(Jason Bostick) #19

I have a site on bluehost that publishes fine. I can double check things when I get to my Rapidweaver computer if that helps.


(Jason Bostick) #20

Here’s my bluehost setup: