Can't publish updated pages

I’ve been having problems publishing PDF files, but now I can’t publishing edited content at all. I’ve gone to settings and done the test and it’s successful. Then I go to publishing and it opens the window to start exporting files, then immediately stops and an error pops up saying “Unable to Export”. I have a feeling this is going to be something pretty simple, but I’m missing it. On using a Mac OS 11.1 and I’ve updated RW to 8.9.1

Thanks, Rye

Hi Rye,

Without more information, it’s going too hard for anyone to help you out here.

With so many publishing settings, and even more hosting options we would need some basic information to start helping debug what’s going on.
To start

  1. Name of hosting company
  2. Screenshots of your publishing settings
  3. Screenshots of the message that you are getting

You can also have a look here

1 Like

Hosting company is Network Solutions.

Error message:

The link you sent to fix publishing issues, I checked all those no luck, and I did download the Support Logs. Would that help?

The unable to export message kind of leads me to think there might be something preventing Rapidweaver from generating the pages.

Have you tried publishing to a local folder?

That would be my first suggestion.

There might be something oN one of the pages that are causing this. If you can’t publish to a local folder then you’ll never publish remotely.

1 Like

Good suggestion, sounds like RapidWeaver might be choking on a file it can’t export…

What happens if you press on test or browse in the publishing options?

When I do the test in the settings it connectsScreen Shot 2021-07-20 at 12.03.09 PM

I have not tried that publishing to a folder. I’ll do that.

I updated to Version 8.9.1 (20881) today and immediately hit the same problem. Nothing in my publishing settings has changed and I don’t understand why I can’t up;oad my files.

I’ll be watching this thread with interest…

Eric (@FounDAry),

Publishing problems usually can be entirely different. Watching a thread about someone else’s publishing issue probably won’t solve your problem.

There are so many different variables like publishing method, hosting companies, etc, etc, that the likelihood that you and Rye (@Rye) are having the same problem is slight.

I’d suggest you go and have a look at the article linked above about solving publishing issues.

More than likely it has nothing to do with the update to RW 8.9.1, as a whole lot of people have taken this upgrade without issue.

If after you go through the kb article you still are having issues, then post back here on the forum with the information, Rye provided and someone will try and get you up and running again.

You can always roll back to a prior release.

…Well… I just remembered a previous experience of this and looked back into the subject.

Tried it and it worked just like it did the first time.

Full story here and I hope it helps…

I will be offline for a few days and will work on this and all your suggestions next week. I REALLY appreciate your help and hope to get this sorted out soon.

Regards, Rye

1 Like

Same problem here. After the update of Rapidweaver (now Rapidweaver has the last version) i’m unable to upload directly from Rapidweaver.
Publishing to a local-folder is working, and uploading via Cyberduck is also working.

Must be a error of Rapidweaver because i’ve changed nothing at all. Just try to republish my website.

1 Like

@jeepke ,
That’s probably an incorrect assumption. There are thousands of people using the latest version of Rapidweaver that took the same latest update and aren’t experiencing any problems publishing.

So what is your problem?

Impossible to say without more information.

For about 18 months ago I had, not exactly, but almost same problem.Every time I made a adjustment I had to exit RW and load again to publish. After reading topics here and trying different suggestions I found the problem at my hosting company - I was their server that cursed the problem. They put me on a newer and more stable - and then it all worked fine.
Well, as mentioned, it’s not quite same problem as topic, but just to give a reply.

I’ve had to put this issue not the back burning and I’m now trying to solve it again. I tried to export the site to a folder and got the same issue. It started to export then failed.

I should expand on this a bit. I tried exporting to a folder - failed. I also tried “Publish site to” - My Server and also “Publish site to” - Export Location. Both failed. So with this info I’m assuming it’s not going to be an issue with the host, Network Solutions. What else to try?

That would indicate that it’s something on the site that is probably causing the issue. Perhaps something in resources or on a particular page.

If you can’t publish to a folder then the whole FTP/SFTP process including the host is out of the picture.

You can try this:

  • keep the publishing set to go to a local folder
  • right-click on each page one at a time and select to publish the single page
  • that should narrow down to the page(s) that are causing the issue

You can also try and look at the logs. The article above tells you how to turn on logging, and you can clear and check the logs from the help menu.

1 Like