Rapid Cart Pro failing Checklist with valid credentials


(Brandon Scott Corlett) #1

Anyone have any issues setting up a RapidCart Pro store?

It says I’m failing the Stripe, Email, and Amazon S3. However, the in RW it can access Amazon S3, I know the email is valid, and the Stipe API key is accurate.


(Roberto Tremonti) #2

That’s because you are visiting your website using a web address that’s different from the one you have set in your RapidWeaver project. Possibly a www difference.
Please update your RapidWeaver Project web address accordingly and republish the page.


(Brandon Scott Corlett) #3

@rob, thank you for you reply.

I have my RW setting set to https://www.betastacks.com/

The RCP setting is asking for the page that me ‘store’ is embedded on which is https://www.betastacks.com/store

Does this mean that my store either has to be on the home page or I have to set the main URL to https://www.betastacks.com/store?

I have redirects setup so that it always direct to https://www.


(Brandon Scott Corlett) #4

@rob, so I tried both making the store the home page as well as changing the main URL to end in /store.

Neither resolved the issue.


(Roberto Tremonti) #5

You have set Stacks Store URL to http://www.betastacks.com/store/rcp/index.php in Customization > Settings > General window.
The page doesn’t exist.
Please set it to the stacks page that actually contains RapidCart Pro Store stack.


(Brandon Scott Corlett) #6

Hmm, that is interesting. I am 99% certain I’ve never entered that into the settings.

I just did a “republish all files” with the original setup I had when I posted my original post. (Depicted in the photos below)

After your first reply I changed the URL in the General setting of RW to be https://www.betastacks.com/store

After that did not work I changed it back and made the Store page my home page and set the RCP Stack store URL to https://www.betastacks.com/ and republished all files.

Perhaps I misunderstood your instructions.

Can you please confirm whether or not these settings should work?

NOTE: The images kept getting edited out.


(Roberto Tremonti) #7

I still see RapidWeaver Project web address set to http://www.betastacks.com without https.
You can see it in Info table at https://www.betastacks.com/store/?checklist

Please update RapidWeaver Project web address accordingly and republish the page.


(Brandon Scott Corlett) #8

I hadn’t noticed that as I kept I immediately scrolling down.

The url was correct in both places. The solution was having to check “force https protocol” and then republish all files.

I think I did this before but neglected to republish all files and just published the changes.

Thanks for your help @rob