8.1 > "This document uses files in multiple locations that Rapidweaver is unable to access"

Opening the upgraded file I get this message… then I replay (gently for now…:D) giving access to the whole hard disk or only to the folder that contains all the data of my website.
This message appear forever… uff

Try again with the right link this time:

From Realmac:
„we have a fix coming that will alleviate the resource access problems. The problem isn’t completely solved - we’re waiting on Apple for that.

Copying resources into a document will definitely work, the problem only occurs when referencing resources outside of the document. All new documents are set to copy by default.“

1 Like

Fix is coming

1 Like

Thanks a lot (Fuelleman & Teefers) for your gently answer :slight_smile:

1 Like

Yes, I saw that today when I opened a RW project. But, I just downloaded RW 8.1 yesterday. In previous version that message you mention never appeared. I like the older RW version myself. To make this message vanish I think you need to set publishing details zt FILE > PUBLISHING SETTINGS. This looks like the RW folks want to FORCE everyone to use the publish settings now.

I see. Actually I prefer to save on my deskop and after using a FTP program uploading my application to the server. Sometime I had problems during transfer and for this reason I prefer to separate RW issue from FTP issue :slight_smile:

Giorgio, I agree with you, I am the same way. But, we are old fashioned. This new version of RW 8.1 FORCES the use of publishing settings to export a project.

1 Like


After upgrading to RW-8.1, I too am having this Problem: “This document uses files in multiple locations that Rapidweaver is unable to access” …

  • I keep my project files in Dropbox to be able to update my websites at home or on the road…

Everything went fine on MBP but when I tried to open the project files that are in Dropbox (After opening them on my MBP) on my 27" iMac I got the “multiple file location’s” pop-up’s. This only happened on one of my project files. The IMPORTANT one… I now get the pop-up on both Macs…

I am not in a rush… Should I stay on 8.1 and wait for fix… Or go back to RW 8.0.3?

**I have included the problem project file for “JONES X-RAY INC” in a email to you

Thanks for you incredible work!

I have this problem with some projects, that have all their resources stored in the project file. There are no referencing resources outside of the project file. I had this issue even with a blank project file I made for testing

I had a look inside the project package (the folder structure of RW project files). There are numerous references to files. Could it be that this is a copy from another project, where you just deleted resources? It is definitely not a pure blank project.

Yes, I know. The project was a project I duplicated and cleaned it from all content including the resources folder

These files remained in the depth of the project file after cleaning the resources folder in the project. There must be sth wrong with the resources manager

Still a lot of (empty) resource links.

@tpbradley, any idea why deleting resources references in the resource manager doesn’t delete the links in the package?

Yes, I can find in the Contents.plist entries pointing to your hard disk to a PDF (anonymising it here):


Look inside the content.plist in the root of the project package: There are still relicts of files and configurations that I had already deleted from the project (see line 15 to line 13392). I had deleted all content etc. from the project but they weren’t deleted in the depth of the project package (including these empty resources folders)

I tested with another project - same result: You think you have deleted data or content but there are still relicts in the package. I do not know if RapidWeaver 8.0.3 had the same behavior but when I deleted sth in a project file I expect that it will be deleted in the depth of the package too. But it doesn’t and I suspect the error I describe above is related to the warning message.

1 Like

I did a new test with RapidWeaver 8.0.3:

Version 8.0.3 will definitely not show that behavior. When I delete files and content from a project these files will be deleted from the package as well. No remaining code in the content.plist and no empty files/folders in /Resources/

I have to go back to RapidWeaver 8.0.3 until the bug ist fixed


Yes, I see all that data in the 8.1 project file (show package contents) after deleting all content and re-saving the project. Looks like 8.1 isn’t tiding up after itself when pages are deleted.

This does explain why I can get rid of the error by creating a new blank project and dragging the pages across to it. Some legacy rubbish left over in the old project files I guess.

1 Like

I think you lot are onto something here, good detective work.
Tagging @ben @tpbradley


Thanks for all the info guys!

A new build is on the way that should help resolve these problems :smiley:


Updated to 8.1.1 > then appear a list of “RW has detected missing resources in this project”, then I repair all link and the old message “This document uses files in multiple,” disappear. Thanks !
(But the other topic "8.1 can’t save on desktop is still there"