Rapidcart live preview ok, on server links are broken

foundation.
rapidweaver

(john) #1

Hi there, i’m a newbie using RapidWeaver/Foundation and Rapidcart pro stack.
At the moment i have 3 different products added to my catalog and i think i’m settingup everything ok.
When i preview the store in safari right out of Rapidweaver (local site), everything is working perfect (the standard store-page)
Every link is working, all of the pictures are working and i can even order my products.

When i than publish the complete site to my webadress, and try to display a custom store-page only the descriptions
are showed and all the pictures are not found. When i click on the buttons to go to a product-page i’m also get an Not-Found error. It seems that the links are not correct translated and that my Resources-map (that stays in my root) is not found by Rapidcart.

I’ve tried everything to fix this first experiment but can’t figure out were it is going wrong.


(steve bee) #2

URL to the site would be handy.


(john) #3

http://www.tonnardkaas.nl/Rapidweaver/2017/produkten/testshop/?catalog/all/-/date/1

http://www.tonnardkaas.nl/Rapidweaver/2017/store.php?catalog/all/-/date/1

Both links are used as a testshop. Our old ecommerce-shop is still active and running. That’s the reason to choose the subdomain “Rapidweaver/2017” .


(steve bee) #4

Your image and link urls point to https not http.

Have you got the correct url set in the project settings and those of Rapidcart? I would suggest you’ve set the Rapidcart url to https when you should have set it to http.


(john) #5

In Rapidcart you could choose to use the HTTPS protocol. The videos about rapidcart suggest to use https for safety. I’ve published rapidcart now with http and nothing happens. The used product-links don’t work and also now pictures.

As i also saight when i preview the standard Rapidcart store in safari, everything is working perfect. Only by publishing to my webspace the links are broken.


(john) #6

ok. the links are working fine with the use of http !! the store is now in working condition. Only the pictures doesn’t work !! It seems that Rapidcart can’t find the resources folder.


(steve bee) #7

You can only use the https if you have a valid ssl cert.

I would double check you have used http not https for all settings, then republish the entire project,


(john) #8

Entire project is republished. No use off https. I also have the “Store-page” set to my own Stacks Store-page and this also is working perfect!!

The only minor thing is the location where Rapidcart looks for my Resources folder. I’ve figured out the following fault.

www.tonnardkaas.nl/Rapidweaver/2017/resources/PRODUKTfotos/Osti-afbeeldingen/tumbs/Osti_draad_1.png

Thats the location of the resources folder.
Rapidcart links to the following adres and places the resources folder into the “produkten”-folder …

www.tonnardkaas.nl/Rapidweaver/2017/produkten/resources/PRODUKTfotos/Osti-afbeeldingen/tumbs/Osti_draad_1.png

What could go wrong here??


(steve bee) #9

How are you adding the link to the item into Rapidcart?

Only other thing I’d say is don’t use resources, as in the feature in RW, it’s pants. Warehouse your images and add the link to them to the Rapidcart product page. It’s only slightly more time consuming, but far better in the long run.


(john) #10

Just as they(ecommerce video of Realmac) discribe i’d added my productsfolder with images into the resources and choose the picture in the products-tab (points to the resources-folder). Why does Rapidweaver places the resources-folder in the site-root and not in the “/produkten/” location?

here the latest link to my site ,

http://www.tonnardkaas.nl/Rapidweaver/2017/produkten/testshop/?catalog/all/-/date/1


(Doug Bennett) #11

The question is why is rapidcart looking for the resource folder in the /produkey/ location?
Rapid Weaver has always placed the resource folder in the root directory.

How are you pointing to this?


(john) #12

Problem solved!! But not happy.

I’ve placed the Rapidcart Store in my Root directory and also my Rapidcart Custom Stacks-page into the root.
Everything republished and now its loading the product-pictures (also from the root resources)

It seems that both the Store-plugin and the stackspage containing the store must be placed into the root.
I can’t reed in a manual that this is required. All i wanted was a nice and clean root-directory were the store is placed into a store subfolder and not in the root. But everything is working now so why complaining…


(steve bee) #13

I can’t help on the location of the resources folder, as I don’t use the facility.

Glad you kinda got things sorted, I’ll just repeat before leaving, don’t use the resource folder for Rapidcart. It might work OK(ish) initially, but once you have a lot of a product in your online shop it’ll slow down editing massively.

The concept of the resource folder is good, but it’s old and best avoided now, for many reasons. Search this forum to read why. If you’re just starting out get in the habit now of warehousing all your images, not just those for Rapidcart.

You absolutely will regret becoming on reliant on the resource folder soon, sooner or later you’ll switch to warehousing, the sooner you do it the less painful it’ll be.


(john) #14

Thanks steve for your advise. I will look to learn about warehouse images and will try to implement this in my shop.


(Doug Bennett) #15

Might want to check out this post from @willwood, he has a great free boo on thisk: