RapidCart Pro 4.12.1 - All Items Missing - HELP


(Sam Rini) #1

Hi there. Very frustrated. Our entire store has gone down and I’m not sure why. We updated some other pages on our site but the store page was not touched!

Here’s a link to the page:

http://www.bayouhaven.com/Extras/Extras/Rental_Gallery.php?catalog/all/-/name/1

As you can see, there are NO products showing up. Even though the Preview in RapidWeaver is perfect. Works fine. All products show up. But when we go to the published page on the web, nothing is there!

Does anyone know what could have happened?
Please help!
Sam


(Sam Rini) #2

I’m still stumped and getting frustrated! I hope there’s a RapidCart expert out there because I have to get this store back up and running!

To test to make sure I am publishing and LINKING to the proper page once published, I put the word ‘test’ in the store header. As you can see in my images attached, this is showing up. Both in the preview (RW) and live on the web. However, Image one shows what is in RW and what shows up in Preview in RW.

Image two shows what is live on the web. No products show up but all are there and have always shown up before! I changed some navigation on the site but that’s it. (Moved the store to another sub-menu). But again, the page I’m seeing is the one I’m publishing.

Here’s what’s in RW (Preview)

Here’s what gets published:


(David) #3

Tagging @rob for you.


(James Bond) #4

Do you know, 100%, that the RCP page was working beforehand?

And what updates to the other pages did you do? Be precise.

Did you republish all pages or just the updated pages?

What version of RW and is that the latest version of RCP?

And when you launched RW to make the updates did any stacks update themselves?

Has anything been updated/changed on the server recently? If so, did RCP work afterwards?

Have you checked that the products in RCP haven’t accidentally been turned off?

Finally, have you run the updater and is everything installed up to date.

And again, just so there is no grey areas: Do you know, 100%, that the RCP page was working before you updated the other pages? 100% sure. Not, “I’m pretty sure”, or “yeah, I presume so”. But 100%, no shadow of a doubt, the RCP page was working 100% the moment before the other pages were updated?

Generally speaking, stuff doesn’t just stop, but when it does you hear about it from a lot of people. So, 99% of the time, when something like this happens to just one person, it’s normally down to the user, or in the case of RCP, something else being changed on the server.


(Jan Fuellemann) #5

Did you contact the support for RapidCart? They do not monitor this forum.


(Sam Rini) #6

They don’t monitor ANY site. Worse support in the world over the past few months. I’m looking for other solutions but need to get this working until I can rebuild in another product.


(James Bond) #7

They’re pretty upfront about that. They will say themselves, they don’t monitor any forums and they won’t offer support via them. Sometimes it seems they relent and do what they can, but it’s not the norm for them.

Their support does exactly what it says it does on the tin. If there is a problem with the plugin they will support it, and fix it. If a user can’t get something to work because they can’t RTFM the manual, or their setup is not compatible, or similar, they don’t offer support.

I’m no expert, but happy to try to help, if you reply to my questions.


(Sam Rini) #8

James. With all do respect, I have been using the product (successfully) for over a year. The failure to publish is linked to a myriad of support issues they have and the simply don’t have an adequate support or development team.

Even though I have the site back up and running (thanks to the help of an expert user on another forum), I don’t intend to support the product until they start supporting basic issues. In both cases when my site has gone down, it was development issues on their end or small quirks that are not documented.

So if you have time, you to RTFM. I have a hundred times. The issue I just resolved is not even mentioned or referred to.

Have a great day.


(James Bond) #9

So you’ve solved the problem then? Great news!

How about giving something back to the community that tried to help you and explain here exactly what the problem was and how you fixed it?

That way, if someone else has the same problem and finds this thread, they’ll have the solution.

Oh, and no need to thank me for offering to help. Oh no, wait, you didn’t.


(Sam Rini) #10

I want to thank NeilUK (/u/NeilUK) who was a lifesaver. He took a copy of my project file and published it to his own server. found that the store worked on his end. This lead he and I to think that some of the server names/folders on my end might be messed up.

I republished the page (again for the 10th time! LOL) on my end, but first. added a new product. Not sure why, but the addition of the ‘new product’ might have forced some type of ‘re-linking’ to take place and the entire inventory of items showed up again online! Like Neil mentioned, it might have been the resorting of folders on the backend that caused it to break in the first place. Who knows, but either the republish and/or new product/re-link fixed the problem.

Thanks again Neil.
Sam


(James Bond) #11

Right, so most likely not the fault of RCP? Good to know.

Ya, you will find that. When the issue is nothing to do with the app the manual often doesn’t cover it.

I know, right, bloody developers. Shocking support.


(Roberto Tremonti) #12

Thank you for your support, @jamesbond.
And yes, @samrini, we usually don’t provide support thru RapidWeaver forums or other website, because we don’t track them… and we are not supposed to.
There’s a official email channel for all support requests.

That being said, RapidCart Pro (and all other plugins) does everything possible to notify RapidWeaver about page changes, but publishing is a functionality handled by RapidWeaver.
A force republishing or a drastic page change seem to fix most problems customers report.

Have a great day!


(Groove Q) #13

Hi, whats the offical email channel link?

None of my product thumbnails work whatsoever in single product or grid stacks since RW 8.1.x

Works fine in RW 8.0.3


(Sam Rini) #14

Thanks @Rob. Can you share the official email support link. I turned to the forums here because the last two RapidCart issue we have had had no response on your official site. Maybe we’re using the wrong channel so it would be helpful if you shared. Based on the incredible amount of questions coming in around RCP, my guess is we’re not the only ones at a loss.

Thank you for the help. When RCP works, it a fine add-on.


(Roberto Tremonti) #15

@quantize @samrini

https://help.4gnd.com/general/index.html#general-faqs-how-can-i-get-support-for-your-products


(Sam Rini) #16

Excellent. Thanks. I looked all over the site and never saw this email. Really appreciated. All is up and running now but I’ll keep it for future reference if something happens I can’t figure out. Thx and have a good day.


(Groove Q) #17

Thanks Rob, unfortunately changing the advanced setting makes no difference.


(Roberto Tremonti) #18

Sorry but I don’t get what’s the problem you are talking about.
I see all products in your Catalog page.