RapidCart Pro not accepting quantities > 1


(John) #1

Hello!

Until this morning, things were going well as I built a store using RapidCart Pro (RCP). At first I added a single product to the store, a one-of-a-kind painting with a detailed listing on its own product page. Adding quantity: one to the cart worked without problem, with one item showing up in the RCP cart. Adding two or more items produced the appropriate ‘you’ve exceeded the available quantity’ error message. Great!

So to the store I added a version of the painting to the product listing, a print of the painting, with a different price, SKU, and large number of available prints set in Product->Versions, plus its own RCP Product stack on the same product page as the painting. Adding quantity: one to the cart worked without problem, with one item showing up in the cart. Adding two, three, even 42 items showed up in the cart, too, with correct quantity and price. (There was no error message.) Even better!

Then I added two more versions of prints with different prices and SKUs; the cart handled that well too, with varying quantities and prices correctly shown based on inputs from the product page. Sweet.

But after tweaking the formatting of the product page and product descriptions in the store, something broke:

RapidCart Pro’s cart stopped accepting quantities of prints greater than one.

For example, I added 10 prints to the cart, priced at $65 each. (Fig. 1).

Fig. 1

But upon opening the cart, the quantity showed only one print; the subtotal is only $65 (Fig. 2).

Fig. 2

For the prints, settings under Products->Versions were set at 100 (Fig. 3).

Fig. 3
Settings for Products->Versions

I do not look forward to trashing the whole RapidCart Pro store for this project and starting from scratch, but I’d do it if that were the only way to solve the problem.

If you have an idea what could be the problem, please let me know. Thanks so much!


Setup
RapidCart Pro 4.10.0
Rapidweaver 7.4.1
Sierra 10.12.6