RapidCart Pro not publishing


(Mathew Mitchell) #21

@Blomman It is pretty typical of official RW support to give a very general response to a first email. And to be fair, it probably sounded initially like the problem may be with Rapidcart Pro. But when you have publishing problems it’s definitely a RW “thing”. Simply go back to RW with this more detailed information. Then they can give you some pointers on how to sort things out. @Aaron: I’ve tagged you so you can maybe help Anders offline.

If you are getting a warning about index.php and index.html files in the same folder then take that seriously. It means what it says. You are just blowing off good info.

So it seems you have 2 problems: one with publishing, one with deleting the extra index file in certain folders (you probably want PHP and not HTML but I’m not sure).

I can’t help at all with the publishing. But if you have an FTP app (Cyberduck, Transmit) then go into your server and check out relevant folders. You will indeed find an index.php and a index.html in some of them. (Which ones: I have no idea!) Delete the one you don’t want. (Which one? I have no idea, but it’s probably the PHP one you want.)


(Anders Blomqvist) #22

Hi Mathew

Thank’s for the info.

RW support told me that the multiple html and index files was a “soft” warning, ie not that serious so I didn’t have t address it as an urgent matter.

As suggested by many I deleted my whole website on the webhosts server and republished the whole site. Result? Now most of my Swedish site has become 404 and I have tried to republish many, many times with no success but somehow the English site is running.

I sent a message to RW support but have heard nothing so far.

At the moment I am downloading CyberDuck so maybe I can find something there.

I noticed something that I am wondering could be the problem.

In the address field when the Swedish shop page is open it says: www.earthingpeople.se/index.php?catalog/all/-/date/1

On the English site’s shop it is****www.earthingpeople.se/en/index.php?catalog/all/-/date/1

Both pages have been set as the home page for each site and normally the address would be www.earthingpeople.se/home or /shop

I don’t understand why rapidCart gives this address

Thank’s

Anders


( ) #23

Hello everyone!

I’m hopping in here. Just a quick reminder, keep everything friendly, upbeat, etc. No insults or crude bits, that makes creating awesome websites less fun. :smiley:

@Blomman - we’d love to help you get your issues resolved. It does seem like there are a few issues going on, so we’ll try to solve these 1-by-1 - sometimes solving 1 solves the others.

Multiple Index Files:

  • this error message is generated because RapidWeaver detects multiple index files for your website. Some hosts prefer index.php and some prefer index.html. Sometimes plugins require a .php extension, so the site may have used index.html before, but it now uses index.php. That’s how you’d end up with 2 “index” files. The fix is to log onto the server and delete the oldest index file. You can also do a complete republish of your site by going to File > Republish All Files.

Once this has been done, you shouldn’t see that error message again and should be able to publish successfully.

Keep me posted!


(Anders Blomqvist) #24

Hi Aaron.

I have tried to republish at least 50, if not 100 times, always with the same result. RW will not publish all files. between 2 and 6 files usually.

I have Cyberduck and have gone through all the folders in the public_html folder looking for duplicates.
The only 2 index.php not part of the RCP or RW Contact form are the pages generated by RW for the Swedish and the English Rapid cart pages.

As RapidCart Pro and RW contact form are php and all the other pages are html I did ask you if there is a way to convert all the html pages to php but I never got an answer. You also asked me to send you the log, which I did, and nothing happened there either.

I found 2 versions of an uikit file. 2.27.4 and 2.27.5 so I deleted the older one as they seemed identical.

2 times I have erased the whole website from the server and uploaded everything. The first time the English site was fully functional but the Swedish site had only 2 html pages published. After a few hours of trying to fix it I wiped the server again and republished the whole site.

A few pages were missing but when I tried to publish only each page one by one I managed the get the site up and running
I took a whole day and now I don’t even dare trying to change anything on the site as it always gives me the same problems.

One solution would be if you came in via remote and looked through my folder structure as I don’t seem to get anywhere with this on my own. That is the very reason I reached out for help in the first place.

It would have been so much easier to have solved this endless problem once instead of going halfways and then passing me on to Foreground. It would have saved a lot of time and a lot of grief as the discussion went to personal attacks instead of problem solving.

So, are you ready to help me solve this now? Then let’s do it.

Anders


(James Bond) #25

You have such an awesome attitude I for one would jump at thr chance to help you, I mean, it’s not at all like you have a tendancy to lash out at anyone who has previously tried to help you.

So, if you could, very carefully and in minute detail describe as precisely as you can what thr problem is and what you’ve tried thus far to solve it.

I’m so excited about helping you!


(Anders Blomqvist) #26

Hi 007

Thank’s for offering help. At the moment one problem (multiple index files) have been solved by republishing the page twice, with difficulty.

The other problem is that RW will not complete publishing all files. It leaves 2 to 6 files unpublished and I have to cancel publishing, change to Passive mode and try again. Usually with the same result. So I change mode and try again, and again, and again. So it goes on until, with some luck, I am able to get all files published.

Yesterday I made some changes in the header section of the RCP and it didn’t register with RW (no blue dot) but publishing just that page worked and the changes were implemented

I just tried to republish the Swedish site and RW does not publish all files so I had to change mode. This time it worked on only 2 attempts. Screenshots attached

MacPro 10.12.6. RW 8.1.7. RapidCart Pro 4.14.2

Cheers

Anders (the angry one)


(James Bond) #27

OK, sarcasm receptors not working!

But…

Your problem is clearly publishing not RCP, RW has a history of this problem, so first try downgrading to RW version 8.1.6, this uses a different publishing system, which might fix things.


(Anders Blomqvist) #28

Clarification. I had to wipe the server first, twice as the first republishing did not work at all.


(system) #29

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.