RapidMaps3 problems


(Michael Lacy) #1

Anyone else having issues with RapidMaps 3? I am adding pins to an existing map, and clicking on the “add pin”, and the trying to create a new pin by inputting into the address field is not working.

The only thing that is working is to manually enter the longitude & latitude on a pin. It “works”, but is far from efficient, as I have to extract that info from a Google Maps page, from the URL.
cheers.


(Brad Halstead) #2

@Sassafras

Have you checked Foregrounds manual and FAQ?

Brad


(Michael Lacy) #3

Yes. I didn’t see anything there.
The workaround is to drop a pin (which will be centered), then enter the coordinates (which is shown buried in the url).
Something along the way must have been changed in an update.


(Brad Halstead) #4

@Sassafras

Are you using a specific theme?

I have RapidMaps 3 and will build a demo site to see what you’re seeing and advise accordingly, expect it sometime tomorrow as I am off to bed now for a change…

I do believe there was an API update that forced a plugin update, but I don’t remember the details and there is nothing on Foregrounds site that I can immediately find like release notes… but my eyes are blurry and forehead bouncing off keyboard so that may explain a little :wink:

Brad


(Brad Halstead) #5

@Sassafras

I’m not seeing this behaviour is RW 6.3.8 with RapidMaps 3.5.4

I can type in a city, town, addresses and the pin drops and is added, the only caveat to that is that sometimes it leaves the original pin drop there… but I may have something configured differently than you for the plugin…

Show screenshots of each setting for the plugin through the Inspector…

Thanks
Brad


(Michael Lacy) #6

I am using Elixir’s Geometric theme. The map in question is here: http://www.lazyeyedistillery.com/page5/rapidmaps/index.html

I had to go back to RW 6.3.7, as 6.3.8 was exhibiting some really wonky behavior (mostly not saving any of your work, if you “saved” your project while you were in the edited page). I was also having an issue where RW was refusing to preview the site, and just rendered a blank page. Running the previous version could be part of my current problem.

I should probably try just building a blank site to see if the problem is due to a conflict with a theme, or another plug-in/stack. I also noticed the “ghost pin” issue, and had a bunch of extra pins appear that were not originally there when the map was first created. Cheers.


(Brad Halstead) #7

@Sassafras

Using Geometric Theme, RapidMaps displays in preview mode (but does not have all functionality - to get all functionality, publish the page).

RE: Add Pin - this is for adding locations manually (Long/Lat/Name, etc)

RE: Ghost Pins - this is because of the use of add pin and trying to use search field at the same time.

To properly add an address, you simply type it in the search field and hit enter (no ghost button generated)

RE: 6.3.7 and 6.3.8 concurrently - this is possibly an issue as they would likely access the same stacks, plugins, etc and cause code conflicts imho

RE: 6.3.8 wonky behaviour - not my experience, should do a full install as per the Announcement thread if you have not done so already.

I have a demo project that works perfectly in RW 6.3.8, if you want it, let me know.

Brad


(Michael Lacy) #8

Regarding 6.3.8, I did a few rounds of troubleshooting, but was not getting anywhere. Backgrading to 6.3.7 solved the preview issue, and the saving problems. The saving thing was a tough one, after many years of instinctually doing a command/s after any significant amount of work in case there was a crash or freeze, having to remember to change active pages too, was a bridge too far, lol.

The problem with using the address field (which would be my preference), is that it was not working at all. Plunk the address in, and no pin would be generated. Adding a pin manually was the only way a pin could be generated, and then the only active area to change the coordinates was through inputting the lat & long into those fields.

I am heading into a busy period for web work, so will probably have to delve into upgrading to 6.3.8 again.
Can you send me a site message so we can exchange email addresses? I would like to try using your demo once I jump back into the 6.3.8 pool…
michael


(Brad Halstead) #9

@Sassafras

Sent PM with link to project file and email address.

Project should work with RW 6.3.7 as well as 6.3.8

Brad


(Michael Lacy) #10

Just tried your demo (thanks!). Address entry is working fine, even in 6.3.7…
Just restarted my computer, and tried the address entry within my original project.
Voila, address entry seems to be working again. Mystery solved… or fixed.
thanks again.