RapidWeaver 6.3.4 is now available!


(Nik Fletcher) #1

Hi Guys,

Just a quick note to let you know that RapidWeaver 6.3.4 is now available! Check for updates in RapidWeaver for super-speedy “delta” update (a few MB, which is applied to your existing version of RapidWeaver), or visit the Release Notes page to download the complete app!

  • Fixes a problem where the publishing history of a project would be ignored when opening a project, causing RapidWeaver to re-publish all files.
  • Fixes a problem where RapidWeaver could crash when quitting.
  • RapidWeaver now disables the “Publish” button if there are no changes to be published.
  • Improves preview reload behaviour in the Contact Form plugin when editing content in the Page Inspector.
  • Fixes a problem that prevented some Google Fonts from loading in Preview mode.

Cheers,

—Nik


(Nik Fletcher) #2

(Jimmy Hsieh) #3

Hi Nik,

I downloaded the update from within RapidWeaver, and when I clicked the “Install and Relaunch” button, the app quit but failed to relaunch. Next, when I looked into my Applications folder, RapidWeaver wasn’t even there! A search within Spotlight also failed to find the app. It’s like the update process deleted the app from the computer

I’ll try downloading the full updated version next, but just letting you know of my experience, in case this might be a bug. I’m on OS X 10.10.5. I was updating from RW 6.3. Thanks!

-Jimmy


(Nik Fletcher) #4

Thanks for the report. We’ll take a look between 6.3.0 and 6.3.4 - however, it sounds like the updater didn’t move the final app into place.

—n


(DeFliGra) #5

I’ve had a lot of those Quit-Crash… I actually thought it was nice. I didn’t have to quite RapidWeaver myself.

Just kiddin’ :smile:

Thanx for the update.


#6

FYI,
I found if you select “Install On Quit” that it updates fine.


(Shirley) #7

Since the update, RW crashing after every publish? I updated via RW prompt and did an ‘install and relaunch’ if that matters/helps?! :slight_smile:


(Pierre von Kaenel) #8

I’ve had this problem for several RW upgrade versions. I always end up having to download a new copy from the RW website and install it. Very frustrating! Using OS X 10.10.5 and today, RW 6.3.3.


(Gary Davis) #9

Thanks for fixing that publishing thing. Mine was re-publishing over and over again. It would keep publishing five or six times if you would let it. Now, works nicely.


(Dennis Nibbeling) #10

Still crashing on quit (OS X 10.11 dev beta). And the Problem Reporter isn’t able to send it to you. Tried to leave it open for more than an hour but still doesn’t send it.


(Mark Sealey) #11

Officially not supported, is it?


(Redha Almousawi) #12

Hi Nik,

I downloaded the update

is ok

:heart_eyes:


(Nik Fletcher) #13

We can’t guarantee compatibility until OS X El Capitan is marked as “GM” by Apple (we’re guessing today, but we have no insight into when this might happen) and we’re able to test on it.

We’re aware of an issue with a well-known third-party plugin that might cause this issue and an update will be forthcoming shortly from the developer :slight_smile:

—Nik


(studiozellige) #14

First, I want to "thank “ Realmac Software for its investment in Rapidweaver with for very many release since the visit of version 6.0.

On the contrary, I always have problems of publication on one of my sites. Impossible to publish THE SINGLE page without RW’S having to publish the entirety of the site, that is more than 3000 files, among which 2,5 Go of videos!..

I have still made bitter experience, this night after the update 6.3.4: more than 8 hours of treatment and RW turns always and seems to have stopped in 2920 ème file!..

I am therefore, always, made to export pages and to synchronise then with Transmitted.

This synchronisation bugs since RW already lasted since for a long time: he would really be time when they are absorbed.

NB: Stacks 3.0 is a true happiness… :wink:

D’abord, je tiens à “remercier” Realmac Software pour son investissement dans Rapidweaver avec de très nombreuse release depuis la venue de la version 6.0.

Par contre, j’ai toujours des problèmes de publication sur un de mes sites. Impossible de publier UNE SEULE page sans que RW doive publier l’intégralité du site, soit plus de 3000 fichiers, dont 2,5 Go de vidéos !..

J’ai encore fait l’amère expérience, cette nuit après l’update 6.3.4 : plus de 8 heures de traitement et RW tourne toujours et semble s’être arrêté au 2920 ème fichier !..

Je suis donc, toujours, obligé d’exporter les pages et de synchroniser ensuite avec Transmit.

Ces bugs de synchronisation depuis RW durent depuis déjà très longtemps : il serait vraiment temps qu’ils soient résorbés.

NB : Stacks 3.0 est un véritable bonheur… :wink:


(Spencer Carroll) #15

Thanks for the update, however I’m still having trouble uploading to my host. Error repeatedly says unable to connect to server.

I also receive a crash report when trying to export the site.

I’ve attached a copy of the crash report below.

Thanks!

https://drive.google.com/file/d/0B4bz6ZCaU61KNk80QmhweVJhZTA/view?usp=sharing


(Charles Davis) #16

Crash on quit is still a problem for me and my defense for this is to frequently save my projects. It seems to happen most frequently if I have 2 or more projects open.


(Markus Frieauff ) #17

same here…occasional crashes when closing projects.


(Richard Lin) #18

After the update, when I edit a Stacks page, just move some text and click Save, it crashes. The Crash Reporter window is up but the app Save box is there. But I try to save the file and it doesn’t actually save.

I tried creating a new page and I can save that. But if I try to copy that page into the existing project and save it, it crashes.


(Pablo J. Malacara) #19

Hello there, have you found a solution? I have this exact same problem, and updated just as you did. I noticed that this wasn’t happening to new projects created from zero on 6.3.4 but it just came back full throttle, and its so annoying. Cheers!


(Nik Fletcher) #20

Try this:

http://forums.realmacsoftware.com/t/rapidweaver-6-3-5/3082

—Nik