RapidWeaver 7.4 (18663b) Beta [UPDATE 11th April]


(Dan) #1

Bonjour Weavers!

I have some good news for you all. We’ve just released a fresh new beta of RapidWeaver 7.4 for you to try out. This build contains plenty of requested features along with the usual bug fixes.

The big new feature in this release is the support for Safari’s Pinned Tab icons, to enable it you just need to add an SVG into the settings sheet. It’s pretty rad!

What’s new in 7.4?

  • Added support for Pinned Tab Icons
  • Developers can now turn off Live Reloading in Preview mode
  • Improvements to state restoration
  • Improvements to tooltip UI
  • Publish operations (including backup) can now be cancelled
  • Other small bug fixes and improvements

This is a beta release of RapidWeaver, do not install this unless you are comfortable with using pre-release software. Please backup all of your project before using.

You can download RapidWeaver 7.4 (18663b) Beta here. NEW, NEW, NEW BUILD 11th April 2017

Please let us know if you find any issues.

Have a good weekend, and Happy Weaving!


When will Rapidweaver 7 stop publishing every file when I change one tiny thing?
Publishing problems - worse with 7.4
(Mathew Mitchell) #2

I’ve had to go back to 7.3.3. When trying to export a page (any page) I get the message shown in the screenshot.

I have no idea what this means, but I’m sure real coders do!


Can't upload website or preview in browser
(Dave Farrants) #3

I had the same fault, reverted back to 7.3.3


Can't Preview in RW or Preview (Export) Mac or Chrome
(Dan) #4

Thanks for the heads-up, we’ll take a look. In the meantime I have removed the download link to 7.4 - Will hopefully have a new build for you all on Monday!


(William Elston) #5

You may have removed the download link, but 8pm PST RW offered it upon launch. After installed and relaunched, I got the same error as everyone else.


(Konstantijn Van Calster) #6

Me too, I have got the same fault in preview mode.


(Konstantijn Van Calster) #7

Thanks Dan hope to see this fixed on Monday :+1:


Problems with Version 7.4 (18651b) -Exception while exporting site
(Dan) #8

Okay, new build is now available with a fix for this issue: https://dl.devmate.com/com.realmacsoftware.rapidweaver/18658b/1491818322/RapidWeaver-18658b.zip

Happy Weaving!


(Konstantijn Van Calster) #9

Ok Dan thanks nevertheless I have still the same problem.


(Konstantijn Van Calster) #10

In the meantime I have moved back to version 7.3.3.


(Mathew Mitchell) #11

Using the new beta I also can not publish. Attached is the message I get. If I try to publish after this initial failure nothing happens at all (i.e. the shortcut key combo does not work)/


(Dan) #13

Okay, another day another release. This new build should fix the publishing issue this time. Download 7.4 build 18663b here.


(Mathew Mitchell) #14

When I’m prompted to upgrade within RW all works as usual … except the finishing part (Install and Restart). RW simply quits.

Then I used Dan’s link here, downloaded and installed. Now I’m not getting the error messages I did before but … there is this weird “idle” message I see when trying to publish. It seems to run on idle for 4 to 10 seconds, and then it will commence the rest of the publishing routine. So it works but it’s definitely slower than previous versions: primarily because of this idle state it reports being in for a few seconds.

I’ve attached a screenshot.


(Jan Fuellemann) #15

Same here (and now for the rest of the 20 characters)


(Dan) #16

Thanks, we’re working on this. Should have a new build for you tomorrow!

Cheers
Dan


(Mathew Mitchell) #17

@dan I was prompted to update to 18665b this morning. And, of course, I took it for a test run. It seems to work just fine. Certainly the previous bugs have been ironed out. If there are remaining issues they are more subtle and I haven’t stumbled upon them yet.

Thanks for the improvements!


(David Jenner) #18

I’ve updated to 7.4 (18665b) and now I get an upload error saying “Couldn’t sign in to your FTP server”

Whilst this is a problem in that I can’t upload my site, the more frustaing element is that I can’t escape from this dialogue window and I have to force quit RapidWeaver to get out of it.

I’ll rolled back to 7.3.3 and it’s up and running again, hopefully this problem will be fixed soon.


(Dan) #19

@Printdevil, Does this happen for all your projects in 7.4? Also, have you tried re-entering your credentials?

Cheers
D


(Dave Farrants) #20

Version 7.4 (18665b) working fine on 6 different sites (2 different hosts) for me.


(David Jenner) #21

I’ve just tested it on my Home Mac and it uploaded fine on the latest beta. I’ll test again on Work Mac. Do you think the error indicates a connection issue rather than a problem with RapidWeaver?