RapidWeaver 7.4 (18672b) - Release Candidate 1


(Dan) #1

Okay, so here’s the latest build of RapidWeaber 7.4, we think we have nailed the publishing issues that occurred in the last build. This will probably be the version we’ll release as GM next week.

What’s New?

  • Added support for Pinned Tab Icons
  • Developers can now turn off Live Reloading in Preview mode
  • Improvements to state restoration
  • Improvements to tooltip UI
  • Fixed an issue that would sometimes cause backup uploads to fail
  • Publish operations (including backup) can now be cancelled
  • Other small bug fixes and improvements

This is a pre-release software, do not install this unless you are comfortable with the risks. Please backup all of your project before using.

You can download RapidWeaver 7.4 (18672b) here

Please let us know if you find any issues.

Happy Weaving!


(Dylan Merte) #4

Wow still no mention or fix for the major saving bug?! RapidWeaver cannot save projects any more


(Rob D) #5

I see 2 improvements I’ve been asking for, so thumbs up from me. Also:

I see potential for productivity improvement in this, but how is this going to work?


(Brian LaPan) #6

We’re still looking into the causes of that saving issue that a few users are experiencing.


(Mathew Mitchell) #7

This new version of 7.4 seems to be working fine for me. Not seeing any of the publishing issues I experienced before. Thanks for the fixes!


(Oliver) #8

Hey, I might be late, I’ve just got the idea for a feature request (cause I’m affected).

Publishing a site without being forced to save the project.

You may wonder now, whats the sense behind this? Well, I’m creating a site for a client and wanted to upload a little update for him to see how its going on…an RW says it cannot save the project. ‘Save as’ isn’t working to. And all my changes are lost now (this little annoying bug is only fixable (for some weeks) by restarting the mac). And its not the first time this happened.

But if I was able to upload all the stuff without having to save the project, I could later download the backup rw made on upload and everything is fine :slight_smile:
So, if its possible, please do it.

~N


(Dave Farrants) #9

Just duplicate the project file before starting working on it, you can always then go back to the previous unchanged version.


(...) #10

This used to be possible. Sometimes publishing failed or locked up the app, then the changes were lost. The lesser of two evils was to force saving first. As has already been recommended, it is best to duplicate the project and make changes with revision numbers or some other method of tracking for your benefit.


(Oliver) #11

@DaveFox and @Flash, of course I tried this, but RW isn’t saving anything at all ¯_(ツ)_/¯


(...) #12

Sorry, you didn’t mention that part.


(Dave Farrants) #13

Duplicate it via the Finder / Folder View, you don’t need to be in RW or even have RW open.


(Martin Waring) #14

Still getting publishing issues here. I’ve sent in a couple of logs for you to have a look at.


(Simon Maddox) #15

Thanks @MartWaring. I’ve just had a look at the logs.

A couple of questions:

  1. What issues are you seeing? Do you see any error messages?
  2. Can you share which publishing settings you’re using?

(Martin Waring) #16

Hi Simon.

Publishing is getting stuck on one particular project for the same files, regardless of how many connections I try using. I’ve tried 6,3 and 1 connections and get the same result.

Mode is set as Extended Passive (default).

Method is FTP

These files are part of Easy CMS but other projects I have on the same hosting server with Easy CMS publish OK so I’m baffled about what the difference might be.
I can currently get round this problem by using Filezilla to upload the site but its not the way I want to be working, long term.

Best wishes

Martin


(Andrea Vitali) #17

My publishing issues are still there: RW 7.4 crashes just before generating the checksum. (I had the same problem at exactly the same moment with RW 7.3.3
Publishing on a ‘page’ basis is boring and time consuming!


(Brian LaPan) #18

Link to latest beta here:

https://dl.devmate.com/com.realmacsoftware.rapidweaver/18677b/1494345279/RapidWeaver-18677b.zip


(Claude Fitzback) #19

Hi
Just try it ad still the same problem, I need to go back to version 7.3.3 to be able to publish my site…
Fitz


(Nicholas) #20

Still cannot publish. Still says “Cannot connect to ftp” tried all the things suggested in forums. Changing to Extended Passive. Changed server with host, Changed passwords, Published to ftp address instead of site name. Changed speeds etc etc etc. All this happened after upgrading to RW7 never had this problem before.

Go Daddy blaming RW. RW blaming Go Daddy. Basically have a site that won’t publish. After ten years with RW i’m considering jumping ship to Weebly… very sad.


(Claude Fitzback) #21

@Nicolas and Realmac: D’on’t blame Godaddy, it is the same here with Chilidog… use version 7.3.3…

Fitz


(Nicholas) #22

Thanks. Although i did upgrade to 7.3.3 with the same issues. Go Daddy tested going to different server and i still couldn’t connect even though the server was testing fine. So the issue must lie with RW7 somewhere