Updated Rapidweaver 7 Latest Version Will Not Open Anything


(Gordon Shupe) #1

After running the latest security update to High Sierra 10.13.5, Rapidweaver 7.5.5 will not open any project file.

If I double click on either RW 7 or a RW 7 project that I was just working with last week, RW 7 starts up and presents the open file dialog box (not the RW custom launch pad) and will not permit me to open any RW 7 project file. They are all grayed out.

If I try to cancel the open file dialog box, it pops backup open again and again, and again, until finally I have to force quit the RW 7 app.

I have uninstalled RW 7 and reinstalled it. I have deleted realmacsoftware plist file. Still no joy.

Updated info: It will open appropriately in another user account on the same computer, so the issue must be in my original user library. Files open fine on my laptop and other Macs.

Updated info: CleanMyMac to the rescue. CleanMyMac has a Uninstaller program that appears to be more thorough and smarter than I am. After allowing it to uninstall RW 7 and associated files, and reinstalling a fresh download of RW 7 I am back in business.

Bug Report: This is the second time I have had this issue. Is anyone else having this issue?

Feature Request: I actually requested this in the RW 7 Beta program, but it still hasn’t been done.
RealMacSoftware: PLEASE DO NOT AUTOMATICALLY BEGIN COPYING MY RW6 files until I approve where they are being copied to!


(Gordon Shupe) #2

Ugh, now reinstalling and activating license for all my plugins… again…


(Greg) #3

I have had this issue a couple of times (Sierra not High Sierra). RW starts and requires a file to open that is not specified and is certainly not a project file. Both times were after a system update and both times were resolved by logging out and in again (or maybe rebooting - can’t remember). It occurred after specifying a different location for add ons but I’m not convinced that was the issue.


(Doug Bennett) #4

Very good chance that utilities like that are causing the problem to begin with.

If you need to uninstall RapidWeaver:


(Greg) #5

Just a follow up. While ‘CleanMyMac’ may be an issue it was not the cause in my case (as I don’t have it or anything similar - my Mac just accumulates dross!)


(Gordon Shupe) #6

No, this was not what caused the problem. This is a RW resource location issue. I have replicated it on several cycles of reinstalling RW according to instructions.

Upon a fresh install of RW, without an option to block it, RW senses that I had RW 6 folders still in my library and automatically begins to copy them into Dropbox. Then when I go to RW preferences and try to redirect the resources to my more recent designated folder of themes, stacks, plugins, it wants to automatically (with no opportunity to say no) copy over the RW 6 era themes (into and replacing newer versions of themes) to my preferred location.

I am pretty frustrated with this!


"RapidWeaver cannot open files in the “RapidWeaver Project” format."
(Doug Bennett) #7

I’m not at my mac right now, but try to starting RW7 will holding down the option key. If I remember it will ask if you want to be prompted to copy files.


(Gordon Shupe) #8

A week ago after I reinstalled RW 7, on launch it began the copy process again. All of my RW resource files disappeared. I went a week round and round with Dropbox, finally today I went to an old work place to get a physical backup (Dropbox recovery is not all that great.) I tried both the logout, restart, and option key, no joy.


(system) #9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.