RapidWeaver 8.1 Final Candidate 6 (Build 20560b)


(Dan) #1

Happy New Year Weavers!

Today we have a new beta build of 8.1, and it’s a goodie. Take it for a spin and let us know if you hit any issues. If you’ve had issues with Document migration in the past (i.e. from 8.0.x to 8.1) then you should give this build a go and try the migration again.

What’s New in Build 20560b?

  • Improved the look of the Addons installer when in Dark Mode.
  • Fixed an issue where the local publishing destination in Finder couldn’t be revealed.
  • Fixed a crash when publishing to Amazon S3.
  • Smart publishing now works for Amazon S3
  • Canceling publishing to an S3 server no longer results in a crash
  • Plugin information is now logged in crash reports
  • Fixed a potential crash when installing plugins
  • Fixed a document migration issue when upgrading to 8.1
  • iCloud drive files are no longer copied into the document during migration due to the systems sandboxing restrictions.

What’s New in RapidWeaver 8.1?

  • Sandboxed!
  • Dark Mode for Mojave now supported
  • Added Amazon S3 as a Publishing Destination
  • Touch Bar support added
  • Added support for resizing the preview in the main window
  • Added support back in for copying a resources URL
  • Added a new drop down menu to the Simulator toolbar button
  • Added iPhone XS Max to the simulator window
  • Added an option to disable OpenGraph metatags on a per page basis
  • Add a new preference to disable UI sounds
  • Multiple selection is now supported in the Resources Browser
  • Resources can now be dragged from a child folder to the root resources folder
  • Source list layout is now restored between opens
  • Improved the handling of files in the Resources Manager
  • Files in the Resources Browser can now be renamed
  • Fixed an issue where the sitemap plugin and sitemap.xml was displayed and exported incorrectly
  • Fixed an issue with adding edited photos from the resources browser
  • Fixed an issue with resources not getting exported when previewing
  • Fixed an issue where RapidWeaver would appear to deadlock while opening projects
  • Fixed an issue where RapidWeaver would re-publish all files on every publish
  • Fixed an issue where RapidWeaver would get stuck looping between pages
  • Fixed an issue where the incorrect path would be used for social tags in the page header
  • Fixed an issue with multiple buy buttons showing
  • Removed the javascript that was removing line breaks from the Offroad theme
  • Fixed an issue where banner images wouldn’t show due to an issue with CSS consolidation
  • Fixed a naming issue with FontAwesome
  • Show Properties button in Blog now works correctly
  • Fixed various podcasting and channel issues within the Blog page
  • Fixed an issue with page styles being incorrectly applied to Master Styles
  • Fixed up an issue with the Addons Installer
  • Fixed up various crashes in the Photo Album Plugin
  • Fixed a crash when using “Reveal in Finder” and the resource cannot be found
  • Fixed up crash when using the link panel
  • Fixed a crash that would sometimes occur in the Snippets Window
  • Plugin information is now logged in crash reports
  • Numerous other fixes and enhancements!

Download RapidWeaver 8.1 Final Candidate 6 (Build 20560b)

Please keep the feedback coming, we’re working hard to make this the most stable version yet.

Happy Weaving!


(Markus Frieauff ) #2

the auto update function doesn’t seem to work. I click on “update now”, it downloads the new version and yet after installation and relaunch it prompts me with the update note again and is stuck on 20541b.


(Mathew Mitchell) #3

Seems to work fine for me. I get Version 8.1 (20560b).

I have no idea if there are any new bugs yet, but the update itself seems smooth. Wonder why you are experiencing something different?


(Dan) #4

Auto-update worked here when I just tested it. Maybe remove RW 8.1 from your system then manual download it from the link above.

Cheers!


(Markus Frieauff ) #5

yes, the manual download worked.


(Dave Farrants) #6

Auto update worked here.


(Markus Frieauff ) #7

I think I found a bug, actually a pretty nasty one. I have a site that is quite complex and includes a lot of stacks. I just had to make some minor changes and in the afternoon I had updated to Build 20560b. When I previewed or simulated or uploaded the page in question from that build, it was broken. The topbar disappeared, the Impact slides were no longer visible. I got error messages regarding the PopDrop stack that I am using. But since I had already been using this for months and not made any changes there I immediately thougt it must be something else.
Turns out that 2056b does not display nor upload the page properly (obviously it has difficulties creating the correct html code). But build 20541b does. I re-downloaded that version, opened it up from the finder, opened the project, preview worked, simulation worked and upload worked as well.
I guess @Dan you will need the project file in order to check this. How can I send it to you and do you think you have all the stacks involved?


(Dave Farrants) #8

Not seeing that with any of my sites with Build 20560b.


(NeilUK) #9

Yesterday I was working on a client site and uploaded the latest version using Version 8.1 (20541b). I had no issues at all publishing.

This morning, using the same project file and publishing settings, this new Candidate 6 will not connect to my server. Switched back to Version 8.1 (20541b) and publishing works.


(Wondrous) #10

Hi!

Dan, for some reason, in RW 8.1 the Preview is not working well. After the project is closed and if you open it again, the Preview (File - Preview page in… ⌥⌘P) does not work until you restart the program.

In this build again some kind of bug with the Resources window, when you open it, it immediately appears:
error


(Mathew Mitchell) #11

I can confirm the behavior noticed by @Wondrous. I typically just use command-P where there is no problem.


(Tom Bradley) #12

Thanks @Wondrous & @Mathew I have a fix for this in the next release

@NeilUK Can you try one more time with the latest build, also what type of connection do you have to your server?


RW8.1 crashing while saving
(NeilUK) #13

@tpbradley I’ve just tested it again with the latest build. Same result: “Couldn’t sign in with your SFTP server”. I’m using SFTP with Public Key Authentication.

It’s the only way I can connect to my host, but up until this latest build, I’ve never had publishing issues.


(Tom Bradley) #14

@NeilUK Thanks, I’ve found the problem and I’ll get a fix in the next release


(David Labuschagne) #15

Having the same issues as @Wondrous. The difference between this build and the previous one is that most of the resources are now showing in the webpages, but not all of them, and still having issues with the app not finding its resources. Backpedalling to 8.0.3 is also no go. I hope and trust that these issues will be resolved very soon. In the interim, any suggestions as to a temporary solution would be most welcome.


(Jan Fuellemann) #16

No SFTP publishing, same as NeilUK. It worked previously - so @tpbradley thanks for looking into :slight_smile:


(Tom Bradley) #17

@therealmf Hey man, thanks for sending the project/addons. Unfortunately, I don’t think I can reproduce the problem (unless I’m looking at the wrong stack).

I’m guessing the missing stack is this nav bar?


(Markus Frieauff ) #18

No, that is a magellan navigation. The nav that was affected was the main nav on the site (Top Bar stack). The other stack that got lost was the Impact banner.


(Tom Bradley) #19

@therealmf Ok can you screenshot them just to make sure I get the right ones?


(Markus Frieauff ) #20

the one in the red frame is the main navigation.