RapidWeaver 8.1 is live!


(Dan) #1

Hello Weavers,

Today is a big day, RapidWeaver 8.1 is finally here, and it’s a huge update. We’ve been working hard on this build for a while now (as you may be aware), and we truly believe this is the best version of RapidWeaver yet!

Thanks to everyone that helped along the way, we couldn’t do this without you.

You can download 8.1 directly here, or it via the in-app updater.

Should you want/need to go back to the previous version of RapidWeaver at any point, you can download 8.0.3 here.

Happy Weaving!

Thanks,
Dan

What’s New in RapidWeaver 8.1

  • Dark Mode for Mojave now supported
  • Continued work to implement Sandboxing
  • Added Amazon S3 as a Publishing Destination
  • Touch Bar support added
  • Added support for resizing the preview in the main window
  • Added support back in for copying a resources URL
  • Added a new drop down menu to the Simulator toolbar button
  • Added iPhone XS Max to the simulator window
  • Added an option to disable OpenGraph metatags on a per page basis
  • Add a new preference to disable UI sounds
  • Multiple selection is now supported in the Resources Browser
  • Resources can now be dragged from a child folder to the root resources folder
  • Source list layout is now restored between opens
  • Improved the handling of files in the Resources Manager
  • Files in the Resources Browser can now be renamed
  • Fixed an issue where the sitemap plugin and sitemap.xml was displayed and exported incorrectly
  • Fixed an issue with adding edited photos from the resources browser
  • Fixed an issue with resources not getting exported when previewing
  • Fixed an issue where RapidWeaver would appear to deadlock while opening projects
  • Fixed an issue where RapidWeaver would re-publish all files on every publish
  • Fixed an issue where RapidWeaver would get stuck looping between pages
  • Fixed an issue where the incorrect path would be used for social tags in the page header
  • Fixed an issue with multiple buy buttons showing
  • Removed the javascript that was removing line breaks from the Offroad theme
  • Fixed an issue where banner images wouldn’t show due to an issue with CSS consolidation
  • Fixed a naming issue with FontAwesome
  • Show Properties button in Blog now works correctly
  • Fixed various podcasting and channel issues within the Blog page
  • Fixed an issue with page styles being incorrectly applied to Master Styles
  • Fixed up an issue with the Addons Installer
  • Fixed up various crashes in the Photo Album Plugin
  • Fixed a crash when using “Reveal in Finder” and the resource cannot be found
  • Fixed up crash when using the link panel
  • Fixed a crash that would sometimes occur in the Snippets Window
  • Plugin information is now logged in crash reports
  • Numerous other fixes and enhancements!

Updating to 8.1 and now my site is gone. very unhappy!
RapidWeaver 8.1 Final Candidate 5 (Build 20536b) *UPDATED*
(Dan) #2

(Joseph Becker) #3

I’ve just downloaded and installed Rapidweaver 8.1 using the in-app updater and I experience the previously reported issue with the warning that Rapidweaver is unable to locate some resources. After selecting my home folder as we’ll as any other folder associated with my project and its resources the warning persists. I’ve tried deleting resources from my project in the Resources browser but I am either unable to delete those resources after selecting them and using the drop-down Delete button (nothing happens) or Rapidweaver freezes with a beachball. The Force Quit function lists Rapidweaver as not responding. I’ve also tried reinstalling the Rapidweaver from the link above and still have the same issues. Can someone at Realmac help or advise?


(Dan) #4

Hi @thinkfilm,

Sorry to hear that. Can you send over your project file so we can take a look, e-mail it to dan@realmacsoftware.com, and references this thread.

In the meantime you can go back to 8.0.3 by re-downloading it here.

Hopefully we’ll get this resolved for you shorty.

Many Thanks
Dan


(Joseph Becker) #5

Thanks you for the quick reply, Dan. I’ve sent you the project file as you’ve requested.


(Dan) #6

Perfect, we have the project and are looking in to it!

If anyone else reading this has also hit the same issue, please email me (dan@realmacsoftware.com) your project file, the more projects with this issue we have the faster we’ll be able to locate the issue and get it fixed.

Many Thanks
Dan


(Dave Farrants) #7

Installed 8.1 - opened 10 different client projects - no problems at all.


(Tom Bradley) #8

@thinkfilm Thanks for sending your project in, I’m trying to get to the bottom of this issue right now.

If anyone sees the “This document uses files that RapidWeaver is unable to access” alert and you’ve tried re-linking without success, click the “Not Now” button and continue as usual.


(Bruce Kieffer) #9

I wonder if this is related to iCloud? My files are there.


(Tom Bradley) #10

@bruce I think you’re right, it’s looking like this is a bug in macOS to do with referencing files on iCloud Drive or desktop/documents if you have iCloud Desktop & Documents enabled.

Please let us know if you don’t store files in iCloud and repeatedly see this alert.


(Sean Chiles) #11

I have the same problem with all projects opened so far.

My files are stored locally on my mac and on raid to a Synology NAS drive. So the files in use are local.


(Bruce Kieffer) #12

2 of my projects open without the warning.


(George Peacock) #13

I also have had a problem with a project that worked fine and now wont publish in 8.1. I get an:

“NSInvalid ArgumentException error. 0.000000 is not a valid magnification value. We suspect this is caused by a plugin, please notify the developer of this problem. SiteMap Plus (3.0.0) from YourHead Software”

when I try to publish and the publish simply fails

However I also got a: This document uses files in another location that RapidWeaver is unable to access

when first loading 8.1. Not sure what this is about. I do however use dropbox to store resources - would this be an issue.

I will check with Yourhead re Sitemap Plus. But am wondering if 8.1 is not compatible with stoiring resource files in dropbox?
Any ideas?

George


(Gary Loch) #14

Same problem here with lost resources. I located them all and everthing was fine. Just reopened the file and we’re back where we started with this message.


(Gary Loch) #15

Update on this. Each time I open the project file I need to relocate the resources folder. Even when done, the message window posted above does not go away until I click ‘not now’. Going back to 8.03 :frowning:


(Gary Loch) #16

Oh dear, now what???


(Jason Bostick) #17

8.0.3 and 8.1 aren’t compatible…


(Franz Rathmair) #18

8.1 is messing my project up. The @import((file)) function of PlusKit is not working anymore! that is serious since I am using it all over!
I reinstalled the previous version and will not touch 8.1 until it is running smoothly.


(Don H) #19

What version of PlusKit do you have installed? YourHead fixed a bug with @import and released 4.1.3 with the fix.

If you have 4.1.3 installed and @import is still not working, I would contact YourHead support.


(Franz Rathmair) #20

Thanks, Don, I did have 4.1.1 and not the newest version.
I am reluctant to try again RW 8.1, but I may test it the next days.