RapidWeaver 8.1 is live!


(Mike Freeman) #42

Gary and Doug, thanks for your reply. I finally realized that this may have happened because I was tying to “organize” files on my hard drive over the past week. In doing so I had changed the name of my website folder from “Website” to “10 Website” in order to get the folder to appear closer to the top of the finder window. The timing of this problem happening following the RapidWeaver update may have just been a coincidence.

It seems odd to me though that RapidWeaver was looking for 60 files many of which were no longer being used and were in the trash. It was also in many cases asking for the same file multiple times. In the case of my banner it was looking for every variation of the banner photo I had tried and discarded before publishing the website with a new theme a month ago. That really makes no sense!

Anyway, after a few hours of work I was not planning on, I think I have everything up and running again.

Thanks


(Mike Movius) #44

With so many “fixes”, especially with the Resources area which I rarely use, I’ll wait until the fixes are fixed and then refixed. I’m very skeptical of new versions since it wasn’t until the last version of RW 7 that it worked correctly.

Continue to test and retest. Maybe I’ll jump At RW 8.5…maybe.


(Weavium) #45

Anyone experiencing problems with previewing?

It seems that no changes are displayed after previewing projects as of the latest version 8.1.2


(Isaiah Carew) #46

@weavium - i had similar issues recently (not with v8.1.2 which seems OK to me so far) – no idea if your issue is the same or different – but i found that i had quite a few zombie php threads active on my system. i suspect they are all fighting to each be the preview server.

i used terminal to # sudo killall php but the Activity Monitor app in /Applicatons/Utilities folder works fine too. after that previewing starting working a bit better.


(Weavium) #47

Thank you Isaiah, I will give this killall command a try!


(Weavium) #48

Unfortunately the killall command didn’t work : (

None of the latest versions of RapidWeaver 8 refresh after making changes to .devstack files

Hopefully we can get this solved sometime. For now, i’m sticking on 8.1.1 and below : )


(Dan) #49

@weavium have you tried restarting your Mac?


(Adam Shiver) #50

This is something to do with Stacks and the way it interacts with the rendering engine I believe. @isaiah would be better to explain the intricacies of it obviously though.


(Isaiah Carew) #51

yep. this one is on me. i’m trying really hard to have a more reasonable solution for this one for Stacks 4. stay tuned.


(Dan) #52

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.