RapidWeaver 8.4.1 hang on using Preview

Hi,
RapidWeaver 8.4.1 hang on using Preview. The App freased an can only quit with kill.
Using Stacks and Foundry.
Regards, Volker

Hi together,
My RapidWeaver Version 8.4.1 (20817) hangs while “Generating Preview” after I use a Partial on a second Page. It it possible to send someone from the support my Project, so it can by analysed?
Regards, Volker

That sounds more like a stacks issue (@isaiah) (probably what’s in the partial).

Have you tried a process of elimination? Removing stacks from within the partial to try and isolate the issue.

You can probably send your project to YourHead support (makers of stacks) to get help.

Thank you Doug, a request is open.

Hi,

I described the occurring error in the RapidWeaver forum. There it was said, it was probably a stacks problem. So I opened a case on YourHead and provided the files as described. Attention! The YourHead support asked me to make the mistake without foundry :slight_smile: I asked how to do it, it’s a web site with only two pages and it only contains foundry stacks. For days I get no answers to the question of how the problem can be solved :frowning:

Does anyone have an idea here?

Greetings, Volker

Hi Volker,

Sorry you’re having the issue.

If I understand what you’re saying the problem you’re having is preview freezings when using a Particular partial on a second page?

This happens every time you use this particular partial on any page?

I know you said you only have two pages, have you tried to place the partial on a new empty page? that would give a clue as to if it something in the partial or something else on the page.

If you followed the instructions above and sent the project file and the addons folder to YourHead they should be able to recreate the problem(they’ll have all the stacks and partials you have).

You might need to be patient right now as @isaiah is out sick right now (just out of the hospital) and so support is backed up right now.

If you’re in a hurry then I’d try a process of elimination. Since you said it’s only foundry stacks there shouldn’t be any compatibility issues.
Have you tried unpacking the partial on the second page?

Since @isaiah is still going to be out for awhile, perhaps Adam @Elixir could have a look at your project file?

Unfortunately Foundry doesn’t have control over previewing, exporting, publishing, etc. That is handled by Stacks and RapidWeaver. I suspect this is something @Isaiah will have to look at once he’s recovered. I can take a look, but I won’t be able to do much about it I’m guessing besides perhaps confirm whether I’m seeing the same thing using your project file.

I had the same issue with foundation…I unpacked a very complicated partial and the issue went away…I saved it for when @isaiah can get to it…we are all wishing him well.

1 Like

@carp-enter Any chance your complex partial has a partial within a partial?

Hi @joemart1951, I now unpacked the partial on both pages an it works. So I wish @Isaiah also the best and wait for him.

Per my own thread on this subject, I’ve downgraded to 8.3, and the problem has gone away.