Unknown problem with RW 8.5

Since recently I have had the following problem with RW 8.5: While one project can be edited without any problems, working on another project or activating preview leads to a crash of RW (spinning beach ball). I tried older versions of RW as well of the project - unfortunately without success. I’m pretty baffled, because the project has taken years of work …

I had similar problems with versions after 8.3. Try downloading 8.3 from the history page (if you rename it, it will coexist with 8.5), and see if that works.

Hi Adam,
Thank you for your advice. I tried RW 8.3, but when generating a preview, the screen remains white and - after a while - RW “hangs” again.

Which plugins are you using?

I am using the following plugins: See attached JPG-file. What puzzles me is, that since the last publishing date (January 4th, 2020) no further changes have been made to RW and/or the project. Everything worked fine until then… - Thanks for taking care of my problem!


Did you upgrade to Catalina?

Yes, I did. See screenshot!

Most plugins have to be updated if you update to Catalina.
You will have to contact each developer.

I thought the Catalina update issue gives you An error message.

Since its seems to be specific to a single project, I would guess it’s something unique to that project.

Does it only hang on a specific page? Only on preview? What kind of page(stacks, blog, etc )?
You said you tried an older version of the same project, how far back did you go?

You are right: After updating to Catalina, I didn’t get any error messages. In fact, the problem only occurs with one specific project. I am using stacks (latest version), blog etc. The project hangs on any attempt to insert text or photographs. With RW a went back to version 8.3, with the project back to last working version (Dec. 2019).

Does it happen on every page or just one?

It happens on any page.

So if I understand what you’re saying is happening.

  • only on this single project
  • any page that you edit text
  • RapidWeaver freezes up - in edit mode or preview?

But on a new or different project everything is fine?

That sounds like the project file has gotten corrupted some how. Since you can open the file up okay, have you tried to do a save as and see if it will save as a different project name?

You said you went back to the last working version, does that mean you’re up and running again?

  • Correct, the problem only occurs with one of my projects.
  • It happens with any page
  • RW freezes up in preview mode instantly, in edit mode after a while (as soon as a try to modify a page)

When starting RW asks for two missing plugins (see screenshot), even if those have been deactivated.

I suspect that the problems may be caused by an incorrect link to the PhotoLibrary. I tried not to set the link. After that, the project also worked in preview mode, but did not show many photos. How can I change the link afterwards?

I went back to prior versions that worked perfectly at the time. Importing them now doesn’t solve the problem.


What you’re getting is a Catalina update issue on the plugins, I’d address that first.

Good news: I was able to solve the problem. - Thanks again for your kind support!

Jürgen Kirchner


Would be nice, if you told us how solve it…

I´m still on Mojave and have the problem, that some projects don´t publish anymore. “generating checksums” and thats it.

All of them worked without problems before. All updates installed…

1 Like

I was able to solve the problem just by coincidence: When I tried earlier versions of the project, a window popped up, asking for a re-link of my photo libraries. I tried both, iPhotoLibrary and PhotoLibrary. This resulted in having the problems, that I initially had descriebed.

Finally I chose the option “Remove”, and all worked fine again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.