RapidWeaver 8.6.2 keeps crashing on opening

This morning RapidWeaver 8.6.2 keeps crashing when opening any existing project.

Creating an new project: crash!

Disabling all plugins, same result.

After backing up the folder:

/User/Library-Containers/com.realmacsoftware.rapidweaver/

And uninstalling RapidWeaver in SetApp and reinstalling RapidWeaver: same result!

I am unable to use RapidWeaver at this moment. Help!

1 Like

Something for @dan ?

Thanks for the heads-up, we’re looking into this now…

@Jaap_van_der_Veen could you send us a crash report?

Crash report in link below:

https://dsh.re/0b734a

Crash report:

https://dsc.cloud/JaapvanderVeen/RapidWeaver-problem-report

@Jaap_van_der_Veen looking at the crash report, it appears it’s a Stacks related crash. Drop @isaiah from YourHead an email with the details, hopefully he’ll be able to help you out.

@Jaap_van_der_Veen

Despite this, the crash report does look like it’s Stacks that crashing.
Stacks 3.6.9 in specific

So we can go in two possible directions here:

  • if the crash really does continue even with all plugins disabled
    in this case i suspect the RapidWeaver devs will want to see a crash report from that run in particular. the crash report will look quite a bit different without Stacks involved. and seeing that crash report will help them identify the root cause of the problem.

  • if the crash actually goes away when Stacks is removed/disabled then i think you should send our support folks a copy of your project. here’s how/what/where to send the project info: Sending Your RapidWeaver Project

If you have any trouble with that, just let me know. If you’ve already sent it then I’ll probably see it in my email in a few minutes. :smiley:

Isaiah

I had the same problem.

My system is 11.6, but I’m a Stacks 4 user.

I reinstalled 8.5.1 and haven’t had any problems since.

I did not send any crash reports, though I guess I should have.

Me too. Mine crashes when using cmd-z. Am using foundation 6 and stacks 4. Both latest versions. I noticed it used to crash after a number of undos (3 or 4) but now crashes every time on first cmd-z. Very frustrating!

The multiple undo crash is a known bug in Stacks. Isaiah is aware of it. I think that the fix is slated for 4.2 at this time.

1 Like

Thanks Joe - loving F6 by the way!

1 Like