Rapidweaver 8.7 crashing


my Version of RapidWeaver 8.6.2 worked fine. I updated to 8.7 and first everything worked well. Yesterday Rapidweaver 8.7 crashed always right from the start.

I disabled all of may stacks but that made no difference - Rapidweaver crashed.

So I downloaded 8.6.2 again and named it ‚Rapidweaver 8.6‘. Now, that one worked again! But Rapidweaver 8.7 (named ‚Rapidweaver‘ on may machine, kept crashing.

So I deleted Rapidweaver 8.7. Now I could rename ‚Rapidweaver 8.6‘ (which worked) to ‚Rapidweaver‘. This time it crashed also.
I renamed it in ‚Rapidweaver 8.6‘ and it works again.

I think it is likely, that a preference related to ‚Rapidweaver‘ (but not related to ‚Rapidweaver 8.6‘) is damaged. So the best would be, to delete it.

But which one should I delete?

Or am I wrong and there ist a totally different mistake?

Thank you

This one is probably best answered by RealMac folks.
@dan, @Aaron, @tpbradley.

Same problem here. Disaster

Hello teefers!
Thank you.
How do I contact them?
I now namend Rapidweaver (8.7) ‘Rapidweaver 8.7’ and that seems to work.
But I still would like to know which preferences I should delete!

Well I tagged them above, so if they don’t respond here then you can try

There used to be some knowledge base articles on some of this stuff, but RealMac decided to ”redesign” their site and removed them before having replacement information available.

@aikonn, I don’t understand this thing about renaming the RW file. My RW 8.7 file is just called RapidWeaver8.app and it works fine.

1 Like

When I leave the name to ‘RapidWeaver8.app’ it crashes. I also do nor understand that. I have to rename it.

@aikonn Ai,

That is a strange one. My guess is like yours, it is picking up something from one of the Library files.

So if you want to try something (and it seems you have already), then as I said, the old KB articles that ID’ed the Library files are gone.

Here is what I’ve been able to identify what you could try to delete to do a complete uninstall of RW:


And this file


I keep an app called AppTrap that Identified these files when I delete RW8. It usually catches all of them but could have missed something.

Keep in mind you will need to re-enter all your serial numbers (RW and plugins).

Thank you teefers!

I will give that a try next week!

But I looked already in the Library.
I always have two of those folders:


That is the same in the other folders (Containers and Prefs)

But I will try.

I had two RW crashes yesterday during a fairly lengthy session. At the time I thought it was probably a memory issue and closed down a bunch of other open apps and made sure that I always made a new version of the project before making any major changes. I guess two crashes in one day is slightly unusual compared to normal.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.