RapidWeaver 8.8.3 failing to publish

I get this screenshot when trying to setup a local test server. With Transmit the username/password or username/ssh public key work fine (trying to browse the same directory that RW is failing on)…

I am using “root” as it is a virtual machine on my desktop, but Transmit handles just fine as well as a normal terminal command to ssh into the VM. Does RW block anything to do with "“root” user?

Thoughts on anywhere to look?

Hi Chris, I have no idea what is happening there. Can’t you do something with MAMP to test your site? Or use the Preview in Browser function in RW.

Not sure what you are trying to do with your test site.



It actually was the browse and test buttons that did that, I did not try to publish when I got that error. I just published to a local folder and used Transmit to move to the virtual machine.

No worries, it all works fine on my hosting provider of choice, and I have a work around for testing locally (publish to local folder, then move with Transmit or scp command).

I typically have a bunch of Linux virtual machines with apache and php running in either vSphere or VMware Workstation to build out sites, prior to publishing at a hosting provider.

I was really just wondering if there was a log file that might have captured the error…

Did you manage to upload your site? I am having problems with uploads since I updated to 8.8.3 and the test connection all works…

Appreciate any help

So, RW publishing works for me with my hosting providers, I was just using a local VMware Workstation virtual machine (Fedora 34) as a testing platform when I got the failure. I worked around that by publishing to a local folder, then using a SFTP client to do the upload.

I can not even export to a local folder! This is a rapid weaver issue and something within the program is not right…

I have several sites and this is the only one I am having issues with

Please help

@Clare You probably want to contact RW support directly. This is a discussion form frequented mainly by users of RW. I’m not sure any non-RW folks can really help you. Most folks have zero problems with the upgrade. I realize you have a real problem but … also keep in mind the RW folks are located in England so at this point it’s after 11 p.m. where they are located.

I am tagging @dan in hopes he can get back to you tomorrow. Or you can send an email to their support directly.

Ok thank you…I have sent them an email and hopefully they can respond soon…

Thank you

Hi @Clare can you tell us exactly what issue you’re seeing?
Better yet, record a short screencast showing you trying to publish and/or export.

Without more detailed information it’s hard to help.

Also, please double check you’ve tried everything in this help guide:


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.