RW 8.6.2 trouble publishing

I get a message " Couldn’t sign in to your FTP server". “Failure when receiving data from the peer”.
I have contacted my hosting company and have confirmed that all credentials, path, URL etc are correct.
The customer service person was able to connect to my server using FTP filezilla and said that everything looked fine and that there was probably some problem with rapidweaver

Can you Browse from the publishing settings in Rapidweaver? It is the middle right button that should be active if you have entered your server details. If you click it then you should connect to your server and then can navigate to the correct folder to publish to. If you can then I’m at a loss…

I do know that the vast majority of problems I have had with publishing haven’t been a fault of Rapidweaver.

I tried the Browse button and it also gives me error message that it is not able to connect

What happens when you try the test button?

Could you give us a screenshot of the publishing settings?

test button also gives same message. I have tried every option on the drop down menus in each field. It is still not able to connect.

can you provide more info? When I set up with FTP vs. Rapidweaver there can be some subtle differences. Mainly with:

  1. path. What is the path name you are using?
  2. website address: what is the address you are using? (This shouldn’t be a problem but just being very careful here)

My guess (and it’s only that) is the key is the path name RW wants.

If the test button does give you an error, then it’s probably something wrong with the credentials (username and password) or the server name.

1 Like

As the form states, the path does vary from host to host. However, my guess is that your path needs to be changed. With my host the path name would be in this form:


The other thing I’m paying attention to … it seems like a customer service rep was able to FTP into your site. But have you done so using Transmit, FileZilla, or any other FTP app?

1 Like

I haven’t tried any other app. I guess I will have try one of these options to publish.
Customer service confirmed path was correct, but I tried anyway, different paths, including your suggestion. It continues to be the same issue.
I will download Filezilla and give it a try and later update you.
I appreciate your time and help.

I share a similar problem.
Hitting Test on the Publishing section, gives success. Path and everything is correct.
Publishing the site gives the publishing error ‘Couldn’t sign in to your FTP server’

This started as I told RW to republish al files of one site. And sadly I it is not just related to one site… now, none of the web pages I use publish anything. Luckily I’m my own customer and nothing is so urgent.

@dan, sorry to disturb You. Any suggestion for us? Are You aware of this ‘flaw’?

If the test button works then the login credentials, server name and protocol work

That’s all the test Button tests. It doesn’t do anything to test path, number of connections, or mode.

Unix/Linux paths are picky about /'s before and after the path names.

If the test button works then I’d suggest you clear out everything in the path field and then hit the Browse button.

If that works it should present you will a directory listing similar to a finder window. Then you select the directory (folder) for the path.

The important step a lot of people forget to do is to clear out the path before hitting browse. The way the browse button works is it tries to ”start” at what’s in the path field. So if you have an invalid path to begin with it can’t give you a directory listing.

If the test button fails, then it’s usually a typo in the username, password or server name. Try to re-enter them.

If you continue to struggle and want help from RealMac, then go through this KB article. If after you’ve completed all the steps outlined you still can’t publish, it explains what they need from you to help, including how to get log files.

1 Like

I get the same annoying message “Couldn’t sign in to your FTP server” & “Couldn’t up-load to your FTP server”. It also says: “Operation was aborted by an application callback. URL:
I had this ever so often. For some strange reason it then suddenly seems to work again all by itself… Does anybody know how to fix this REALLY annoying thing?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.