RapidWeaver crashing when opening files

I am using RW8 with Stacks, Foundry and FormSnap on both a 2011 iMac (High Sierra) and a 2015 MBP (Catalina). The project files are stored on a OneDrive folder so I can access them from both Mac’s.

I now run into an issue that is puzzling me:

  • Creating a project file on the iMac and saving it on OneDrive lets me open the files on both the iMac and the MBP
  • When I work on a iMac created file on the MBP and save it, I can no longer open it on the iMac. The file seems to open and then RW8 crashes. I have the same result when creating a file on the MBP and then try to open it from the iMac.

Not sure what is happening here. Could there be an incompatibility between files created (or saved) in Catalina and High Sierra? Everything created under High Sierra seems to work well on a Mac running Catalina.

Thanks in advance for any pointers you can give on this.


What version of RW?

I’ve had the same problem with RW 8.6.2, but my system is very old (11.6) so I just now reverted back to 8.5.1.

I had upgraded to 8.6.2 via the in-app automatic update and thought that might have been the problem so I downloaded directly from RealMac and re-installed 8.6.2, but it still crashed.

Back on 8.5.1 and so far things appear to be working okay.

I suggest downloading upgrades directly from https://www.realmacsoftware.com/rapidweaver/releasenotes/

I would doubt it. High Sierra (10.13.x) is only a couple releases back.

The RapidWeaver project file is actually a special kind of folder called a package. It contains quite a lot of files.

I know a lot of people have been having issues with storing these files on Dropbox (a similar cloud service to OneDrive).


Not sure what is running on what.

It sounds like you have no problem recreating the problem?

You might create a project on one Mac and save it to a local drive, then zip it onto a file on OneDrive. Then on the other Mac, grab the zipped project from OneDrive and copy it to the local drive and unzip it. Then try opening it. If that works then you know it’s a OneDrive thing.

If that doesn’t work then you know something else is going on.

Thanks David.
Both machines are indeed running 8.6.2 (20836), so if everything else fails I will try to downgrade and see what happens. Will keep you posted.

The iMac is running High Sierra - the MBP is on Catalina. Both machines have RW 8.6.2 (20836).

No, I no problem at all recreating the problem. You gave me something to think about and try, as I had not done this yet.
So I saved the file from the MBP to a USB drive and then tried to open it on the iMac -> RW attempts to open the file and then crashes. Put the USB drive back in the MBP and the file opens normally in RW.

To me that indicates it is not a OneDrive issue but that something is going on that doesn’t allow RW on the iMac to open files that were created or have been saved by the MBP.

That sounds like one for RealMac support (@Aaron, @tpbradley).

If it produces a crash report, they’ll probably want a copy.

Ah, diving into the log files - why didn’t I think of this.
Here is what I found:

RapidWeaver 8[33886:840044] warning: Filename 5B0901D5-4618-4B7C-86D5-DD3419C7E90D' doesn't exist in sandwich at /Volumes/Macintosh HD/Users/Andre/OneDrive/RapidWeaver/Documents/AESI test5.rw8/Pages/1-Home/Data 2020-05-13 22:24:11.086 RapidWeaver 8[33886:840044] warning: Filename 5B0901D5-4618-4B7C-86D5-DD3419C7E90D’ doesn’t exist in sandwich at /Volumes/Macintosh HD/Users/Andre/OneDrive/RapidWeaver/Documents/AESI test5.rw8/Pages/2-Kennismaking/Data

It seems to me that when launching on the iMac it is missing files and crashes…but how could this be as I start the file from the same location on the MBP and then do not have any issues.

Please try to:

a) Check in the general settings that resources are copied in the document. Save and try again.

b) zip the file first, then transfer it.

I downgraded to 861. I was having high CPU load.

We’re looking into the reported issues with RW 8.6.2, if anyone has a crash report or video of the issue(s) in action, please send them over, you can send me a private message here on the forum.

I’m really sorry if you’re having issues, we’re working hard to get to the bottom of this and will ship an update as soon as possible!


Sent reports this afternoon

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.