Rapidweaver 8, Stacks4 and Intuos M Tablet


(Piers Cross) #1

I am using Rapidweaver 8.2.1 and Stacks 4. Everything seems fine (excellent update from 3, by the way), but I can no longer drag stacks onto the work area using my Wacom Intuos M stylus. Other functions work as expected. Have reinstalled the tablet, but same result. Any suggestions or fixes please?


Weird behavior Stacks 4
(Isaiah Carew) #2

We’re researching this one. It also seems to affect the exact same drag, from library to layout, when using RapidWeaver over a remote screen sharing connection.

I’m confident it’s the same bug – this is just too strange of a behavior to be anything else.

I’m less confident I will fix it quickly, however. I’ve now spent two complete days researching this. What I can say for certain is that the bug was not caused by a change in Stacks software – either mine or the libraries I’m using.

I can re-create the problem simply by recompiling Stacks 3 with updated build settings. This means the bug is a bit more difficult to fix. It’s likely that something very fundamental inside macOS has changed recently – and this catalyzed a change in behavior in Stacks.

We will get this fixed, but I’m afraid this looks to be less and less like a quick turn-around. I suspect it may take me more than a week to even find the problem. And making fundamental changes at this level can often lead to a cascade of cleanup afterwards.

In the meantime I can only recommend using a standard mouse and avoiding screen sharing – or dropping back to Stacks 3 for a week or two.

Thanks for understanding,
Isaiah


(Piers Cross) #3

Isaiah,
Thanks for the swift response.

Using a mouse for a while is not the end of the world.

One thing I’ve noticed though: if I click on a stack with the mouse, I can then drag it with the Intuos stylus into the layout…

I don’t know if that give you a clue to the possible problem, but it certainly gave me cause for (possibly misplaced) optimism!

Best,

Piers


(Isaiah Carew) #4

good news. this bug is solved and in the bag. i’ve actually been stuck a few days on a minor issue with Externals that is still giving me pains today.

i think even if i’ve gotten no further i’ll release what fixes i’ve completed tomorrow (Sunday) – it seems this issue with alternate input devices really affects quite a few people – way more than i would have guessed, anyway.

so look for an auto-update tomorrow sometime and let me know if that helps out – i’m pretty confident it will, but never hurts to get some confirmation that it worked out.


(Piers Cross) #5

Isaiah, That has fixed the issue. Thank you so much.
Piers