Rapidweaver eating up memory?

After upgrading to RW8 several months ago, I noticed that I have to reboot my iMac when it started to get very sluggish often.

Yesterday, it started to get sluggish again badly so I started up mac activity monitor and noticed one of the process “distnoted” using 48.30GB of memory!!

I restarted it and it went back down to 2-3MB of memory.

I left activity running all day yesterday and today while using my iMac and today I started up RW and noticed that while using RW preview, it shot up from around 5MB to 154MB of memory.

Is RW leaking memory or not giving memory back to pool?

read your post wrong earlier – please ignore my earlier message.

The distributed notification center deamon (distnoted) is not really directly associated with RapidWeaver (that i’m aware of) – it’s used by some apps that communicate over networks and by iCloud.

there was trouble with this process a few system versions ago – like OS X 10.11 i think. but i thought they had been corrected. googling doesn’t seem to pop up many newer instances.

if you’re still running an older system, i think the solution would be upgrading. but if not then i’m not quite sure. i’d look into what software you’re using that’s talking over the network or syncing files.

I am running iMac 5K 27" 2017 i7 with Mojave 10.14.6 OS

I know it used for some type of notification since I spent most of the time trying to find more about on Google yesterday.

This is why I have Activity Monitor running all time now to see if any of the apps are causing it to shoot up and so far it shot up while I was using RW and haven’t went back down when I quit RW.

If not RW, then what you think it could be… I wondered about MS OneDrive .or Chrome browser notification pop up? This iMac is my work machine at office so only apps on it are web developing apps like editor, adobe apps, RW, browsers, browsers tools, MSOfffice suite .

It’s still hovering at 154.1MB after I quit RW and haven’t gone up or down since I started this thread.

154MB is a long way from 48GB’s.

I know Safari on my MacPro eats up memory if I leave it running for days. I just quit it and relaunch it every few days. I keep too many tabs open, but when I relaunch Safari the memory used drops down, and all the tabs that were open are open again.

Never had any problem with Firefox or any of the Chromium browsers. I did have a problem a while ago with the Dropbox helper app and just removed dropbox (I don’t use it much).

I can start rapidWeaver, go to preview, Simulator preview in a browser (tried Edge, Safari, and Firefox) and the Distnoted processes memory doesn’t change.

Now you may be doing something different inside RW.

I use RW some more this afternoon and It haven’t gone up or even down. Still don’t know what or where it coming from…

I already tried killing a bunch of apps to see if it goes down and it doesn’t. Only wait to clean it up it to restart the iMac itself completely.

My distnoted (for my username) is about 8.3mb, I haven’t rebooted in about a week. RW, MSEdge,Firefox, VScode, Safari, iTunes and Affinity Design/Photo running pretty much all the time.

It’s gone down a tiny bit, it’s at 153.8MB now :confused:

Look like it the iMessage that causing this …

iMessage or Message app?

What MacOS version are you running?

I Message running all the time and still 8.4mb. 10.14.6

Mojave 10.14.6 OS

Messages.app

It shot up to 5GB then went back down to 380MB

What makes you think it was Message?

I was working on RW and it shot up when I starting to get text to my iPhone which also linked to Message on my iMac

How comfortable are you with the command line/ terminal?

If you want to create a log file that might give you a clue here is a link to an old (but still should work) way of doing just that. Just go to the proper directory and do a touch command for that file to create it. Then reboot. When it spikes again double click on the file you created in finder. It should bring up the console app.

Part of the message log message should be the PID that will match the PID in the activity monitor.

Cool … thank for the tip.

I will do it on Monday.

My shift is about over and I am getting ready to gooooooooooooo home! It’s FRIDAY! :slight_smile:

Been so busy over the holiday …

Anyway, I haven’t gotten a chance to log it yet however today while using RW, my distnoted process was eating up CPU and memory usage again. I didn’t have this issue until I started opening more than 1 copies of RW projects using stacks.

I strongly feel my distnoted process runaway is somehow tied to having multiple RW project open but I cannot pinpoint it yet.

I am wondering if it’s because I access and save all my RW project on the MS Onedrive that causing this?

We suspected that maybe the MS Onedrive “File on Demand” was causing the issue when using with RW so this feature is disabled now to see if that stop memory runaway issue.

I hope I am not jinxing myself posting this but it seems that turning off “File on Demand” is what fixes my memory leak issue with RW when using Onedrive to store project files.

So far so good… hopefully …

1 Like