Rapidweaver publishing not working

Hi I’m a bit of a novice to this web building thing.

I can’t get some alterations I’ve made to my website published.

All was working two years ago when I set up the site, but I now have time to work on it and would like to be able to update it.

Ive made some minor changes but when I try to publish them the first thing i notice is that the publish button is greyed out.
The drop down menu allows me to 'Republish All Files '. This then goes through all the files and appears to be working. However when it has finished and I visit the site, nothing has changed.

Ive discovered a trick… If I start to Re-publish All Files and then ‘cancel’ it halfway through, when I return to the Publish button it is no longer greyed out. Using that option again looks hopeful, and it says that publishing is completed but again nothing seems to have changed on my website.

Im using Rapidweaver 7 and publishing to a site hosted on SiteGround.
I have been to them and they’ve checked my publishing settings and can’t see a problem from their end.

Ive spent a lot of time on this and can’t find a fix in the help topics.

So Ive come here to see if any of you clever folks can shed some light on it.

Many thanks
Steve

Hi Stephen and welcome to the forum,

The grayed out publishing button usually happens when RapidWeaver hasn’t detected any changes since the last time you published. Republishing all files and then change something on a page should in-grey out the publishing button. You should also notice a blue-dot next to the page(s) that have changes that need to be published.

That could be caused by the page being in the browsers cache. The page might be changed on the server but you aren’t seeing it. Try clearing the browsers cache or try a different browser or device.

If the changes still don’t show up and you’re not getting any errors when publishing then you might have an invalid path in your publishing settings. You are copying the files to a directory on the server that’s not where the web server software is pointing at.

If you want help with this it’s best if you can give us a screenshot of the publishing settings and a URL to the site.

1 Like

Hi Doug-

Thank you for your swift and encouraging reply- much appreciated.
I have tried republishing all files a few times. Whenever I change a few things I can seen the blue dots. As you say the publish button appears.
So I think Im doing that bit right.

Ive cleared my history in safari and tried again. Ive switched default browser to Chrome and tried again with republishing and altering and republishing.- but -though in every case it says publishing has been successful - nothing has changed on my site.

I hope you can see this screenshot of my publishing settings
If not I can always list them.

Many thanks for your help

Steve

1 Like

PS nice to think I have Sir Isaac Newtons alter-ego on my side!

1 Like

So no error messages when you publish right?

Eyeballing the setting they look okay, I don’t have any accounts with SiteGround but they have a good reputation.

Have you tried looking with the FileManager, built into the cpanel to see if the files are uploaded? You should be able to check the date.

Also do you have a URL to a page that was changed you can share?

You can also clear out the path (make a copy first) and try the browser button. You should get a list of files and folders on the host.

@morrispaintings This may not help but yesterday I was updating an old website and I was having some problems publishing. It published by very slowly. Checked against newer website and the only difference was I used SFTP in newer websites, FTP for older ones. So worth testing out that change.

Also worth trying a slower connection speed: 3 or 4 instead of 6.

I don’t think it’s a “publishing issue” as you say that you aren’t getting any kind of error message.

I personally only use SFTP for publishing, but I don’t think that or connection speed is the problem. If actual connection or publishing settings are a problem then you’d get an error message.

I think you are publishing the site but you are probably going to a different directory then the domain is pointing at.

Thanks again.
Ive tried slower speeds but this didn’t work.
Ive been into my site ground cPanel and file manager as you suggested.
The files are all there but not been updated since I originally made them in feb 2018- so I think you’re right that all the pages which have ‘successfully published’ aren’t making their way to the right place in SiteGround.

Sorry to sound dim but I’m not quite sure how to ‘clear out the path’- is that in Rapidweaver?

I’m determined to get to the bottom of this and greatly appreciate your help.

Steve

Hi Doug
I really appreciated yours and Matthews help last week
I have been busy with other things but have now returned to trying to get my rapidweaver project to publish.
I think you’re right about the path not pointing to the changes correctly -although Siteground think nothing has changed.
It’s a bit of an impasse. What do you think I should do next?

Thanks for your help again

Steve

Yes Stephen. If you look at your screen shot you’ll see the path is currently set to
/home/morrisp7/public_html

Make a note of that
remove the path from that field and then click Browse
if the other settings are correct, that should lead you to where your website is published

Rob

Hi Rob
Thanks for this.
Ive made a note of the current path, deleted it and this is the window I get when I click ‘browse’.
Ive been through all the folders - how can I find what it should say?

Steve

Typically it would be in public_html.

If you select that and click Choose and then select the option that lets you change the path without re-publishing all your files, what publishing path is displayed in RapidWeaver?

Rob

1 Like

Dear Rob

Thats fixed it! - I’m so pleased.

It came up with the new path of

/public_html

and its just published my minor updates.

I’m very grateful for your help

Many thanks to you all

Steve

1 Like