Rapidweaver seems to be not uploading some files


(Lawrence Diggs) #1

My website is not displaying properly. According to the server techies it seems to be a css issue based on the findings on the console. Note the image. This is causing the pages to display in a haphazard manner.

How can I fix this?


(Mark Sealey) #2

Lawrence,

Have you tried marking (all) pages as changed and/or republishing all files?

From your 404 result code (Page or Resource not Found) Console entries it does indeed seem simply a matter of the files not being in the place where the page in the browser expects to get them from.

That is indeed consistent with the way your pages are displaying.


(Lawrence Diggs) #3

I haven’t but I am trying it now. The site was tested on a different place on the server and was working fine. When i transferred it tot the place it belongs I got problems. Some pages seem to load fine while others are having problems.


(Lawrence Diggs) #4

Well it is much better, thanks. But I am still having problems. Pretty photo is not very pretty.
Note difference between what I am seeing in preview and what is displayed on the web [ http://www.ldiggs.com/ ].

http://www.ldiggs.com/


(Greg Schneck) #5

Hello,
Export the entire site to local folder and then upload all files via ftp.


(Lawrence Diggs) #6

So I have to do this every time I make a correction or addition to the site? Shouldn’t I be able to ftp the site without those extra steps? Seems easier to dump Pretty Photo.


(Greg Schneck) #7

No… Smart Publishing has lost track of your changes somehow. Do this once then all should be OK. Just remember that smart publishing will publish ONLY the files it THINKS you changed. Mine doesn’t work very well. I can make CSS changes and other things and it tells me no changes were made. So you sometimes have to just make sure all files were indeed uploaded. I’m hoping 7.1 release will fix this.


(Greg Schneck) #8

And actually, that’s how I use RW most of the time. Export to local folder and FTP the files. That way you KNOW what files are uploading for sure. You also will learn what files change when you do certain changes. Exporting and uploading with ftp is a good educational experience. But that is just an opinion… :slight_smile:


(Lawrence Diggs) #9

Thanks. I get your point. I have done ftp uploading before. From my perspective, the more steps in a workflow, the more chances to make mistakes or that piece of software to malfunction and the more checking and double checking that has to be done. Thus I like to simplify.

I did a republish everything and that seemed to have cleared up the original problem. HOWEVER, the application still is not republishing everything, even when I choose to republish the whole site. Is this a known bug and something the RW code writers are trying to fix or is it something they don’t intend to fix until the next upgrade, if ever?


(Mark Sealey) #10

Lawrence,

One tactic at this point would be to delete all the published files on the server (or, better - in case you don’t have backups - to move them all into a safe directory in the docroot).

Then mark all files as changed.

And republish all in RapidWeaver. (You really shouldn’t have to do separate ftp.)

Now, see whether - if publishing should fail again - it does so at the same place. Make a note and get back to us here. That would identify a possible corrupt or has a permissions issue etc.


(Greg Schneck) #11

No… you shouldn’t have to do a separate ftp but sometimes that is the ONLY thing that works. :slight_smile:

Should you want to help troubleshoot my publish issues PM me because I would love to have help. Smart publishing is not working for me sometimes. As info, these are the same projects and same existing pages that exported/upoaded FLAWLESSLY with RW5.x and 6.x. (I ran with Smart Publishing off and uploaded single changed pages via right click on page.) But that is not the case with RW7… very intermittent.


(Lawrence Diggs) #12

MarkSealey, Actually I did that as well. It is acting as though the site I have built is cached and will not see updates. That said, I am doing it again.


(Lawrence Diggs) #13

That said, I am doing it again.


(Mark Sealey) #14

If it doesn’t work after the steps I suggest here, you may never have spoken a truer word: could it actually be your browser’s cache?

Please try noting at which point the built-in ftp fails (if it does) to see whether it is one file or random.


(Lawrence Diggs) #15

Now it doesn’t publish at all. I just get a 404.


(Mark Sealey) #16

A 404 is something you see in the browser.

When I go to the site, I see a set of vibrant red pages all displaying perfectly.

What happens if you view your site in another browser; and/or empty the (current) browser’s cache?

What do you see in RapidWeaver?


(Lawrence Diggs) #17

In RW it is fine. It seems to have cleared up , for now. I am not sure which of the many things I tried cleared up the problem, but it is working now. Thanks for your help.