Rapidweaver does not publish changed pages


(Ben Valkhoff) #1

Hi all,

Strange thing happening today. I publish changed pages to the server, but they do not show up in the browser. As a test I uploaded the complete site to a subfolder on the server, but all I see on the server are empty folders. Also no index.html.

I exported the site to my local hard disk: no problems there.

Until now I have had no problems uploading corrected pages, have been doing so for years, until now.

Help much needed, as I’ve run out on solutions for this one.

Thank you in advance for you kind help.


(Doug Bennett) #2

Did you try clearing your browsers cache?

What did you use to check this? Does your host have a file manager? Do you have a stand-alone FTP app like Transmit or FileZilla?


(Ben Valkhoff) #3

I used Cyberduck [Mac stand-alone FTP software] to look into the server of the host.

I guess my host has a file manager, but I wouldn’t know how to use it. I’m pretty much a RW user, not a tech guy. I’m 66 old. :slight_smile:

By the way: I tested Rapidweaver on my wife’s Mac, and she couldn’t make changes on her own site as well. Makes me think: could it be a problem of the server since two separate Macs have the same problem?

I could of course upload the saved site from my HD to the server by FTP, but that would be very time consuming if done daily uploads…

I want to alarm my host only if we can’t solve this here, as he charges $$$ for his time.


(Ben Valkhoff) #4

Yes, I cleared the browsers cache…


(Mathew Mitchell) #5

Can you provide a link? Both to main site and to subfolder?

You really see “nothing” or the changes do not appear? If changes do not appear (just see old version) then perhaps 1 or more pages have been changed to a PHP extension instead of HTML. You will have to go in with a FTP app and remove the old index.html files as they get priority over php.

Finally, if your hosting service charges for service you may want to seriously think about changing hosting services. I’ve never had to pay for help. For many years I used ChiliDog hosting (@barchard) and it’s a fantastic service. Later I changed to an education-only hosting service for practical reasons having to do with supporting my students. ChiliDog is first rate all the way and great at support.


(Gregory Barchard) #6

This is usually one of two things:

  1. The publishing path is incorrect or
  2. The file extension for the page changed from html to php

My guess is is that the page name was hanged from index.html to index.php. If you post the link to your site, this can be easily confirmed.

If you’d like me to help you get started at Chillidog, please let me know. Migration is free :slight_smile:

Thanks
Greg


(Ben Valkhoff) #7

The publishing path is not incorrect. I have not changed anything
The file extension for the page did not change to php.

I tried making changes on different sites I control, but to no avail.
I even tried changing pages on my wife’s website on her Mac, same thing.
I exported my site to my own hard disk, and it works just fine. It seems something goes wrong between our modem and the hosted server.

Of course I can update my site with an ftp-client, but that is not workable.

Here is one of my sites:

http://www.jaapvalkhoff.nl/

I have made a small text change on this page, but it does not appear after updating.

Thank you for your help.


(Ben Valkhoff) #8

On other thing. Everything worked just fine, and had doen for many years, until this morning. Makes you wonder…


(Ben Valkhoff) #9

I uploaded also the whole site to a new subfolder, but all I got was empty folders with no files. :frowning:


(Doug Bennett) #10

If you look with cyber duck, does it show you modification date?
When you publish with RapidWeaver does it give you any errors?
Can you try uploading the changed page with cyber duck? That would tell you if it’s a RapidWeaver problem or maybe a host problem.

You might want to post who the host company is, others might have experience with them.


(Isaiah Carew) #11

Hi Ben,

It sounds to me like your server maybe be having some issues. A lot of hosting providers had to do a lot of extra work for new EU regulations – it wouldn’t surprise me at all if something got disturbed during all that work.
I think probably your first stop should be a support email to your hosting provider to ask if anything has changed.

But secondly, a little advice when posting about an issue here on the forum: Please be as detailed as you can about what you’re doing. Post the specifics of what you did and what you saw. Let me try to give an example…

I uploaded also the whole site to a new subfolder

There are three ways to publish content within RapidWeaver and you mentioned you also use an FTP app – so there are for possibilities of what you were doing here. If they are inconsequential differences the experts here on the forum can ignore those bits. If they are important, it might help to identify the issue.

I have made a small text change on this page, but it does not appear after updating.

Did the change not appear when you browsed to the site?
Or when you checked with your FTP app?
Or did RW say that it didn’t publish?
What change did you make?
What was the URL of the page?

All the little details you can provide give experts a bit more info and sometimes can be the key to uncovering a problem. :smiley:

Isaiah


(Ben Valkhoff) #12

At last the source of my problem was solved. As it turned out there was something wrong with the hosted server. So it was not Rapidweaver, my Mac, or my connection to the server. I found out it was the server after I tried to replace the index.html of my site with my ftp client, as suggested by teefers here. All I got was the error notification ‘Upload failed – 552 Disk full’. I contacted my host and he got his tech people to fix the problem, whatever it was.

I thank all of you for taking the time to help me with this matter.


(system) #13

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.