Rapidweaver stopped publishing my files (Resolved)

Without any modifications, changes, to settings or preferences, I suddenly cannot publish my website. Using the “test” button, everything looks good and I get the “ok”. Using identical credentials with Fetch, I can upload just fine. Is anyone else having this issue? June 02, 2021 discovered this. Thanks in advance!

Mac OS 11.4 Big Sur
Rapidweaver 8

I have exactly the same problem with Mac 11.4 Big Sur and Rapidweaver 8.
Help anyone?

After clearing out all publishing settings and re-entering, I still had no success UNTIL I randomly changed “publishing method” to SFTP. Now everything works again.

Reese Schroeder
liquidoranges STUDIO


iPhone email

1 Like

Thanks, but that didn’t work with me. I couldn’t sign in to the SFTP server.

Without knowing more information about what is exactly happening to you, it’s going to be hard for anyone to help.

Screenshots of the publishing settings and the error message(s) you are getting, along with the name of the hosting company would be a good start.

You can also go through all the steps outlined here:

Thanks for your reply.
I attach a screenshot with my settings.
I can send updates to my host, but they are not updated on the website. I get no error messages.
I have talked to my host, dandomain.dk. They say the bug is in Rapidweaver’s files.
I am using iMac macOS Big Sur version 11.4 and RapidWeaver 8 version 8.8.3 (20877).
Could it be because RW is not compatible with the latest macOS?

Unless it’s a beta version The latest version of RW should have no problems. You aren’t the first person to update.

If I understand what you are saying you publish from RW it shows you the publishing screen and then shows you a “publishing complete”?

That’s not a very helpful response. It published thousands of pages every day with RW. Typical novice technical support reply.

I tried to checkout their support pages, but I don’t speak Danish and their site blocks both M/S Edge and Google translation functions from working.

If I understood what you say and RW completed the publishing okay, that tells me that the files are getting published somewhere, just not the right directory on the server.

Looking at the screenshot you gave you have nothing in the path. That’s highly unusual. Most hosting companies require something in the path. Common paths would include:

  • htdocs/

  • httpdocs/

  • www/

  • public_html/

  • /

Sometime you need the trailing slash, other times not.

The easiest way to select the path is to hit the Browse button next to the path.

Since I can’t translate the Danish from their support page, it looks like it needs to be www/

Når du er forbundet skal hjemmeside filerne placeres i /www/ mappen på serveren.


Thank you for your answer.
I think you are right about the path.
I contact Dandomain again in the morning.

I’ve talked to Dandomain again.
They suggest that I delete all the files on the server and publish them again.
How do I do it?
I press browse and can see the files. But I can not delete them ???

Most hosting companies have a file manager built-in to their control panel. If they don’t you need to use an FTP app like Transmit(paid) or Filezilla(free). Looking at their support pages (sorry don’t understand Danish) looked like they had an FTP a page for FileZilla.

I am having the same problem…

@Clare have you tried re-selecting the path, this is often the most cause of issues.

I have tried that and still not working…It was working until I did the update

Ok so please tech support reach out to me…there is something in rapid weaver that is not right…I have tried everything…
I managed to upload one website using the same program -molokaioutdoors.com (site 1), but when I upload the second website molokaiholokai.com (site 2) it is not working…

Somewhere within rapid weaver I must have done something different…Site 2 has an extra export box location…I tried duplicating that one to the same settings as publishing…I also tried leaving it blank…

Please help…:slight_smile:

Hi @Clare,

Can you email me directly (dan@realmacsoftware.com) with screenshots of your publishing setups, the one that works and the one that doesn’t.

Like this…

You should also follow this guide:

And if you can send me your publishing logs when publishing fails (details on how to do that in the above guide).


Before anything else, switch Publishing Method to SFTP (as per Dan‘s screenshot). This completely solved my issues, and seems to have done so for many others. Seems that hosts have upgraded something which does not like FTP any more — this certainly seems to be the case with LittleOak, who host my sites.

Also you don‘t need to set up Public Key Authentication with SFTP — that‘s an option. Leave it unchecked unless you want this level of security.

1 Like

Aloha Dan
I figured it out. I guess my banner photo went missing even though I was overriding on most pages. It’s working so I am a happy camper!!

Mahalo (thank you)