RapidWeaver Upload Problem


(Peter Danckwerts) #1

I’m afraid I’ve been rather dismissive of upload problems in RW… until recently. Since, I think, 6.3.6, my ip address has been repeatedly blacklisted by my host UK2 after it rejects my user/password details, despite the fact that I have exactly the same settings in RW as I have in Transmit (with which I’ve had no problems).

I usually remember to export and upload but every once in a while I forget and have to wait to be un-blacklisted.:confused:


(Rob D) #2

@peterdanckwerts – Yep, being dismissive about some deficiency or another does not make it non-existent. Some users experience them and some don’t. I think it all depends on a specific computer configuration and kind of software that one uses.

I used to have constant problems with my MacPro startups being stalled (up to 1 hour waiting time), until I deleted the RapidWeaver 5 folder from my Library. Now, I wait less than 30 secs.

So, I guess, it’s back to Transmit for you? I always publish with it and I get zero problems.

How about updating RW with its built-in update system? Do you experience problems as well?


(Brad Halstead) #3

@peterdanckwerts

Check your FTP settings, specifically passive or not (try one then the other), not sure why your host is blacklisting you, but that definitely is a problem with the host and I would talk to them about that for sure.

Ask them WHY you’re being black listed? Is it a connection issue from RapidWeaver?

What are your server logs saying after a publish with RapidWeaver…

Places to start

I have never, in all my FTPing, been blacklisted from a server by using any specific software like HomeSite, CuteFTP, Transmit, Dreamweaver 4 through MX2004, RapidWeaver, CoffeeCup HTML but to name just a few programs I have used on both Windows and Mac computers over the last 20 years… but my hosts have always been US or Canada, so that may be the difference I don’t know…

HTH
Brad


(Peter Danckwerts) #4

Thanks, @Rovertek, @Turtle. My host says I’m being blacklisted because of repeated attempts to ftp using the wrong credentials, but, as I say, they are identical to those used in Transmit. The server logs aren’t even showing the blocked attempts to FTP.

I think UK2 must have toughened their security because I never had a problem in the past with the odd mistake.

I’ll just stick to Transmit from now on. The only reason I didn’t before was that I occasionally forgot. I’ve now changed all the ftp settings to non-existent ones so they won’t trigger another lock-out!


(Brad Halstead) #5

@peterdanckwerts

I’m wondering if you have a path incorrectly set in your publish profile in RapidWeaver… (path is case sensitive)

Did you verify your credentials, www root folder and ftp (FTPS, SFTP, FTP Passive, FTP Non-passive, Private/public key info, etc type with your host? To me, blocking your IP for RapidWeaver but you can use Transmit ok is not a valid answer from the Hosting company imho

I’m not trying to be a jerk here, but I myself made a boo-boo and used a capital P in RapidWeaver and a lowercase p in Transmit and wondered why changes were said to be published but weren’t actually there (where I thought they should be) until I FTP’d in and it clicked… duh me…

I’m truly sorry you’re having such difficulty with your Host and RapidWeaver, but I would suggest that you contact support@realmacsoftware.com and provide your login information so that they can test it out because frankly there is little more that we can suggest without knowing the login details…

The only other thing I can think of is that is there anybody else that you have shared the connection information with that may be playing behind your back and causing the RapidWeaver issue…

One more thing… are you sure you don’t have any leading spaces or trailing spaces in your login id and password? That can cause a failure and can easily go unnoticed!

Good Luck
Brad


(Peter Danckwerts) #6

What I did, to make quite certain that the settings were the same in RW as Transmit, was to copy and paste everything except the password and the type of ftp (FTP PSV which I triple-checked) from Transmit. I also copied them into FileZilla as an extra check. Now I just have to wait until they unlock me. Until then, of course, I can’t even use Transmit.


(Brad Halstead) #7

@peterdanckwerts

I’m wondering what exactly PSV in Transmit is equivalent to in RapidWeaver (Extended Passive -default, Passive or Active)…

I sure hope this gets resolved for you… Password is case sensitive, so is username and host name (no spaces in any of them)

Keep us posted and let us know the results if/when you get it resolved.

Brad


(Peter Danckwerts) #8

@Turtle I don’t know. I rather assumed Passive but I tried both it and Passive Extended. Not Active, though.


(Peter Danckwerts) #9

I hate having a dynamic IP address but now I love it! My hosting company has still not removed my blacklisting but I played around with my ADSL modem to try and acquire a new IP address. Disconnecting it for an hour didn’t work but changing the settings to bridge mode and back again did the trick. Phew!