Red Banner "Slogan" about CMS


(Adriano ) #1

Hello Rapid Weavers,

Can you help me to fix this unwanted Red Slogan that appear to my admin-blog page:
" Could not communicate with Total CMS. Either you have not published your project yet, or your website address is not properly set."
Is there anything I can do to fix this?. Any help is highly appreciated.

Thank you
Adriano


(Paul Russam) #3

Please don’t edit your post to remove your error, it makes subsequent replies meaningless and also prevents someone else having a similar problem finding an answer.


(Joe Workman) #4

Have you published Total CMS? Do you have your website address in the general settings setup properly?


(Jochen Abitz) #5

You have to publish the project on your web server to make Total CMS or Easy CMS work correctly.


(Adriano ) #6

Hello Paul,
I know. The fact is that the previous issue I was having is not coming up anymore, so I thought to edit this post instead of creating a new one. But, yeah… Thanks for pointing this out :slight_smile:


(Adriano ) #7

Hello Joe,
Thanks for your reply.

Before coming to yo your questions, I need to point out that when browsing my site and blog (which is part of my website) in the web all is smooth and lovely. Except a few issues like not being able to upload my Avatar in my public page and the Depot stack in the Admin page, although I have linked the two correctly as explained in the tutorial. And the strange thing is that the Depot Stack appear in the Live External Preview, but the avatar doesn’t (there is the small icon), and in the web browser none of them appear.

The red banner with the message stated in my previous message appear JUST in ALL the pages of the admin section of my blog.

Having explained that, yes I did press the button “Publish in the Live Server” inside RW on the top -right corner. Is this what you mean?

Regarding the website address in the general settings inside RW it is set-up as: http://www.healingdietcoach.com/ .
Before today it was set up as http://http:www.healingdietcoach.com (double http) I think that was a mistake, or the guys from GoDaddy suggested me so, I can’t remember well. But anyway I changed it to: http://www.healingdietcoach.com/

Also, I think it is worth mentioning that I am following the great tutorial for blogging and in some instances Ben changed a few things in the FTP app, but I didn’t for the simple reason that it worked anyway. For example he deleted the index.html file and so on, but because my blog is inside my website I have been thinking that I shouldn’t do it. But maybe that is why, I suppose, I am having issues in uploading my avatar for example and my Depot Stack (it shows in the Live External Preview, but when I publish it doesn’t appear).

Thank you very much for your assistance.
I highly appreciated.


(Adriano ) #8

Hello jochenabitz,

Thanks for your message.

Please see the reply I wrote above.

Cheers :slight_smile:


(Jason Bostick) #9

When you are editing your admin page, are you using http://www.healingdietcoach.com/ exactly (i.e. with the ‘www’?). Because Total CMS allows for unlimited domains, it views http://www.healingdietcoach.com/ and http://healingdietcoach.com/ as different sites) so if you are not using the address exactly as set in your rapidweaver project, you’ll get an error when trying to save new content


(Adriano ) #10

Hello jabostick,

Thanks for your message.
Yes, I am editing with http://www.healingdietcoach.com/.

When I edit my blog in the browser there is no problem, what I am struggling with is to get the changes I am making inside RW visible in the online admin pages (i.e. hipwig editor options, the upload of other Total-CMS stacks such as the Categories, Tags, Images and Depot). I tried with “Re-plublishing all files”, but no success.

These changes appear readily when I do External Live Preview, and that is exactly when I get the red banner saying : " Could not communicate with Total CMS. Either you have not published your project yet, or your website address is not properly set.".
That’s strange, isn’t it?

It shouldn’t take so long to publish this changes and making them accessible online… :roll_eyes:


(Joe Workman) #11

What is the web address configured inside of the project General Settings and in the Publishing Settings?

Are you seeing any changes at all that are made to your project online? Have you triple checked the publishing settings is actually uploading the files to the proper folder?

Another possibility is the index.html vs index.php debacle. If the pages recently changed from html to php, then you will need to manually delete the html version from your server.


(Robert Ziebol 🖖🏼) #12

Regardless of where that red message is appearing, what @jabostick is telling you is something you need to correct. Your site has two domains attached to it
http://www.healingdietcoach.com/
and
http://healingdietcoach.com/

This might not only confuse Total CMS, but it will also cause Google to think you are playing games and making two sites with the same content. They will penalize you in SEO for this. You will want to edit your .htaccess file to include a redirect from www to the non-www or vice versa. Which ever way you want it to work.

I know this does not answer your question about the red banner, but you need to correct this issue as well.


(Adriano ) #13

Hi Joe,

This is the situation at the moment:

  • Web Address in the General settings is http://healingdietcoach.com/

  • Web Address in the Publishing Settings is http://healingdietcoach.com/

  • My domain name is: healingdietcoach.com

  • I see changes I make in RW straight away on my site, although in the blog (Total-CMS) they are not uploading well and I think this is due to:
    a. In my admin/articles page there is a message: “The Web Address in your RapidWeaver Project (//healingdietcoach.com/) does not match the published domain in your browser (healingdietcoach.com). The CMS may not function properly until this is fixed” And indeed, in this page many stacks are not uploading such as the Top Menu Bar, The Depot Stack, The Blog List, and the image (avatar). When I open this same page on RW preview mode no problem, but when I do Live External Preview the message: “Could not communicate with Total CMS.Either you have not published your project yet, or your website address is not properly set.”. So apparently there is something here that I am not getting it right.

  • In my admin/article page the hipwig has been uploaded with the new changes (yay!) and the categories and tags stacks also (hurray!)

  • In my public blog page all is well except the image (avatar) is not displaying next to the author name

Thanks for your support


(Adriano ) #14

Hello zeebe,

Thank you so much!.

Yes, indeed I don’t know why I am having two domain names - I take it as a good luck sign! :slight_smile: -

Mmm…okay. It is confusing me for days, so it makes sense is confusing Total-CMS from day 1. It might be it actually.

I am going to edit this .htaccess file, but could you suggest me how to do it best? Shall I do it together with my Domain provider, or can I do it by myself?.
Thanks for your help zeebe.

I’ll get there :slight_smile:


(Robert Ziebol 🖖🏼) #15

If you are using RW 8, you can edit the .htaccess file in the app. Here is a google search for redirects:
www to non-www
https://www.google.com/search?client=safari&rls=en&q=redirect+www+to+non+www+htaccess&ie=UTF-8&oe=UTF-8

non-www to www
https://www.google.com/search?client=safari&rls=en&q=redirect+non-www+to+www+htaccess&ie=UTF-8&oe=UTF-8


(Adriano ) #16

Hi zeebe,

Thanks for your suggestion.
I have been trying to do this today.

I am opening a new topic in the forum regarding that. Feel free to tune in :slight_smile:

I will get back to the Total-CMS issue as soon as the Redirect/https issue has resolved.

Cheers


(Adriano ) #17

Hello everyone,

Just to update you: I resolved this issue yesterday. :slight_smile:

I redirected my www. and non-www. to https://www. and changed the Web Browser I was Live External Previewing with (I had to clear cached data on that one).
Now all works well.

Thanks for your support !


(system) #18

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.