Total CMS trial problems


(Nick Smith) #1

Hi Joe - I’m attempting to trial Total CMS and running into a few problems. RW preview on the admin page has the dreaded ‘Could not communicate with Total CMS’ red strip and in the browser the page from the server will not save text (red cross). I’ve republished all files, the single text box has the same (default) name in the admin and the content page, my server uses php 7.1 and the url in my RW settings includes the sandbox folder where this development site is currently living (http://www.see-science.co.uk/sandbox/). I’m using the Foundry framework (is this the problem?) and have set Admin Core styles to ‘No I’m not using Foundation’.
I’ve added the Debug stack to the admin page but the cms-data folder doesn’t seem to be on the server. Any help or suggestions gratefully received. If I get this simple trial of Total CMS up and running I’ll be going for Easy CMS - client only wants to add simple text and the odd pic.


(scott williams) #2

Something didn’t publish there are 404 errors on the admin page pointing to the TotalCms api

I would try:
save project
Quit RW
Restart RW
Open Project
Mark all pages as changed
republish all from file menu.


(Nick Smith) #3

Hi Scott - thanks for the suggestions. I had already done this a couple of times Inc clearing all caches and restarting the Mac) but have just repeated the process with republishing from the File menu - still the same!


(scott williams) #4

Well the error is plain as day on your admin page
404 - http://www.see-science.co.uk/rw_common/plugins/stacks/total-cms/totalapi.php 404 (Not Found)
Maybe Joe will impart some wisdom


(Joe Workman) #5

What the the web address inside of the General Settings in the project? If you look at the errors in the dev console…

Notice the URL to the API that its trying to access. That is not the correct URL. This tells me that you have the web address set to http://www.see-science.co.uk/ instead of http://www.see-science.co.uk/sandbox/

If you read that error that Total CMS gave you. It mentions that you should verify the website address set in the project.


(Nick Smith) #6

Thanks guys - my error. I added /sandox to the url in the publishing settings but hadn’t done it in the general settings.
But now the published CMS is not displaying on the content page in browser - and there’s no content when I look at the page source (caches / history cleared + checked in other browser). CMS does display OK in RW preview of content page. Could this be a compatibility problem with Foundry? I have ‘not using Foundation’ selected in both Admin and Core Admin stacks


(Robert Ziebol 🖖🏼) #7

Total CMS works with Foundry, I have tested it before. Do you have a specific page where content is not showing up that you can link for us? Your main sandbox page has content for me.


(Nick Smith) #8

I have a text box on this page http://www.see-science.co.uk/sandbox/who-we-are/ with the content %cmsText(totalcms)%. The page ID on admin and content page text boxes is totalcms - setting son both text/markdown


(Robert Ziebol 🖖🏼) #9

OK, that is because when you add Total CMS to a page, it changes the filename to index.php from index.html
You can see your page here
http://www.see-science.co.uk/sandbox/who-we-are/index.php

Since RapidWeaver will not delete the unwanted file, you will want to go on your server and remove it with an FTP app.


(Nick Smith) #10

Great, thanks - that’s it and all working now. Perhaps deleting all files from the server before republishing all could be part of the standard first troubleshooting step?


(Robert Ziebol 🖖🏼) #11

Well if you do that and have actual data saved in the CMS then that will get deleted too. There will be a folder called cms-data that you want to be sure you save.