Reducing the size of the Edit view


(Jason Bailey) #1

Hi,
Sorry if this has already been addressed somewhere but I cant find it.

How do you reduce the size of an edit page so that I don’t have to scroll sideways to view it.
It would appear that when I add a HTML, specifically, the edit page becomes very wide which is a real pain when editing. Other than removing the specific HTML, is there a way of reducing the size?


(Doug Bennett) #2

Are you talking edit or preview? HTML page or stack?


(Rob D) #3

This happens sometimes if a stack is incompatible with the Stacks plugin, or if a stack’s settings are corrupted, or when the html code is malformed. Try to delete the stack and add a fresh instance of it again. Also, remember to “clear formatting” of any text or code that you paste in.


(Dominick Designs Websites & Tech Training Seminars LLC) #4

I’ve had this same problem. It appears as though the built in Markdown stack does this for me.


(Dominick Designs Websites & Tech Training Seminars LLC) #5

Thanks for the advice. This helps. But when adding Joe’s markdown stack (instead of the built-in markdown stack) there’s an error on my page and it won’t preview).


(Jason Bailey) #6

Hi Doug,
I am referring to edit mode. It only happens when I place a piece of HTML code into a HTML stack. The code is a Metoffice weather embed which is set to “Dynamic with content”. So I am guessing dynamic with content size is the issue. I still don’t understand why my edit page is roughly 2000 pixels wide?


(Jason Bailey) #7

Hi Rob,
I tried all of the tips you mentioned nd still cannot get my edit page to be less than about 2000 pixels, which is obviously impossibly to edit with?


(Dominick Designs Websites & Tech Training Seminars LLC) #8

When I removed the built-in markdown stack it all went back to normal.

But I need that stack b/c Joe workman’s markdown stack caused a strange error when trying to preview.


(Rob D) #9

Hi, @moonha,
What happens when you remove that code? Does the page shrinks in size? If that is what happens, the code is probably malformed. I have a free stack called Weather Embed from Stacks4Stacks, which works fine for me. See, if it could replace your Metoffice code…

Hi, @devananda,
We all need to find some kind of workarounds once in a while. Perhaps you could use a different kind of stack (HTML, Text, etc.) instead of markdown, until you will find a better solution?

To both of you, guys: always try to use the latest versions of Stacks plugin and stacks, test any external code, paste in any text and/or code as plain text (clear formatting). That will help avoid many unexpected behaviors.


(Jason Bailey) #10

Hi Rob,
Yes, the problem is solved on removing the HTML. And I do use the latest software. Its probably just this piece of code!
I have already tried your Weather Embed, its great but I need it to fit in a 3 column stack in my footer and I wanted it to display more than 1 days forecast. I use Stacks4stacks alot, so thankyou.


(Doug Bennett) #11

Jason,
I would say it is something in the code snippet that maybe causing the problem. Stacks pages are less forgiving than most modern browsers when it comes to thinks like matching closing and opening tags.
Without see the code it would be hard to tell.
Does the problem go away in preview or when you publish?
Is the snippet available for someone here to look at (URL)?

You could try to place your HTML stack in a 1 Column stack and see if it helps?


(Robert Ziebol 🖖🏼) #12

What error??

Previews just fine for me:
RapidWeaver

Safari


(Dominick Designs Websites & Tech Training Seminars LLC) #13

@zeebe

Hello, Thanks for replying!

I get a blank white page with nothing but this error in bold:

Parse error: parse error in /private/var/folders/1g/7ljr_mn51_x7qkzvm47ky3300000gn/T/com.realmacsoftware.rapidweaver/RapidWeaver/15559/document-0x7f929679e1f0/RWDocumentPagePreview/transcriptions/gbc_capstones/1991_10_14/index.php on line 389


(Robert Ziebol 🖖🏼) #14

What version of RW? What version of the Stacks Plugin? What version of the Markdown stack by Joe?


(Dominick Designs Websites & Tech Training Seminars LLC) #15

@zeebe

thanks for the support!

RW — 7.2.2
Stacks — 3.2.6
Markdown stack by Joe— 1.2.0


(Robert Ziebol 🖖🏼) #16

Same here, not sure why this would happen, but it works here.


(D. Scott Lee) #17

Great! Well I have spent the last two hours searching the forum and the internet to solve this exact issue. I have been using RapidWeaver for some time now and never seen this happen.
I am using Illuminate (have for a couple of years now), running RW6.2. The other pages are okay. This page has just normal stacks, like text, image, responsive columns, houdini for the sidebar table of contents. I have tried moving Houdini but still cannot resize this page. I have tried using Teleport but still cannot resize with or without Houdini or Teleport. And that is in the sidebar and shouldn’t have any effect.
So, once again, RW has failed me after working on a new page, so I must delete the page and start over again.
I cannot understand why this happens but I suppose programmers, software, and yes even RapidWeaver are not infallible!