Restore RW Themes and Plugins from Time Machine?


(paul shard) #1

I have had to restore my machine from a Time Machine backup and now the RW themes and plugins do not work. They appear to be in the right place but do not seem to work? Any ideas?

Thanks!

Paul


(Mark Sealey) #2

Paul,

Are you on RW5 or 6?

When you say that your Themes and Plugins don’t ‘work’, what exactly is happening, please?


(paul shard) #3

Thx Mark!

We are at 6.3.3 and opening the project in RW but our project “requires a plugin that isn’t currently installed.”

I guess I have them somehow in the wrong folder…


(Mark Sealey) #4

Paul,

RW5 kept its Plugins and Themes in ~/Library/Application Support/RapidWeaver

Could it be that the TM backup pulled from there and so - understandably - restored to there as well?

Whereas RW6 uses ~/Containers/com.realmacsoftware.rapidweaver6/Data/Library/Application Support/RapidWeaver

What’s in that latter location now, Paul?


(Brian LaPan) #5

Mark is correct, Time Machine will restore them in their original location unless you suggest another. Here’s an article to restore a file somewhere else:

http://www.macobserver.com/tmo/article/time_machine_restoring_files_to_specific_locations


(paul shard) #6

Thanks Mark (& LaPan), I have now restored that “containers” directory and all is fixed!

I had done a specific restore of “necessary” files when I reinstalled the system and missed that - as frankly the sandboxing directory structure is a bit confusing :smile:

Thanks again!

Paul