RSNn Contact-us email using FreeStack Contact Plus stack still not arriving


(Cris Baker) #1

Hi,

Now that I’ve just upgraded to RapidWeaver6 from previous rwsw on my new MacMini i5, I’m not receiving the email from the contact-us form although it both publishes fine as well as reports it’s working, I’m using exactly the same BlueBall FreeStack Contact Plus stack I used in rwsw.

And when I look at the RW6 stacks, the FreeStack Contact Plus stack is listed along with all the other FreeStack stacks under Unknown Developer. Could this be the cause of the Contact Plus stack not delivering the email it says it sends?

How do I get these stacks to be recognised under the BlueBalls developer? How do I find out if they’ve been updated and to update them if needed? How do I get all stacks listed under their developer and to find out if any need updating?

All help gratefully received.
warm regards,
Cris Baker
Wednesday, 2018/05/02


(Doobox Software) #2

Stack updates will appear here (see image) if there are any available.
You can access the updates below your stacks library in any stacks page in edit mode.

You have no control over where the stack appears in the library. That is down to the developer. But this is not the cause of your issue.


(scott williams) #3

I doubt that the not send is related to how the stacks are listed. The listing is controlled by the info developers add to the stack. Those were probably made before that feature existed in Stacks. That being said you can sort them into your own folders. in the Stacks UI.

Form Troubleshooting:
Does the form require PHP? (most do)
Is the file name index.php?
Make sure there is no index.html in that folder on the server.
Most hosts no longer allow mail to be sent from an account that is not under the same domain. Are you sending it from account@yourdomain.xxx?

Still Not Working?
Check the error logs on your hosting account for clues.


(Cris Baker) #4

Thanks, Doobox, but how do I get to this display window with the footer options shown? I have 3 occurrences of “Manage Addons” in my RW6 menu bar, but they all give me exactly the same window.

Thanks, this part of the problem has been solved


(scott williams) #5

The screen Doobox is showing you is not in addon’s manager it is at the bottom of the Stack library panel on the main RW edit screen


(scott williams) #6


(Doobox Software) #7

Yep, see above :point_up:


(Cris Baker) #8

Thanks Scott, but how do I get it to show the panel “Get This”? I’ve tried ALL the options in the View menu (and all the other menus and buttons as well) yet just can’t see how to get RW6 to display that panel. What am I missing?


(Isaiah Carew) #9

To open the Library, click the Library button (labeled “Click This” above). If you still don’t see it, can you show us a screenshot of what you do see?


(Cris Baker) #10

Thanks Isaiah, There’s no Library button on the line below Edit/Preview, how do I get it to show that button? My page looks like this:

Thanks, this part of the problem has been resolved


(scott williams) #11

are you on a stacks page type?


(Isaiah Carew) #12

You’re using Stacks v2.x – It’s now several years since Stacks v3.x was released.

The Library pane in Stack 3 is what the Stack Elements popover window was in Stacks 2. But in those days there were no options for sorting, or user defined groups. To get those features you’ll need to upgrade to Stacks 3.

Isaiah


(Cris Baker) #13

Hi Scott, the page and the whole site only has stacks in it, and its theme name is RSNn Stacks BBox. It’s old, was created for me maybe five years ago to use with stacks. you can see the page I’m trying to update with my new email address at http://www.reducestressnow.net/contact-us-2


(Cris Baker) #14

Hi Isaah, I purchased Stacks 3 a month ago and I think I also installed it. How do I check to confirm?

Are you saying Stacks-3 does NOT work with stacks-2 themes and stacks?


(Isaiah Carew) #15

Hi Isaah[sic], I purchased Stacks 3 a month ago and I think I also installed it. How do I check to confirm?

Your screenshot is absolutely Stacks 2. Stacks 3 is not installed. You can download Stacks here: http://yourhead.com/stacks

Installing should be as easy as double clicking. If you have trouble getting it installed check our support FAQ: http://yourhead.com/support
If all else fails send an email (at the same URL) and Christi will give you a hand installing it.

Are you saying stacks-3 does NOT work with stacks-2 themes?

A stack that works with Stacks v2 should always work with Stacks v3. We work very hard not to break things during the upgrades.

Isaiah


(Cris Baker) #16

I downloaded it when purchased and I’m 99.999% certain I also double clicked on it to install. How can I check Stacks-3 is installed in RW6?

If it’s already installed would I upset anything if I double clicked again? Will that automatically get my RSNn project to use Stacks-3? If installing it does NOT get my RSNn project to use it, how do I get it to use it?

Another project told me that I needed to purchase latest version of Sitemap Plus from Loghound which I did, installed and got working…


(Isaiah Carew) #17

To be absolutely certain which version is installed you can open the addons folder and check the version number of whatever you find there:

  1. Hold down the Option key and choose Reveal Addons Folder from the View menu.
    This will open the addons folder in the Finder.

  2. Here you should see all of the plugins that you have installed.
    The Stacks plugin should be called Stacks.rapidweaverplugin

  3. Click on the plugin and choose Get Info from the File menu.
    The version number is listed in the first section (General).

You can avoid any installer complications by simply dragging the new version of Stacks into this folder.

How can I check Stacks-3 is installed in RW6

It’s quite clear simply by looking at your screenshot. The versions look quite a bit different. And I have spent years designing them both. :stuck_out_tongue_closed_eyes: Trust me on this one.
I’m 100% positive you have version 2 installed.

Isaiah


(Cris Baker) #18

Thanks Isaiah, You’re absolutely right, Stacks 2 was still installed. I quit RW6, replaced the obsolete Stacks.rapidweaverplugin as directed and restarted RW6, it’s now installed and also updated to latest 3.5.9.

Thanks Doobox and Scott. I’ve now updated all the stacks installed with your help.

I have a whole bunch of stacks - many named FreeStack xxx - in Ungrouped and also showing in Unknown Developer. How do I get them in with their Developers?

I now need to republish and check my contact-us page to see if these updates will now enable it to deliver messages…


(Isaiah Carew) #19

Ungrouped and also showing in Unknown Developer. How do I get them in with their Developers?

This meta-data (tags, author, subtitle, support URLs, etc.) is set by the author of the stack. It’s not user-configurable. There were many of these that were added around the time of Stacks 3 (actually Stacks 2.5 to be specific). It could be that you have some older stacks installed that are from a time before these features were added. I’d recommend checking with the developer of the stack to see if there is a new version – or at a minimum ask them why they haven’t set the meta-data.

You can, however, create your own groups.

  1. Ctrl-Click (or right-click) on a stack – or on several and choose Add to Group > Create New Group
    This will add the stacks to a group and let you give it a name. This group will show up in the skinny bar to the left of the Library pane.
  2. You can drag more stacks into this group.
  3. You can remove items from a group by Ctrl-Clicking on them and choosing Remove From Group

(Cris Baker) #20

Thanks Isaiah, I’ve tried to group these ungrouped stacks, but is it working properly? One place it says they’re grouped:

Thanks, this part of the problem has been solved