Upgraded my stacks, could not download them to my computer

My Rapid weaver is in complete disarray. Is there anyone or anyplace I can communicate with someone who can talk to me directly. I am exasperated with not having things work, not knowing how to fix them and having no customers service to actually help me. My Rapidweaver worked
fine until I bought a new iMac and transferred my software to my new computer. I’m about to drop the whole thing and never use Rapidweaver again and just hire someone to develop my web sites as a result of no answers and no help.

There are quite a few folks here on the forum that will help you out.
Just ask questions.
Not knowing what problem you are having specifically makes it hard to get answers.

You moved over to a new computer and can’t find stacks?

What version of RapidWeaver are you running?
Might have a look here first:

If you can’t figure it out just ask.

I have no idea where you are getting the no answers and no help. Perhaps you mean from RealMac directly. As far as I can tell the last time you posted here was 11 months ago. While no one on this forum are “official” RW support folks, there are a lot of knowledgeable and kind folks who peruse these forums.

@teefers points to some good materials. In addition, do you have your “old computer” still? Or do you have a backup of all its contents on an SSD drive or other backup location?

Moving forward … RW offers a very nice option to place the stacks and plugins in a location of your choice. This means users can store all these things, if they want, on Dropbox or iCloud. In turn this means when they use a 2nd computer, or move to a new computer, it’s very easy to know where all plugins and stacks are located and they are all synced automagically.

1 Like

Matthew, don’t despair. If you can be patient with this forum, the forum will certainly help you. It’s best to be systematic and detail-oriented.

Follow Doug’s advice and read some instructions on moving to a new computer and/or new version of RW.

If you use Catalina on your new Mac (you almost certainly are), make sure that you have all newest versions of your RW add-ons.

Now, start with describing in detail your new Mac’s setup: OS version, RW’s version, Stacks’ version (if you use this plug-in). And what exactly is it that you have problems with?

Hi Mathew. Much thanks for the reply. Yes I was referring to the company. The frustration comes from dealing with a lot of companies “email only” support but that doesn’t make any of their people bad. Sorry if my frustration came out a little strong :grin:

I think what I need to do is transfer all of my RW to my new computer - see what I have and compare it to what I have purchased. I purchased an upgrade for stacks today. I was only able to download the first two in the list– I’m assuming I have to send Realmac an email about that. Can I load what I need from my old Mac to “Time Machine” then download to my new computer?

Hi Doug. Thanks very much. You guys are amazingly quick. Most forums that I have used have not been very useful. :slightly_smiling_face:

@Weaver_Man I’m hoping someone can help you with this more than I. It may have to wait a day or two since it’s the weekend. Unfortunately (for you) I always put all my stacks, etc. on Dropbox. (I mainly do this so my 2 computers are always synced in terms of RW stuff). So I don’t remember the “regular” storage place. You may have to play around a bit.

The great news is it seems like you still have your old Mac at home. I’d suggest starting it up, open RW, and then open Preferences. You’ll see something like the image below. (I am assuming you are on RW8. Things may be a bit different on an older version of RW: not sure)

Let’s look at this screenshot:

  1. when you go to Preferences, then click on the Addons tab
  2. just below you see 3 sub-tabs for plugins, themes, stacks
  3. below that window you will see your addons location. You can see mine is in dropbox, don’t know where yours is … but it doesn’t matter because …
  4. look a little lower and there are 2 very useful buttons. Export Addons Directory and Reveal in Finder. I don’t know which is best for you but I’d choose Export Addons Directory. It creates a nice zipped folder of all your stuff.
  5. once created move your zipped folder to your new Mac. Place where you want. Unzip.
  6. go into new RW and direct it to find the addons at the location you placed it.

Choosing the location to place addons can be quite important. But to protect yourself I’d also keep a second copy of that zipped folder somewhere safe. Then you have something of a backup plan in case things go wrong. (Note: this zipped folder will only contain stuff from your old Mac and obviously won’t magically update to new stuff you have added/purchased later)

Hope this helps a bit. Others can help more I’m sure.

Hi Mathew. Thank you very much! I am on RW8. I have Dropbox and I do keep my zip folders in a folder. So you have RW software on two computers and use the add-ons from Dropbox? :thinking:

Most people have been getting away from Dropbox, as there have been a lot of problems like endless or long syncing. You can do a search of the Forum for “dropbox” and see the posts. Seems a lot are using iCloud or OneDrive.

You “can” put your addons folder anyplace you like(including Dropbox).

I’ve had 0 nada zero problems with Addons in Dropbox.

That said, placing my RW projects in Dropbox once in awhile had problems syncing. Of course the project files are generally bigger and need to be synced more often.

If I was doing things again I’d put addons in iCloud, but not a big enough deal for me to change right now.

@Weaver_Man Yes, you are correct. I have RW on 2 computers (that’s allowed) and both use the same addons folder. Very nice way to go.

Thanks Mathew. I’m going to do this. When I load the software to my new computer do I contact RW to get permission?

@Weaver_Man Not that I know of. Just use the same license # you have. I believe it is automatically good for at least 2 computers. (There is a limit, but I can’t remember if it is 3 or 4 computers or no.) The main restriction, I believe, is that RW is NOT being used on 2 or more computers at the same time with the same license. (A very reasonable restriction.) Since one computer is at home, the other at my office, this works perfectly well.

Hey I’ve got a little more info on my problem. I’ve been conversing with Aaron over at Realmac Support for over 2 weeks and getting absolutely no where. I’ve got the RW8 software working on my computer now. I can see the Foundation stacks in the stacks column on the left but there is no “site styles” in the list. If I launch one of my older projects nothing shows in the edit window except a notice that “the stack are not loaded onto my computer”. I downloaded them onto my computer and had a confirmation notice that the download was successful but I’m still having the problem. Should I upgrade to the latest version of Foundation and hopefully this will fix it? Any suggestions?

How did you download and install the foundation 1 stacks?

Double-clicking doesn’t always work, especially if you have more than one version of RapidWeaver installed.

Try this:

  1. Do an order lookup for your purchases, send the order history
  2. In the email there will be a link to the foundation starter pack.
  3. Try dragging and dropping the stack onto rapidWeaver (running) on the dock
  4. If you get a message about an older version installed, install the one you downloaded anyway

You certainly can upgrade, but keep in mind that it might have the same problem. Also note that Foundation 6 is an entirely new product. Meaning you would have to redo the website with the new foundation product. It’s not just a replacement.

It’s a super upgrade and worth doing, but F6 works differently than F1 so there’s a learning curve.

Hey Doug. Much thanks.
So I went ahead and upgraded to Foundation 6. After the installation is complete should it just work or do I need to launch a license key or something. Is there a tutorial for Foundation 6? :sunglasses:

There’s no license key. Just install the stacks and themes. there are two themes, LTR(left to right) and RTL.

There’s a bunch of video tutorials here:

There’s also the original live streams preview videos that Joe did when he launched F6, I put out a cheat sheet post here:

There’s no written documentation out yet.

Hey Doug. Much thanks again. Still having problems. I downloaded Foundation RW8 and later Foundation 6. I see Foundation 6 in Preferences > Addons > Themes. After creating a new project I click on the “Add” Tab (upper left hand corner) for the dropdown menu and click on “Stacks”. The Old Foundation loads up automatically and I still do not see “site styles”. If I click on “Themes” I see Foundation 6, I select it and then… nothing. Was I suppose to uninstall the older version of Foundation?

Quick history: A couple of years ago when I first found out about Realmac I was very excited to see something so user friendly. I purchased RW, Foundation and a few other things. Watched the tutorials. It all made sense - I built my first website - it looked great - it worked great and had no problems. Soon after this (a year and a half ago) I bought a new computer, had my dada transferred to my new iMac and this is when everything went haywire. I contacted Realmac Support and after a few emails still could not fix the problem or get any information from Realmac Support that could help me. I ended up getting very busy and had to put everything off for a while. Never got it going. Now I have a new iMac and after conversing with Realmac Support, again, have gotten nowhere with Aaron. He has not replied back to me from my last email which has been a week ago or so. I am dumbfounded as to how two people (Aaron and myself) can be speaking the same language and still not communicate in which he has chosen to, I guess ignore me now. I have many systems and software that I use like Protools. I’m a wiz at it. How can I have a brand new iMac, download the latest/updated software and have it not work? All do respect to you guys here at the forum. You’ve been great but as for Realmac and their “customer support”, I’ve never had such a problem with any companies products or customer service. I don’t want to seem like a ranting fool. I’m sure the fix is easy. I just don’t know where to start. Everything that has been suggested has not worked. I’m at the brink of giving up, just taking my losses and go use one those limited template sites. Sorry to bother you with this but I’m a lone, lamb in the desert far away from water.

Sorry, you’re having issues.

Foundation 1 and Foundation 6 are separate products. They both can be on the same machine so you shouldn’t have to uninstall anything.

Have you tried the search bar in the stacks Library for site style?

I have both F1 and F6 installed and if I search I get both:

Make sure you are in the stacks Library when you search:

You Might want to create a group of stacks for Foundation 6. You can easily do that by making sure you are in the stacks Library and search for foundation 6:

Then Select them all Click the first one that shows up, scroll down to the bottom of the search results and shift Click the last one. That should select all the search results for foundation 6.

Now Right-click the last one and you should see an option to add to Group, select that and you can Create a new group and name it.

Then you can Arrange icons by Tag and they are grouped nicely together by type:

1 Like

Oh my God! I figured it out. Had a brainstorm as a result of going through your last email so yes this was a big help. I went to addons > Reveal in Finder > Themes, and there was 2 F6 folders - clicked on them - they installed - started a new project and in the library list is F6 showing “site styles”. One thing though: It looks like everything is in order but after closing out the project, I re-launched again and I get an alert window that says, "Project Theme is Missing. The Foundation 6 theme that this document uses is missing. If you open this project, RapidWeaver will apply the Foundation 6 theme". Then I click on “Apply Theme and Open” and it all loads up fine. Att. photo

Hey Doug. I figured it out. OK all is in order. Everything is looking good. Thank you so much for helping me out. Be well. :sunglasses:

1 Like