RW 7.0.4 - Failing to Publish


(SF) #1

Since upgrading to 7.0.4, RapidCartPro 4 gets publishing errors constantly and won’t upload. Turns out even trying to export it, then uploading the files to the server via FTP won’t work. [Edit: For a bit I thought it was even exporting the files unchanged, but this is no longer the case.]

Anyone else experiencing this?


(David ) #2

I am in the same boat, I get a publishing error every time. Any idea of a fix?


(SF) #3

Nope - and it turns out it isn’t just RapdiCart, it’s just publishing in general.


(Roberto Tremonti) #4

What error do you get?

Does RapidWeaver export successfully?
Are you saying that you get a error when uploading to your FTP with a FTP client (not RapidWeaver)?
In this case, it seems that it’s not a RapidWeaver or RapidCart Pro problem.


(SF) #5

I can connect just fine via FTP. RW doesn’t want to connect.

I wrote my previous comment poorly. It also appeared, that it wasn’t correctly exporting changed pages correctly either, so that changes I had made and then exported, (with the intention of uploading manually), weren’t actually happening either. But that appears to have stopped.

Also, originally, I though the issue was only changes being made to RapidCart that were failing to upload, as my first attempt at uploading “seemed” to upload the other changes. Nope. RW just marked them as having been uploaded. They actually never made it up to the site.


(Gilberto De Faveri) #6

If your FTP bookmarks were automatically migrated from RW6 to RW7, try changing FTP Mode in Publishing Setup... from Passive to Extended Passive (Default).


(SF) #7

I went through those pains when I first made the switch from RW6 to RW7. This is a RW7.03 to .04 issue. I’ve actually manually re-entered everything and I’m still only able to export and then use an external client. Something has changed from .03 to .04 that’s either upsetting the FTP server, or is broken within RW7.

I’m going to restore back to 7.03 and see if I can get this working again.


(Marc) #8

Does restoring back to 7.0.3.do the trick for you?
Having issues here too with my cms-data folder…


(David ) #9

I restored back to 7.0.3 and still have the same issue


(SF) #10

Yeah me too. Weird that it originally worked at 7.0.3 but now is completely pooched, even after restoring back down.


(Alan Smith) #11

Me too in 7.0.3 (I haven’t dared upgrade to 7.0.4 yet). I’m sticking with 7.0.1 because it does at least publish (although I have to re-publish all files every time or else they don’t make it to the server).


(SF) #12

I changed FTP to ACTIVE and it solved it. :confused:

“You keep using that word, I do not think it means what you think it means.”


(Brian LaPan) #13

+100 for Princess Bride quote.


(Marc) #14

Cool! Changing the FTP Mode to “Active” worked for me too. Everything was uploaded and works the way it should.


(Guy Woodland) #15

An issue I have had is that making even a small change with rapidcart pro and uploading the change doesn’t seem to work. When I asked rapid weaver and rapidcart about this they both said there is an issue and for the time being you have to re upload the whole site… Which then seems to work.


(SF) #16

I was having this exact issue myself until the rapid cart recent patch. Now I can makes changes to product items, like descriptions, etc, but if I want to remove a product or add a new product, I have to republish the entire site.

And I’m still having trouble with RapidCart Pro deciding that a thumbnail which is there is not there, and it giving me errors.


(Gilberto De Faveri) #17

This has been fixed in RapidWeaver 7.0.3


(Roberto Tremonti) #18

Uhu? Please send me the link to a test page.


(SF) #19

I’m currently travelling for work and don’t have the ability to set up a test page. As a workaround, I uploaded the images separately and used the “remote” option and specified the URL.


(SF) #20

Anyone else having issues publishing changes with RapidCart again? I had been able to make changes to products, etc, and along as I republished my entire site, I could get the changes to be reflected. If I just tried publishing the store, it wouldn’t. Now nothing will update.