RW 7.1.7 "Revert to" and automatic backup issue


(Larry F.) #1

Today, I decided to keep a diary of all of RW’s crashes. It seems to crash regularly on all project files, and frankly, I’m sick of it. I love RW, but the crashes have got to STOP. Today was a typical day, unfortunately. RapidWeaver is cool, but so is my time.

Hardware: MacBook Pro
Model Identifier: MacBookPro10,1
Processor Name: Intel Core i7
Processor Speed: 2.4 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 16 GB
Boot ROM Version: MBP101.00EE.B0A
SMC Version (system): 2.3f36

Operating System: El Capitan, version 10.11.6 (15G1108)
RapidWeaver 7.1.7

About 12:10 pm PST—I changed the breakpoint in the menus in two places in one of my project files. The home page has a separate menu and the rest of the pages have their menu in a Partial. I realized that I’d decreased the number and I should have increased it. RW crashed when I tried to use the menu command, “Revert to” to undo the changes.

12:12 pm—Application hang and then crash again when I tried to use “Revert to” to go back to an earlier version.

12:14 pm—I reopened the file. Now the theme is missing in the file.

12:15 pm—After reapplying the Foundation theme, the screen shows an empty project with no pages at all.

12:16 pm—I quit RapidWeaver and tried reopening the file. The project is still empty. All pages are gone.

12:17 pm—I re-launched RW and re-opened the now empty file. Once again, I went to the “Revert to” menu item and tried to open the version from the first time I opened it today. I got RW’s Time Machine-like window. I scrolled back to the version I wanted. RW kept loading previous versions. I assume it’s loading every version that I’ve ever created. When I click on “Restore” I get a system beep. RW keeps loading versions.

12:33 pm—RW crashes again, without restoring the file.

12:34 pm—I retrieve the backup that I manually created from the web server. The backup zip file that RW created is also from yesterday. Since they’re both from yesterday, all subsequent changes have been lost.

I’ll now have to spend an afternoon recreating my project file. Yes, I send in the Crash Reporter reports each time.

STOP ADDING FEATURES UNTIL RAPIDWEAVER IS STABLE!!!


(Larry F.) #2

No, I didn’t save changes after any attempt to open the file.


(Larry F.) #3

Tonight I worked on a different file. RW 7.1.7 wouldn’t preview it, wouldn’t publish it and then crashed when I used that rarely used, hidden and obscure feature called “Quit.” I don’t use PlusKit or any other problematic stacks. All of my other apps work just fine.

My fledgling business is now totally dead in water again, thanks to RapidWeaver and RealMac. I’ve tried reinstalling the app and each of my stacks and plug-ins. I’ve tried running RW with only the stacks that I actually use installed. I’ve tried reverting to older RW versions, but each of them crashes in their own peculiar way. I’ve tried posting things here and I’ve gone through pages and pages of postings. When I was able to pinpoint a reproducible issue, I posted it here. I’ve always put in details when Crash Reporter appears. I’ve sat through Crash Reporter piling up a slew of “Oops” windows for a single crash. I’ve made sure that my hard disk is happy with Disk Utility, Disk Warrior and Onyx. I’ve always installed the latest updates to the OS and like a prudent Mac user, I’m waiting for v2 of Sierra before I install it. Absolutely nothing has worked. The app crashes when I try to do basic things like quitting. It crashes doing different things with different files. Even its backup/revert utility crashes. It sometimes seems to crash almost at random, without a clear cause. Again, all of my other apps work just fine.

On top of all of that, RW still can’t publish any of my files to my server–no version that I’ve ever had has been able to do that. I have to use another product to publish. If a word processor couldn’t print without another application, how long would it last in the marketplace? RealMac just seems to be assuming loyalty, no matter what.

Is there anybody home at RealMac or are they just sitting around, adding buggy features and bathing in how “cool” they think they are? I’m really getting fed up with all of this.


(Dan) #4

Hi @Adiantum,

I’ve replied to you via the email you sent yesterday, so check your email :slight_smile:

We’ll do our best to get RW up and running reliable for you!

Thanks,
Dan


(Dan) #5