RW 7.1.X opens fast and then s l o w!


(Mark Spaulding) #1

Het All,

Not sure if it is just my set-up, but since moving to RW 7.1.X it is super zippy opening projects, but once open, way slower to preview in RW or export in prep to upload to server.

Also, change one page to draft and it take some 1200 files to upload. Seem excessive.

I may try going back to preview with MAMP and see if that speeds things up. At this point, RW is becoming unusable.

OK, I have griped enough.

Thanks.
Blessings,
—Mark


(Ric) #2

Sums up my my feelings nicely.
My site used to take 48 seconds to open but would export and publish in less than 25 minutes.
Now, it opens in a few seconds but exporting and publishing takes 38 minutes.

Presumably @garageshop you have a ‘large’ site too? Link?

Whist the thought of changing software and starting from scratch terrifies me, I think I’m now using the wrong app for my needs.


(Sascha Krüger) #3

Same here…it seems they created a real mess with all those little updates and fixes. I am really thinking about dumping everything and looking for a new development platform.


(Rob D) #4

At least, guys, your projects are getting opened fast. In my case, projects open slow and export slow.

My main site contains over 2800 files (on export). It takes now 54 seconds to open, almost 5 minutes to export to a local folder and about 15 seconds to switch from Edit to Preview.

What’s more, Publishing never gets completed. Exporting to a local folder crashes RW. I can now export my site only after several quits, restarts, dismissing the crash reporter, sometimes even shutting down my Mac and starting all those steps again and again.

I am on El Capitan, with RW 7.1.7 and all addons up-to-date. The last version of RW that was relatively manageable for me was 7.1.0.

it seems they created a real mess with all those little updates and fixes.

That is exactly what I think, as well. It seems to me that RealMac Software has too many coders and not enough software designers/engineers.

If this situation won’t get straightened up quick, I will have to bite the bullet and try my luck with some other software.


(Rob D) #5

Good news (at least, for some of the problems I just described) – please, see this thread.


(Mark Spaulding) #6

Thanks @Rovertek that update helped for sure!

@isaiah I have a page with some 42 stacks (mostly image stacks) and RW/Stacks drops the dialog that Stacks is optimizing, et. al., drops down and clears seven times when I preview in RW. It does publish with one one drop down however. Any close what is going on?

Thanks!
Blessings,
—Mark


(Isaiah Carew) #7

Without the file in hand I’d just be making a wild guess as to what is going on and that would more likely send you off in the wrong direction rather than a right one.

I can offer a basic mechanism for debugging any page, and if that doesn’t work, then you can send the page in question, along with any stacks/plugins/themes required to open it to support@yourhead.com – you’ll need to zip everything up and share as a Dropbox link (or your favorite sharing service).

To debug any page: This is exactly what I do when people send their files to me for help. You can do it too. There’s no magic, and no special knowledge required. Just a bit of patience and careful observation. :smiley:

  1. Drag the page to a new file.
    This is not a permanent solution, but it isolates the page away from any of the project settings, extra HTML/CSS, and anything else there that might clouding the issue.

  2. Close the original file. Or better yet, restart RapidWeaver with only the page in question open.

  3. Remove any extra HTML and/or CSS that you’ve added to the page.
    This includes in the sidebar, in the “header” area of the info-panel. In any HTML stacks, and anywhere else.

  4. Start removing stacks from the page. After every group you remove, preview/export the page to see if the odd behavior persists. If the behavior persists, remove more stacks. If the behavior goes away then undo – and remove other stacks instead.

Keep removing stacks until you have only the stacks that are causing the issue. This might be just one, or perhaps a small group. If it’s more than about 4 – you can probably keep removing some.

If your page has hundreds of stacks, you can remove half of the stacks between each test. In that way, 7 tests, removing half at each test can get you down to just one. 7 tests only takes a few minutes.

  1. When you’ve isolated the problem to just a few stacks take a moment and look them over for anything strange.
  • Do they include code?
  • Content pasted from another site?
  • Are the stacks up to date?
  • Is PlusKit involved?

With that information it’s often easy to see the problem or to at least make a few educated guesses on how it can be solved.

You can then:

  • Correct the error, if its your own.
  • As the forum a very specific question.
  • Or contact the developer of the stack in question for assistance.

Isaiah


(Mark Spaulding) #8

Thanks @isaiah this isa very helpful and careful explanation.

Will give it a go and see what happens.

Thanks.
Blessings,
—Mark


(Greg Schneck) #9

Could you explain your comment in further detail? Do you have a 1200 page blog? I just publish the single new page or changed page but I’m referring to Stacks pages (not a blog.)


(Mark Spaulding) #10

Hi,

Actually no not a blog, just a project with a couple dozen pages and many stacks on each page.

I just updated a page since applying that Stacks update and publish was back to normal, about a dozen files! Yes!!

Thanks.
Blessings,
—Mark


(Mark Spaulding) #11

OK, I removed about a half dozen stacks and the export dialog was normal, dropped down only once.

When I removed the last 3 col reflow stack with three images, the dialog flashed 3 time instead of seven. Removing two more reflow stacks and export was normal.

I have zipped up the project called ‘test copy’ that is the unmodified problem project.
The second zip ‘Test’ is the modified one removing several stacks.
The final zip are the stacks I used.

I will send the dropbox links to support.

Thanks.
Blessings,
—Mark


(Mark Spaulding) #12

Wanted to update that @isaiah Sent me a VERY helpful and informative support response. Looks like a couple of my stacks and a tweak in RW are not playing nice, and folks are looking into it. This is great.

I did a fine tooth comb look at the large project and the result is I found that RW and Stacks were behaving quite normally one every page, except the new pages I built with 7.1.7. An easy work-around for me was to rebuild those pages with out the offending stacks in them as, like most folks, I have many stacks from several developers that to essentially the exact same thing.

Once I did that. Export to preview and publishing worked as expected!

Thanks again Isaiah!

Blessings,
—Mark