RapidWeaver Version 7.3 (18575) Problem


(Monica Sayegh) #1

Hi, after I have updated RW to Version 7.3 I am having lots of issues eg: RW takes ages to open a project, saving, preview is the worst and also crashes all the time.
does anyone have same issues or only me? any solutions? Thanks


(Rob D) #2

Different people have different problems. Some people don’t have problems at all (or so they say). I my case, projects open much faster than in previous versions, but the time to switch from ‘edit’ to ‘preview’ significantly increased – to about 10-15 seconds – even if I don’t change anything on the page. The time for saving also increased in general, but it depends to some extent on the complexity of a page and the amount of changes.


(Monica Sayegh) #3

@Rovertek Glad to hear you are not facing my issues :slight_smile:


(Greg Schneck) #4

I’m using Version 7.2 (18443b) and it is by far the most stable I’ve had in 7. I’m so happy with it I’m am terribly afraid to move on to newer versions. I was having crash after crash but with this particular beta I have not had a single one. But as Rovertek says… different versions work differently for different people and seemingly different hardware and perhaps even on different days… Ha!


(Monica Sayegh) #5

@1611mac thanks, maybe I should downgrade it to 7.2 :slight_smile:


(Ann Doneen) #6

This problem developed after I downloaded 7.3 and I’m pulling my hair out because I could lose my position in an important local community organization because I cannot get their website to publish. It is a gorgeous website for a political client and the opposition has their website up and running and I cannot publish. I called Network Solutions, the hosting company, and they are doing everything to help, but the FTP connection is good because they tested it there. They thought it might be with my hardware, so I called Charter Cable and they came out and gave me (free of charge) a brand new modem and brand new cable.
The first time I tried to publish with the new equipment, it did publish (thank heavens) so it now is up – however, the client is asking me to make very important changes and I cannot make them because I cannot republish. I tried going directly to Filezilla and dragging the files across, but when I do that, I check to see if the changes have published and they have not! I now am trying to publish to my desktop, but that does not seem to be working, either. I have tried every combination of host names given to me by the host, but they do not work. The error message I get (which I click on the blue dot with the “i” in it) sometimes says: “Couldn’t sign in to your FTP server.” And sometimes it says “Failure when receiving data from the peer.” Except Network Solutions says the problem is not on their end and I believe them. I am at my wit’s end. It is not Charter Communications (now Spectrum). They gave me all new equipment and the tech checked it out – came to the house. It DID publish ONCE with the tech here, and I did not change ANYTHING after he left (except I made a very few minor edits to the site – minor for me, but major for the client!). And it has NOT published since he left. I called Charter also and they say everything is working normally. I have published six good websites before using RW6 and RW5, but RW7 has given me these awful problems and it looks like I may lose the client as this is a real political battle here and they MUST HAVE A WEBSITE THAT IS RESPONSIVE. PLEASE PLEASE HELP ASAP!!! (No, it is NOT a commercial client – it is a volunteer job, but they are a client nontheless… they are a nonprofit and I’m donating my time to them. But it’s still urgent and very important.) P.S. I did try to download the 7.3 upgrade . . .Maybe that caused it. I cannot find the upgrade on my computer at this point. Was going to try to re-load it, or reload the original software. It is possible that the software might have been running when I downloaded the upgrade, but I don’t think it was (if it was, it might have been hidden under a Photoshop document or something.)
PULLING MY HAIR OUT!!! Please!!! Not even certain, at this point, how to get a copy of the original software if I trash the application that I have (7.0 – and, who knows? Maybe 7.3 if it’s on this computer at all. It does not come up when I do a search for it.)


(David) #7

You can download previous versions of RW7 here: https://realmacsoftware.com/rapidweaver/releasenotes/

Maybe try reverting to RW 7.2.2? 7.3 seemed to create FTP problems for some users. Just trash your 7.3 version and put 7.2.2 in your applications folder. Might be good to re-start your Mac as well.

Also, check what version of RW you are actually using by clicking on “About Rapidweaver” in the top menu under “Rapidweaver 7” and make sure you are actually using 7.2.2


(Ann Doneen) #8

Thank you, thang (David)… I will try that now.


(Ann Doneen) #9

I just checked the software (BEFORE trashing it) to see whether, in fact, it was 7.3. And – YEP! It is!
OMG! I hope I can do this right.

I went to my applications folder and the application for Rapidweaver just says RapidWeaver7 on it. There is no Rapidweaver folder. If I trash the RapidWeaver application (that does not say .3 in the name of it) will the website I created with it still open in 2.2? Sometimes more recent software will NOT be able to be opened in older software. I have a large website with lots of pretty pictures on it and it took me about 6 weeks, 10 hours a day, or so, doing nothing else but this, to create. I don’t want to lose the site when I replace the application – or not be able to call it up. Is there anything I can do to guarantee that doesn’t happen? I have the actual site stored in a file named for the political organization (not named “RapidWeaver Projects” but RW still knows where to find its websites, even so. I know that usually you can trash an application and the files will remain, but I have had nothing but trouble from this site. It did publish perfectly under 7.0 (or a previous version that I downloaded several months ago.)


(David) #10

You can find the version of RW by clicking once (highligting) RW7.app and clicking on “get Info” in the “File” menu in the Finder window.

You will not have any problems opening up your existing project file(s) in RW 7.2.2

That being said always good to back up your projects just in case.

Once your project is open in RW 7.2.2 you probably will want to “republish all files”, but first test your publishing credentials in RW and make sure that all your info is correct and working. You can use 'browse" to find your upload folder on your host’s server.


(Ann Doneen) #11

Maybe I’ll just move the application (7.3) to the trash, but not empty the trash. I could reclaim it later if I had to open the website. If I had to re-create the website, at least I would have prototype pages to use as models. Or, possibly I could create the home page and then move over each individual page from one site to another. – Ooops. I see I’m getting a helpful hint at right saying I should consolidate my replies. So sorry! But I did not think of these things until it sunk in that I’m going to have to do this and could lose my precious site. The brain always works better after I’ve pressed “send.” Darn!


(David) #12

You can always re-download 7.3 if needed, or let RW update it, but yes you can also leave it in the trash.

Like i said, make back-ups of your project files just in case, but it is most unlikely that anything untoward will occur.

Now take a deep breath, relax and proceed. :sunglasses:


(Ann Doneen) #13

Thanks, David…I’m not sure what this line means. I’m publishing to Filezilla and have no problem findint the site there. But my host is Network Solutions. NS uses FZ as their publishing vehicle (sorry, I’m not techie enough to know the proper names for things. I just figure it out as I go with RW and do it. )


(Ann Doneen) #14

THANK YOU!!! ha, ha. Taking a deep breath! And proceeding now!


(David) #15

OK - thought you were publishing with RW. RW can publish your site as well, and it works fine for most people. It will work for any host as will any other FTP client providing your publishing credentials for your host are correct.

So if you can export your site locally and have had no problems with using FileZilla to publish to your host then all should be well. You can also try using RW 7.2.2 to publish. The “browse” button in RW’s publishing window just allows you to locate your upload folder on your server. Enter your credentials and try “test”.

Otherwise if you’re happy using FileZilla, that’s fine as well.


(Ann Doneen) #16

I’m not sure I understood you correctly . . . sometimes I overthink things. Let me try to clarify (if I don’t confuse you more with my amateur lingo). Before I downloaded 7.3 I was publishing a prototype version of the site so that the board of directors could review and change, etc. I did this by using the RW “Publishing Window” and just clicking “Publish.” Maybe that is what you mean when you say “publishing with RW.” I do see the “browse” option next to the Path Window. (and when I click it I get this: Failure when receiving data from the peer.) I was NOT able (so far) to publish to my desk top in order to drag the published file into Filezilla. But when I went into Filezilla I COULD SEE THE FILES in my own computer, locate the website (MalibuOpenSpace.org) and drag the edited pages across Filezilla’s chart into the published side with the hope of replacing the old page with the new page. As I said, that did NOT work when I went online to check to see whether it had published. You said, "if you can export your site locally . . . " But I tried that and I was not able to do that the first time I tried. I was just up for a cup of coffee and “to take my deep breath” (ha, ha), when I sat down and found this new note (and I"m SOOOO grateful for your help!). It sounds as though you think my server has a publishing (uh – what do I call it? vehicle? engine? facility?) similar to Filezilla but owned by the host. I do not think they do. Their clients all use Filezilla, as far as I can tell. I am not experienced enough at the publishing end of this (total of about 10 websites so far, but the first ones were with iWeb, which then folded, so I learned RW when that happened) to know if I’m “happy” with FZ. But I’m always very happy when a site actually publishes – a feat which seems to be a complete miracle to me! Love that RW’s 3rd party software makes such gorgeous sites. Okay. I’m not ready to do this. Thank you so much for helping! Technology is just so incredible! (The “ask for help and you get it asap” part of it. Here goes.)


(Ann Doneen) #17

NOW ready to do this, not “Not ready” . . .


(Ann Doneen) #18

One more thing: I did not know that RW had a “publisher” such as Filezilla. If it does, and if it’s easier to use, I should try it. You seemed to indicate that I would not need a host company (such as Network Solutions) to use the RW publisher. . . or maybe I misunderstood. I am in Malibu, California. RapidWeaver, as I understand it, is a British company and is pretty much located in England. So, I wonder about compatibility. I’ve never heard of any other publishers except for Filezilla. Thought that was the standard vehicle. Really going now – but wanted to save that thought or question or info/assumption or whatever it was. :blush:


(David) #19

OK - that’s a lot of stuff to reply to. I think you’re overthinking/analyzing and maybe further confusing yourself.

Btw, I’m near downtown LA and also use Spectrum. Don’t be worried about RMS being located in the UK - all this stuff works the same anywhere in the world.

I think you would benefit greatly by checking the Introductory RW Videos made by RMS:
https://rapidweavercommunity.com/tutorials/series/getting-started

Particularly this one on publishing:
https://rapidweavercommunity.com/tutorials/series/getting-started/episode/publishing-projects

I think this will answer a lot of your questions. If you have further questions after you’ve watched the video(s), perhaps we can take it from there?

There are many 3rd party FTP apps out there for Mac, including Transmit, Forklift, Yummy FTP, Fetch, etc. They all will work, and people have their favorites.

RW has it’s own publishing engine as well which you will learn about in the video.

You don’t ‘need’ a hosting company to publish. You need a hosting account to publish your files to.

There are several methods you can use:

  1. RW’s own publishing tool
  2. A third party FTP app
  3. or usually you can publish from your hosting account’s file manager which i think is usually located in C-Panel.

For the second two options you have to export your project locally and then upload the files to your hosting account.

OK - please watch the video!! :stuck_out_tongue_winking_eye:


(tomas nittner) #20

why don’t you export the site to a folder on your computer and then upload with cyberduck or filezilla to your server? i’ve been doing that for a long time. now with version #7.x i don’t seem to have the problem any longer!
greetings, tomas