RW 7.5.5 won't save, just spins - need to exit via Force Quit


(Stewart Duthie) #1

In the previous week have had issues saving, I have an 100 GB SSD for the OS, & around 60% is used nornally. After using RapidWeaver for 6-8 hours, it fills the SSD to capacity & I have to restart the computer, emptying the trash makes no difference, I have to restart, then the disk goes from 99.5% full to 60%. It is bloating the apps folder somewhere - can’t find where.

It has happened 10+ times.

Today on trying to save using 7.5.5, it won’t save, just gives me the spinning beach ball forever. the software interface is good - but it’s kind of bug ridden !! So, can’t continue & finish my site. Have tried restarting the MacPro 10+ times, make no difference.


(Rob D) #2

This topic has been discussed in the past. Please, type “temporary files” into search area.


(Buck) #3

I just came into the forum to ask this SAME question. I can make edits to my project but as soon as I attempt to save it in order to publish, the spinning beach ball pops up and the only remedy is using Force Quit. I’ve duplicated the file, restarted my MacBook Pro, but nothing has helped. At this point, I cannot publish any updates. I’m using Version 7.5.5 (18814) Please help!


(Stewart Duthie) #4

I search & I see it has been discussed - but I don’t see nor find a solution.

The initial issue was as described - it bloats the SSD.

The current issue is I cannot change/save anything at all. If I try to export the site it doesn’t work. If I try to save it it doesn’t work. If I try save as & use another name it doesn’t work.

I have slimmed the assets folder down to only the jpeg files I am using - this has reduced (GB to 3, & the .rw file is down from 9 to 1.9 GB. I have emptied the cache. I have removed RapidWeaver & reinstalled it - but I still cannot make any changes to the site.

It is frustrating - I have just spent a month & 100’s of hours building the site.

The other problem is I am not a super-techy type - some of the suggestions are like double-Dutch to me.


(scott williams) #5

Can you;
Open RW and create a brand new one page project and save it with no content?


(Stewart Duthie) #6

yes - without problem


(scott williams) #7

Okay, then something in the project has an issue. To find the issue, I would:

  1. start a new project
  2. drag the pages one at a time from your other project to the new one and publish (add one page publish, add another & publish…) until you find the page that is breaking things.
  3. once you have know which page is causing the issue, start a third project and add just the page with the issue. If it won’t publish with just that page (and I would bet it won’t) start removing things from the page until you find the culprit.

(Stewart Duthie) #8

OK - thanks. Will try, but it’s a lot of pages, maybe 200+, including sub-pages

How likely is it to be the one I was working on when the issues began yesterday ?

Will revert sometime…


(scott williams) #9

I would say it’s very likely to be one of the last few pages you modified assuming you haven’t done anything else like add a new plug-in or similar.


(Bill Fleming) #10

If it was me, I would do it backward.

Make a copy of the project and start deleting one by one in reverse order which you did when you build your RW page until the problem you were having disappear then go back to the original project file and delete that one item that to see if that was causing the problem all along.


(Stewart Duthie) #11

OK - thanks guys. I started transferring the files one by one from the existing project to the new project, but all the sidebar content was missing. As I have 200+ pages I didn’t fancy the idea of redoing everything.

Yesterday’s “impossible to save” was with one particular page I was on all day, it was the last page of the site, & I was doing a ton of photo-searching, cropping, collages, resizing, & then things started going wrong when I was trying to change border & shade colours in RW.

So today I went into timemachine & got out the saved project from lunchtime yesterday (the issues started late afternoon) & went from there. I reinstated it, deleted the page I was having issues with (or thought I was), redid it in a separate project to see if I could do it today (only the one page), it was fine, so I redid the page (tried dragging & dropping it but links & stuff were missing when i published it), published it & all is well now.

Pages published, able to save. What a pain in the but though (literally, haven’t moved out this chair in 9 hours) !! Ultimately, all I can say is it went wrong with 8 or 9 larger jpegs width wise (1500 pixels being inserted at 80%, but only 300 or less high) & with trying to change border & shade colours. That’s when it went really wonky.

Thanks again guys for chipping in.


(Buck) #12

I made a copy of the project and then, as you suggested, deleted one by one, the three changes (additions) I had made which seemed to cause this problem. Or to put it another way, this problem started after I made those three specific edits. Unfortunately, that did not correct the problem. As soon as I tried saving everything, I immediately got the spinning beach ball and had to use Force Quit. Does anyone have any other suggestions?


(system) #13

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.