RW 7 Update problem


(Lawrence Diggs) #1

I just updated to RW 7.4.1. When trying to open the site I got the prompt below. I continued but the site did not open. Now somehow the original RW file is not there, only all of the pages. How can I fix this and get RW to see all of the components associated with the files of the website?


(Lawrence Diggs) #2

Is it possible to download the site from the web an open it with RW?


(Lisa Sandler) #3

Only if you backed up your actual RW file. Did you do a search for the title of the RW file? I believe things were kept in a different place on RW 6 than RW7.


(Lawrence Diggs) #4

The file was not only backed up but published multiple times. When I tried to open what I believe was the file, it gave me some cryptic message that I noted above. I don’t know what file it wants or where to find it. When I try to open files wth the same name it acts like it there is no data. Apparently it can not find the “sandwich files”?


(Lisa Sandler) #5

Backing up and publishing are 2 different things. Backing up would mean making a copy of your RW file. You could do this via copying to a 2nd HD, setting RW to back up when you publish, or using Time Machine.
You cannot open a RW project without a RW file.

It was telling you that it was converting the old file to v 7. They have different extensions, so you would have been left with 2 separate files. Rw6 and 7.


(Lawrence Diggs) #6

Yes I know that. I mentioned it to underscored that it had been saved. If you are asking whether I made an additional copy. I believe so as my computer auto saves everything. My problem is that I don’t know what to look for since the files that have the same name as the one I want opens blank.

I was updating from RW 7.3 to 7.4.1. They don’t show the version numbers on the extensions.


(Robert Ziebol 🖖🏼) #7

If you were using RapidWeaver 5 or lower, the file would end with .rwsw, if you updated from RapidWeaver 6, it will end in .rw6. To look for your RapidWeaver 7 file, it will end with .rw


(Lawrence Diggs) #8

It seems to have worked itself out and now the file is back. However I still can not find the RW file. I even did a “save as”. All it saved was the attached screenshot. I don’t see anything with an RW7 extension. Where do I find that?


(Lisa Sandler) #9

What do you mean the “file” is back? But there is no RW file?

What you are showing looks like you “control-clicked” the RW sandwich file and opened the package contents.
Can you go back up one folder? Just hit the back arrow and you should be back to the RW file.


(Lawrence Diggs) #10

When I clicked on the projects tab and selected the website before, it would not open. Two days of trying various nothing more than cryptic messages. I was searching for the rw7 extension to try and open it from there. I could not find anything with an rw7 extension.

Now it opened from inside RW7, but I still can not find anything with an RW7 extension. I found the package. I had found that before. But there is nothing in the package that has RW7 or that I can click to open the website.

I figure it must be somewhere, but I can’t find it.


(Lisa Sandler) #11

You don’t open the package. That is my point. And the RW 7 extension is .rw.


(Lisa Sandler) #12

These are what your RW files look like. They are no different than any other file saved on your Hard Drive.


(scott williams) #13

This package IS the .rw file. you don’t right click and open it.

DiggsWorld 2016_b is the actual project file. (.rw)


(Doug Bennett) #14

Also might want to check out this post about using finder to find project files.