RW 8.01 and ECWID plugin

Seem to be having a problem with the ECWID plugin. When trying to reconnect to an existing store, it crashed RW 8 out completely.

Anyone have the same issue. Tried recreating the page, and get the same problem, even from a blank new RW project.


Looking into this now, and will make Ecwid aware of the issue as it may be a problem with their plugin.

Have you tried contacting them?

On it Dan, thanks

Reported to ECWID @dan

Great, hopefully we’ll get this resolved quickly.

In the meantime, there are other ways to integrate Ecwid into RapidWeaver, check out the tutorials further down the page, especially part 3, as thi shows how to use Stacks with Ecwid :slight_smile:

1 Like

Just a quick note. Cartloom fully designed pages and checkout and work perfect in RapidWeaver 8. Here’s a quick video on how easily you can setup Cartloom products in RapidWeaver:


Hey guys,

Matt from Ecwid here.

Thanks for reporting. We’re looking into the issue.

1 Like

Hi Matt,

I reported it to one of your team last night through the chat function on your site. There should be a record of the setup I’m using to help


Hi Nick, I already use Cartloom on another site


Looking forward to a release that supports SEO? :slight_smile:

Still love it!

Got it! Thanks for letting me know.

Only our product embed method use iframes, but with our iframe pages we embed json+LD product info in the page head for SEO. This is the same method that Wista uses to maintain SEO for their video embeds.

All that said, we also offer Buy buttons, Quick buy, and Advanced snippets, so that you can bring your own custom product information/SEO.

Hi Nick,

Thats what we do…use your snippets!! :grinning:

Hey @SimonPalmer ,

Can you let me know the following

  1. The version of Ecwid addon installed on your RapidWeaver. You can find the version this way: click the Addons icon in the editor, click “Ecwid” in the list, find the version in the “Online Store” line. Screenshot:

  2. MacOS version

That will help us a lot.


Hi @makfruit (Matt), Sara B in your support group has a case open on this. Currently the version is 1.02 of your add-on. I’m using Mojave, but this morning updated to 18A371a. However, it was the last three betas that have had the problem.

Now, interestingly, I’ve just gone through the process of adding a store to a new project using last nights beta release of Mojave. Instead of trying to reconnect and crashing, it allowed me to connect, and then reconnect without a problem (yippee).

So the issue has been resolved with an update of the Mojave beta. I’ll let your support folks know as well to close the case.

Thanks again for being so responsive!

1 Like

Thank you! Please let us know if you face this trouble again — we’ll have a look.
And thanks for sharing the OS details, that will help a lot.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.