RW 8 Not Recognizing Stacks 4 upgrade - SOLVED!

Here is a grab of what I am seeing when I try to add a Stacks page:

when I launch RW8 I get a pane noting that some upgrades did not load. I click that and then I get another pane noting that RW ‘unexpectedly quit’ and round and round I go until it finally loads.

My version of Stacks 4 is paid for, so that is not the issue.

Any help will be appreciated.

A screenshot of what that says would probably be helpful.

You can always install Stacks4 again, you will need the licence key. Just click on the free download:
YourHead Software

Here is what I see immediately after launching RW8


Thanks! I will try that.

Did you udate your macOS?

You can goto the same link above and get the latest version of sitmap from yourhead.

Just downloaded and drug Stacks4 to RW8 and got this:

After clicking ‘Update Plugins’ I get the following:

Just downloaded RW8 and installed and got the very same result.

Will restart my iMac.

After restarting my iMac and relaunching RW8 - same result:

Did you update macOS, or what?

Sorry, I am running V10.15.7

Now upgrading to Big Sur …

Will see how this works in a hour or so …

Those “Not codesigned messages” are usally because you upgradedg macOS 10.15.x or greater. Apple desided to protect you from stuff that has been running for years.

Big Sur won’t help! Apple is locking things more with each update

You need to upgrade all plugins to the latest version. If they are older ones, they won’t work. If they are no longer supported, you will need to delete them.

:fire: RapidWeaver 8.4 and macOS Catalina Plugin Compatibility - RapidWeaver / Announcements - RapidWeaver Support Forum (

OK! I stopped the Big Sur upgrade.

I have just reinstalled the latest version of RW v8.8.3 and Isaiah’s Stacks 4 version and still no luck.

Are you still getting the message about sitemap?

You can get the latest version of sitemap from the yourhead site (same as stacks)

You can also quite RW and the start it will holding the ⌥Opt key.

You should get a screen that allows you to start RW without 3rd party plugins. That will allow you to getin and find what plugins you have installed and remove them (if you aren’t using them) or find updates for them.

This was more an Apple thing, with Catalina they started locking things up.

@chicago Hopefully @teefers suggestions will help. (I have no idea what’s happening to you, unfortunately). I’m tagging @isaiah : since he is the developer for Stacks and Sitemap he might have some extra suggestions that will help you out of this quagmire.

I held down option and relaunched RW8, deselected ‘Enable Third-Party Plugins’ and got the very same result when I clicked on the Add button.

No change whatsoever.

And I did download the very latest version of Stacks 4. Again no change.

Thanks Mathew. I appreciate the help.

I cannot help but laugh after just purchasing Foundry and now I can’t even get RW8 to work properly. My luck.

So, to be crystal clear:

(1) I have reinstalled RW 8
(2) I have re-downloaded Stacks 4
(3) I have restarted my iMac

and I still see the following

And running MacOS Catalina

The error messages you posted indicates an issue with SiteMap, as Doug (@teefers ) pointed out. You need to update that plugin. Like Stacks, it’s also made by YourHead Software. You need to download and install the latest version of that plugin. Have you done that?

1 Like