RW 8. Problems, stacks gone


(Paul Hastings) #1

Hi. I have a glitch.
I use a mac fully updated.
I use rapid weaver eight fully updated.
I use stacks fully updated.
I have cleaned my mac, updated all the programs on my mac.
Cleaned all my browsers. Cleared history. Even gone into my web hosting and cleaned my catch and super catch.

I use site ground. I have also re-fragged my mac hard drive and fixed all systems. Run apple maintenance scripts, and all that stuff. I have updated all plugins if Rapid Weaver updates work as they should.

I still have a glitch.
This morning, I restarted Rapid Weaver to continue working on an active site that I have changed and made changes to. All worked until two days ago.

Rapid Weaver told me.
The stack is, not currently installed. You need to reinstall it to use it.

I contacted stacks guy. He suggested re-installing Rapid Weaver 8.
I did this.
I also re-downloaded his stacks.

Was suggested I contact Rapid Weaver.

Until a day or so ago. Rapid Weaver worked.

Now, when I open to continue working on a project, website.
All stacks have disappeared.
Any advice?

By the way.
When scanning my mac, it can not find the stacks file?

Paul.


(Isaiah Carew) #2

It sounds to me like RapidWeaver is having trouble finding your addons, or the Stacks plugin, or the stacks themselves. Or perhaps you have some old addons installed that are causing issues. I’d recommend a look through your addons folder:

  • Open Your Addons Folder
    From inside RapidWeaver choose: Reveal Addons Folder from the View menu. Once the addons folder is open, Quit RapidWeaver.
    Use this method to open the addons folder: Every version of RapidWeaver has a unique addons folder location – and each can be customized – so it can be difficult to be 100% sure which addons folder is the right one. Using RapidWeaver to open the addons folder ensures that the one that RapidWeaver is currently using is the one that you open.

  • Remove Unused Addons
    Remove any addons that you’re not currently using. Addons can change the way RapidWeaver works whenever they’re installed, even if they’re not currently in use. So if you’re not using some, remove them.

  • Remove Questionable Addons
    If you’re not sure whether an addon is RapidWeaver 8 compatible, then remove it – at least temporarily. You can always add it back later once you get things working again.

  • Reinstall Stacks.
    You can download a fresh copy here: http://yourhead.com/stacks Once downloaded and unzipped just drag it right into the addons folder.

  • Check your Stacks folder.
    Inside the addons folder is a folder called Stacks. All of the 3rd party stacks you’ve installed should be inside. If they’re not, then you may want to retrieve them from your RapidWeaver 7 addons folder.

If things are still not working, please post a few more pieces of info to help us debug:

  • The macOS version
  • The Stacks version
  • The error message you see

I know you said you have “fully updated” Stacks and Mac, but macOS is currently in beta so “fully updated” can have 3 distinct meanings: current release version, current developer beta, and current public beta. All are quite different. You can find the version number of macOS in the About This Mac in the Apple menu.

And to a lesser degree the same applies to Stacks since there is almost always a beta release of available as well as the main release. The versions are not radically dissimilar, but are different enough that it’s helpful to have the specific version numbers. You can find the version number of Stacks that you’re using by open the addons window in RapidWeaver 8. It should look something like this:


(Paul Hastings) #3

Thank you for takeing the time to run me through this.
I will attempt doing what you advised.


(Paul Hastings) #4

Thank you.


(Paul Hastings) #5

I seem to be having a glitch with rapid weaver latest version. Version 8.0.3 (20142)
I have posted before and have done all the things I was advised to do.
I have made sure I have the latest version of mac. Gone to there site and downloaded. I have manually updated stacks, see last post and reply.

I have updated the latest stacks and contacted the other stuff I use to get there latest updates. And if I don’t use them deleted them.

By the way, rapid weaver your stacks update thing should work or just don’t include it. Don’t sell it if it does not work. Don’t say automatic stacks and programs updates if you know it does not work. As you do.

Sorry guys I am simplifying my websites and going for rapid weaver themes with little or no other stuff. That way won’t get bounced around with not our fault, contact x. Now contact y. now contact s. now do this, now do that, now contact server, now pray. Now dos. T. Now go to the server. It all worked well before the upgrade.

Guess what. All was fine before the upgrade. So what is the one constant? The upgrade.

My ego does not need to make a good template individual with lots of glitches, so rebuilding my three main websites with just basic stuff, that rapid weaver 8 says works, but it does not at the moment just seems simpler, and if it does not work. I have a lot more clout.

Basic stuff you said would work. So make it work. Nothing fancy added. Just your basic programme. You sold it to me. I paid. you said it works. It does not. You took my money. You fix it. Very simple. You can’t blame the third party add-ons as you recommended them and would have tested them in order not to allow them to damage your reputation.
Or I just don’t use them.

I have deleted all old unused stacks and rapidly approved templates. In order to reduce the problems. I just want a website to work and bring in the income.

I have a few glitches after doing all I have been advised to do both publicly on this site and privately. At the moment I have three glitches.

O. and by the way I have also spent hours of my life with my hosting server siteground who have checked all the stuff and advised me to do lots of things that really scared me.

You sold me on rapid weaver being simple and easy, so why have I been asked, now by you to learn HTML and use a third party htmp uploader and go into my host HTML server thing and remove HTML, now that you advise PHP or whatever it is.

This is not simple and easy and basic. Please rewrite your sales pitch. but I did so that I could come back to rapid weaver and say. No, it’s you.

  1. I now get messages advising me I have. Html and PHP files on my site and I have to go into an HTTP thing and make HTML or serious changes on the host stuff. All frightening, why do I have to do this rapid weaver?
    This only happened on the upgrade, you should cover this stuff.

  2. Stacks and addon seem to be disappearing.
    I have paid for two stacks.
    Eric Boo.
    Seo stack disappeared. he sent me the download link went through the process.
    Still, can’t use the stack can’t even find it.

I have a few youtube videos on my other sites that are active.
Have just attempted to place another youtube video on another one of my sites.

Guess what. That stack has disappeared as well.
Can’t find it.
I bought it. I have it active on this site and other sites I have.
But now when I attempt to use it .againe.
It has disappeared.

Rapid weaver help.


(Doug Bennett) #6

Any reason you have posted this twice?


Sorry to hear you’re having problems.

I’m having difficulty determining what exactly the problem you’re having.

What problem are you having with the stacks update? It’s working fine for most of us, but if you’re having a problem then it would be help if could give a bit more details on exactly what’s happening. Is it crashing?

I would doubt the upgrade had anything to do with putting out a PHP file as well as an html file. You didn’t say what version you upgraded from? If it was pre RW7 than the message didn’t exist. But more than likely a stack you’re using requires PHP and changed the extension automatically. RapidWeaver is a non destructive application and won’t delete files on the server. You’ll need to that manually, it’s not much different than deleting a file on your Mac.

As for the missing stacks after you upgraded, RW8 copied the addons folder to a new location. So the old folder is still on your hard drive. If you give the old version number of RapidWeaver someone can help you find them and copy them over.


(Paul Hastings) #7

yes, new to this kind of glitch and not yet used to how forum works, thank you for pointing this out to me.


(system) #8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.